source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 615

Revision 615, 13.7 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define name    mplayer
2%define version 1.0
3#%%define extver        %{nil}
4%define extver  rc2
5#% define release       4%{?extver:.%{extver}}%{?_dist_release}
6%define svndate  20100317
7%define release 31.%{svndate}%{?_dist_release}
8
9%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
10%define ttfontdir   /usr/share/fonts
11%define ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
12                    TrueType-sazanami-gothic/sazanami-gothic
13%endif
14%if %{?_dist_release} == "vl4"
15%define ttfontdir   /usr/X11R6/lib/X11/fonts/TrueType
16%define ttfontlist  VL-PGothic-Regular ipagp sazanami-gothic luxirr
17%endif
18
19Summary:        The Movie Player
20Summary(ja):    動画プレイヤー
21Name:           %{name}
22Version:        %{version}
23Release:        %{release}
24#Source0:       http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
25Source0:        mplayer-export-%{svndate}.tar.bz2
26Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
27Source10:       mplayer-snapshot.sh
28Patch2:         %{name}-config.patch
29Patch8:         %{name}-manlinks.patch
30Patch10:        %{name}-qcelp.patch
31Patch14:        %{name}-nodvdcss.patch
32
33License:        GPLv2+
34Group:          Applications/Multimedia
35URL:            http://www.mplayerhq.hu/
36
37BuildRequires:  gtk2-devel
38BuildRequires:  freetype2-devel
39BuildRequires:  SDL-devel
40BuildRequires:  alsa-lib-devel
41BuildRequires:  esound-devel
42BuildRequires:  cdparanoia-devel
43BuildRequires:  libvorbis-devel
44BuildRequires:  libjpeg-devel
45BuildRequires:  libpng-devel
46BuildRequires:  giflib-devel
47BuildRequires:  zlib-devel
48BuildRequires:  libdvdread
49BuildRequires:  libmpcdec-devel
50BuildRequires:  twolame-devel
51BuildRequires:  yasm
52BuildRequires:  libvdpau-devel
53BuildRequires:  libXScrnSaver-devel
54# *-devel packages provided by other self-build-* should only be listed
55# in self-build-%{name}.spec as PreReq.
56##Requires:     self-build-mplayer-codecs
57##BuildRequires:        self-build-libdvdcss
58##BuildRequires:        self-build-libdvdnav
59##BuildRequires:  self-build-faac
60##BuildRequires:  self-build-lame
61##BuildRequires:  self-build-libdca
62##BuildRequires:  self-build-x264 >= 0.0.0-4.20090110
63##BuildRequires:  self-build-xvidcore >= 0.9.2
64##BuildRequires:  self-build-faad2 >= 2.6
65##BuildRequires:  self-build-libmad
66Requires:       TrueType-vlgothic
67%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
68Requires:       mesa-libGL
69BuildRequires:  xorg-x11-devel
70BuildRequires:  mesa-libGL-devel
71%endif
72%if %{?_dist_release} == "vl4"
73Requires:       XOrg-gl
74BuildRequires:  XOrg-devel
75BuildRequires:  XOrg-gl-devel
76%endif
77BuildRoot:      %{_tmppath}/%{name}-%{version}-root
78
79
80%description
81MPlayer can play most standard video formats out of the box and almost
82all others with the help of external codecs.
83MPlayer currently works best from the command line, but visual feedback
84for many functions is available from its onscreen status display (OSD),
85which is also used for displaying subtitles.
86MPlayer also has a GUI with skin support and several unofficial alternative
87graphical frontends are available.
88
89MEncoder is a command line video encoder for advanced users that can
90be built from the MPlayer source tree. Unofficial graphical frontends
91exist but arenot included.
92
93MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
94support for some newer codecs are not yet inpmlemented.
95You should install mplayer-codecs package if you want to play videos
96using those new codecs.
97
98%description -l ja
99MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
100またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
101で生できます。
102現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
103は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
104面上で確認できます。
105MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
106非公式なフロントエンドも利用できます。
107
108MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
109非公式な GUI フロントエンドもありますが、このパッケージには含まれて
110いません。
111
112MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
113を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
114いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
115をインストールする必要があります。
116
117
118%prep
119#% setup -q -n MPlayer-%{version}%{extver}
120%setup -q -n mplayer-export-%{svndate}
121
122%patch2 -p1 -b .config
123%patch8 -p1 -b .manlinks
124%patch10 -p1 -b .qclp
125%patch14 -p1 -b .nodvdcss
126
127%build
128./configure \
129    --prefix=%{_prefix} \
130    --confdir=%{_sysconfdir}/mplayer \
131    --enable-runtime-cpudetection \
132    --extra-cflags="$RPM_OPT_FLAGS" \
133    --disable-libdvdcss-internal \
134    --disable-dvdread-internal \
135    --enable-dvdread \
136    --enable-dvdnav \
137    \
138    --disable-faac-lavc \
139    --disable-mp3lame-lavc \
140    --disable-x264-lavc \
141    \
142    --disable-faad-internal \
143    \
144    --disable-libopenjpeg \
145    \
146    --disable-bitmap-font \
147    --disable-termcap \
148    --enable-xvmc \
149    --with-xvmclib=XvMCW \
150    \
151    --enable-largefiles \
152    --enable-menu \
153    --enable-gui \
154    --language=ja,en \
155    ;
156
157%{__make} %{?_smp_mflags}
158
159%install
160%{__rm} -rf ${RPM_BUILD_ROOT}
161%{__make} install prefix=${RPM_BUILD_ROOT}%{_prefix} \
162                  BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
163                  DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
164                  CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
165                  LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
166                  MANDIR=${RPM_BUILD_ROOT}%{_mandir}
167
168## install some default config files
169%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
170%{__install} -pm 644 etc/example.conf \
171    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
172%{__install} -pm 644 etc/{input,menu,codecs}.conf \
173    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
174
175# install default skin
176%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
177pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
178%{__tar} xjf %{SOURCE1}
179%{__ln_s} Blue default
180popd
181
182# make sybolic link to ttf font for subtitle
183for i in %{ttfontlist}; do
184    if [ -e %{ttfontdir}/$i.ttf ];then
185        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
186        break;
187    fi;
188done
189
190## install TOOLS
191for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
192%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
193done
194
195for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
196%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
197done
198
199for file in vobshift.py ; do
200%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
201done
202
203%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
204%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
205
206
207%clean
208%{__rm} -rf ${RPM_BUILD_ROOT}
209
210
211%files
212%defattr(-,root,root)
213%doc AUTHORS Changelog Copyright LICENSE README
214%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
215%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
216%config(noreplace) %{_sysconfdir}/mplayer/input.conf
217%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
218%{_bindir}/mplayer
219%{_bindir}/gmplayer
220%{_bindir}/mencoder
221%{_datadir}/mplayer/skins/Blue
222%{_datadir}/mplayer/skins/default
223%{_datadir}/mplayer/subfont.ttf
224%{_datadir}/applications/mplayer.desktop
225%{_datadir}/pixmaps/mplayer.xpm
226%{_mandir}/man1/mplayer.1*
227%{_mandir}/man1/mencoder.1*
228## TOOLS
229%{_bindir}/aconvert
230%{_bindir}/calcbpp
231%{_bindir}/countquant
232%{_bindir}/divx2svcd
233%{_bindir}/dvd2divxscript
234%{_bindir}/mencvcd
235%{_bindir}/midentify
236%{_bindir}/mpconsole
237%{_bindir}/qepdvcd
238%{_bindir}/subsearch
239%{_bindir}/vobshift
240%{_datadir}/mplayer/*.fp
241
242
243%changelog
244* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
245- updated source snapshot 20100317
246
247* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
248- updated source snapshot 20100216
249- moved scripts from TOOLS
250- added --disable-libopenjpeg in configure options
251
252* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
253- updated source snapshot 20100201
254- dropped obsolete patches
255- added BuildRequires:
256  - libvdpau-devel
257  - libXScrnSaver-devel
258
259* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
260- update mplayer-config-20091215-vine.patch
261- update mplayer-20091215-x86_32-compile.patch
262- added --enable-runtime-cpudetection in configure options
263
264* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
265- source snapshot 20091031
266  - updated mplayer-20091031-x86_32-compile.patch
267
268* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
269- source snapshot 20091003
270
271* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
272- change release to sync with self-build-mplayer
273
274* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
275- source snapshot 20090905
276- added settings for vl6
277
278* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
279- source snapshot 20090821
280- replaced BR: libungif-devel with BR: giflib-devel
281
282* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
283- source snapshot 20090722
284
285* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
286- source snapshot 20090702
287
288* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
289- source snapshot 20090611
290
291* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
292- added Requires: TrueType-vlgothic
293
294* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
295- source snapshot 20090522
296  - build with x264 >= 0.0.0-9.20090522
297  - updated mplayer-20090522-nodvdcss.patch
298
299* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
300- change release to sync with self-build-mplayer
301
302* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
303- source snapshot 20090502
304- updated mplayer-20090503-x86_32-compile.patch
305- updated mplayer-20090502-nodvdcss.patch
306
307* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
308- applied mplayer-config-vine.patch
309
310* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
311- source snapshot 20090327
312- updated mplayer-20090327-x86_32-compile.patch
313- updated mplayer-20090325-nodvdcss.patch
314- dropped gmplayer-about-vine.patch
315- install some default config files
316- added configure options:
317  - --disable-termcap
318  - --enable-xvmc
319  - --with-xvmclib=XvMCW
320- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
321- fixed %%files for *.conf
322
323* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
324- source snapshot 20090305
325
326* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
327- source snapshot 20090227
328
329* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
330- source snapshot 20090216
331
332* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
333- source snapshot 20090206
334- dropped mplayer-man-zh_CN.patch
335- updated mplayer-20090206-nodvdcss.patch
336- changed to PreReq:  self-build-faad2 from faad2-devel
337- added PreReq:  self-build-libmad
338
339* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
340- source snapshot 20090131
341
342* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
343- change release to sync with self-build-mplayer
344
345* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
346- source snapshot
347- update mplayer-20090122-nodvdcss.patch
348- added BuildRequires:
349  - faad2-devel
350  - libmpcdec-devel
351  - twolame-devel
352  - yasm
353  - faac-devel (as PreReq in self-build-%{name})
354  - lame-devel (as PreReq in self-build-%{name})
355  - libdca-devel (as PreReq in self-build-%{name})
356  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
357  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
358
359* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
360- source snapshot
361- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
362  --disable-faad-internal in configure options
363- dropped gmplayer-add-flv-extension.patch
364
365* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
366- source snapshot
367- fixed License
368- added some patches from RPM Fusion
369- updated gmplayer-about-vine.patch for 20081001 snapshot
370- added BuildRequires:  libdvdread
371- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
372- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
373  in configure options
374#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
375
376* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
377- fixed License
378- added some devel packages to support OpenGL
379
380* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
381- spec in utf8
382- fix sybolic link of subfont for vl5
383
384* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
385- add "Patch105: CVE-2008-1558.patch".
386
387* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
388- build with new versioning policy.
389- fix Source[01] URLs.
390- add "Patch200: gmplayer-about-vine.patch".
391- add "Patch201: gmplayer-add-flv-extension.patch".
392
393* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
394- add four official security patches (CVE-2008-0485, CVE-2008-0486,
395  CVE-2008-0629, CVE-2008-0630)
396- add mplayer-1.0rc2-20080211-stream_cddb.patch
397
398* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
399- change source download URL. <BTS:VineLinux:603>
400
401* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
402- fix CONFDIR for make install. <BTS:wishes:33>
403
404* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
405- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.