source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 2621

Revision 2621, 15.2 KB checked in by munepi, 13 years ago (diff)

updated self-build-mplayer: added some BuildRequires?

Line 
1%define with_vaapi 1
2%define with_libvpx 1
3
4%define name    mplayer
5%define version 1.0
6%define extver  rc3
7#% define release       4%{?extver:.%{extver}}%{?_dist_release}
8%define svndate  20100709
9%define release 40.%{svndate}%{?_dist_release}
10
11%define ttfontdir   /usr/share/fonts
12%define ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
13                    TrueType-sazanami-gothic/sazanami-gothic
14
15Summary:        The Movie Player
16Summary(ja):    動画プレイヤー
17Name:           %{name}
18Version:        %{version}
19Release:        %{release}
20#Source0:       http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
21Source0:        mplayer-export-%{svndate}.tar.bz2
22Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
23Source10:       mplayer-snapshot-vine.sh
24#Patch2:         %{name}-config.patch
25Patch2:         %{name}-config-20100709-vine.patch
26Patch8:         %{name}-manlinks.patch
27Patch14:        %{name}-nodvdcss.patch
28
29## Vine
30Patch50:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
31
32License:        GPLv2+
33Group:          Applications/Multimedia
34URL:            http://www.mplayerhq.hu/
35
36BuildRequires:  SDL-devel
37BuildRequires:  aalib-devel
38BuildRequires:  alsa-lib-devel
39BuildRequires:  cdparanoia-devel
40BuildRequires:  desktop-file-utils
41BuildRequires:  esound-devel
42BuildRequires:  enca-devel
43BuildRequires:  freetype2-devel
44BuildRequires:  fribidi-devel
45BuildRequires:  fontconfig-devel
46BuildRequires:  giflib-devel
47BuildRequires:  gtk2-devel
48BuildRequires:  mesa-libGL-devel
49BuildRequires:  libXinerama-devel
50BuildRequires:  libXScrnSaver-devel
51BuildRequires:  libXv-devel
52BuildRequires:  libXvMC-devel
53BuildRequires:  libXxf86dga-devel
54BuildRequires:  libXxf86vm-devel
55BuildRequires:  libpng-devel
56BuildRequires:  libjpeg-devel
57BuildRequires:  libdvdread
58BuildRequires:  libmpcdec-devel
59%{?with_vaapi:BuildRequires:libva-devel}
60BuildRequires:  libvdpau-devel
61BuildRequires:  libvorbis-devel
62%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
63BuildRequires:  lzo-devel >= 2
64BuildRequires:  pulseaudio-lib-devel
65BuildRequires:  speex-devel >= 1.1
66BuildRequires:  twolame-devel
67BuildRequires:  xorg-x11-devel
68BuildRequires:  yasm
69BuildRequires:  zlib-devel
70
71# *-devel packages provided by other self-build-* should only be listed
72# in self-build-%{name}.spec as PreReq.
73##Requires:     self-build-mplayer-codecs
74##BuildRequires:        self-build-libdvdcss
75##BuildRequires:        self-build-libdvdnav
76##BuildRequires:  self-build-faac
77##BuildRequires:  self-build-lame
78##BuildRequires:  self-build-libdca
79##BuildRequires:  self-build-x264 >= 0.0.0-4.20090110
80##BuildRequires:  self-build-xvidcore >= 0.9.2
81##BuildRequires:  self-build-faad2 >= 2.6
82##BuildRequires:  self-build-libmad
83##BuildRequires:  self-build-libmpeg2
84
85Requires:       TrueType-vlgothic
86Requires:       mesa-libGL
87
88BuildRoot:      %{_tmppath}/%{name}-%{version}-root
89
90
91%description
92MPlayer can play most standard video formats out of the box and almost
93all others with the help of external codecs.
94MPlayer currently works best from the command line, but visual feedback
95for many functions is available from its onscreen status display (OSD),
96which is also used for displaying subtitles.
97MPlayer also has a GUI with skin support and several unofficial alternative
98graphical frontends are available.
99
100MEncoder is a command line video encoder for advanced users that can
101be built from the MPlayer source tree. Unofficial graphical frontends
102exist but arenot included.
103
104MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
105support for some newer codecs are not yet inpmlemented.
106You should install mplayer-codecs package if you want to play videos
107using those new codecs.
108
109%description -l ja
110MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
111またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
112現在の MPlayer はコマンドラインから使うのが一番便利ですが、
113多くの操作は字幕と同様に、
114オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
115MPlayer には スキンを変更できる GUI も用意されていますし、
116また複数の非公式なフロントエンドも利用できます。
117
118MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
119非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
120
121MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
122を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
123いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
124をインストールする必要があります。
125
126
127%prep
128#% setup -q -n MPlayer-%{version}%{extver}
129%setup -q -n mplayer-export-%{svndate}
130
131%patch2 -p1 -b .config
132%patch8 -p1 -b .manlinks
133%patch14 -p1 -b .nodvdcss
134
135%patch50 -p1 -b .x11
136
137%build
138./configure \
139    --prefix=%{_prefix} \
140    --confdir=%{_sysconfdir}/mplayer \
141    --enable-runtime-cpudetection \
142    --extra-cflags="$RPM_OPT_FLAGS" \
143    --disable-libdvdcss-internal \
144    --disable-dvdread-internal \
145    --enable-dvdread \
146    --enable-dvdnav \
147    \
148    --disable-faac-lavc \
149    --disable-mp3lame-lavc \
150    --disable-x264-lavc \
151    \
152    --disable-faad-internal \
153    \
154    --disable-libopenjpeg \
155    \
156    --disable-bitmap-font \
157    --disable-termcap \
158    --enable-xvmc \
159    --with-xvmclib=XvMCW \
160    \
161    --enable-largefiles \
162    --enable-menu \
163    --enable-gui \
164    --language=ja,en \
165    ;
166
167%{__make} %{?_smp_mflags}
168
169%install
170%{__rm} -rf ${RPM_BUILD_ROOT}
171%{__make} install INSTALLSTRIP= \
172    prefix=${RPM_BUILD_ROOT}%{_prefix} \
173    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
174    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
175    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
176    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
177    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
178    ;
179
180## install some default config files
181%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
182%{__install} -pm 644 etc/example.conf \
183    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
184%{__install} -pm 644 etc/{input,menu,codecs}.conf \
185    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
186
187# install default skin
188%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
189pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
190%{__tar} xjf %{SOURCE1}
191%{__ln_s} Blue default
192popd
193
194# make sybolic link to ttf font for subtitle
195for i in %{ttfontlist}; do
196    if [ -e %{ttfontdir}/$i.ttf ];then
197        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
198        break;
199    fi;
200done
201
202## install TOOLS
203for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
204%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
205done
206
207for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
208%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
209done
210
211for file in vobshift.py ; do
212%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
213done
214
215%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
216%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
217
218
219%clean
220%{__rm} -rf ${RPM_BUILD_ROOT}
221
222
223%files
224%defattr(-,root,root)
225%doc AUTHORS Changelog Copyright LICENSE README
226%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
227%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
228%config(noreplace) %{_sysconfdir}/mplayer/input.conf
229%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
230%{_bindir}/mplayer
231%{_bindir}/gmplayer
232%{_bindir}/mencoder
233%{_datadir}/mplayer/skins/Blue
234%{_datadir}/mplayer/skins/default
235%{_datadir}/mplayer/subfont.ttf
236%{_datadir}/applications/mplayer.desktop
237%{_datadir}/pixmaps/mplayer.xpm
238%{_mandir}/man1/mplayer.1*
239%{_mandir}/man1/mencoder.1*
240## TOOLS
241%{_bindir}/aconvert
242%{_bindir}/calcbpp
243%{_bindir}/countquant
244%{_bindir}/divx2svcd
245%{_bindir}/dvd2divxscript
246%{_bindir}/mencvcd
247%{_bindir}/midentify
248%{_bindir}/mpconsole
249%{_bindir}/qepdvcd
250%{_bindir}/subsearch
251%{_bindir}/vobshift
252%{_datadir}/mplayer/*.fp
253
254
255%changelog
256* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
257- added BuildRequires:
258  - aalib-devel
259  - enca-devel
260  - lzo-devel
261  - speex-devel
262
263* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
264- updated fixed %{name}-config.patch
265  - applied %{name}-config-20100709-vine.patch
266
267* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
268- change release to sync with self-build-mplayer
269
270* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
271- updated source snapshot 20100709
272- renamed %%Source10 to mplayer-snapshot-vine.sh
273- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
274- added BuildRequires: libvpx-devel >= 0.9.1
275
276* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
277- updated source snapshot 20100621
278
279* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
280- updated source snapshot 20100615
281- added BuildRequires: libXinerama-devel
282- dropped vl4 support
283
284* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
285- updated source snapshot 20100410
286
287* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
288- updated source snapshot 20100401
289
290* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
291- updated source snapshot 20100326
292
293* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
294- updated source snapshot 20100317
295
296* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
297- updated source snapshot 20100216
298- moved scripts from TOOLS
299- added --disable-libopenjpeg in configure options
300
301* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
302- updated source snapshot 20100201
303- dropped obsolete patches
304- added BuildRequires:
305  - libvdpau-devel
306  - libXScrnSaver-devel
307
308* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
309- update mplayer-config-20091215-vine.patch
310- update mplayer-20091215-x86_32-compile.patch
311- added --enable-runtime-cpudetection in configure options
312
313* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
314- source snapshot 20091031
315  - updated mplayer-20091031-x86_32-compile.patch
316
317* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
318- source snapshot 20091003
319
320* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
321- change release to sync with self-build-mplayer
322
323* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
324- source snapshot 20090905
325- added settings for vl6
326
327* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
328- source snapshot 20090821
329- replaced BR: libungif-devel with BR: giflib-devel
330
331* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
332- source snapshot 20090722
333
334* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
335- source snapshot 20090702
336
337* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
338- source snapshot 20090611
339
340* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
341- added Requires: TrueType-vlgothic
342
343* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
344- source snapshot 20090522
345  - build with x264 >= 0.0.0-9.20090522
346  - updated mplayer-20090522-nodvdcss.patch
347
348* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
349- change release to sync with self-build-mplayer
350
351* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
352- source snapshot 20090502
353- updated mplayer-20090503-x86_32-compile.patch
354- updated mplayer-20090502-nodvdcss.patch
355
356* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
357- applied mplayer-config-vine.patch
358
359* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
360- source snapshot 20090327
361- updated mplayer-20090327-x86_32-compile.patch
362- updated mplayer-20090325-nodvdcss.patch
363- dropped gmplayer-about-vine.patch
364- install some default config files
365- added configure options:
366  - --disable-termcap
367  - --enable-xvmc
368  - --with-xvmclib=XvMCW
369- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
370- fixed %%files for *.conf
371
372* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
373- source snapshot 20090305
374
375* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
376- source snapshot 20090227
377
378* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
379- source snapshot 20090216
380
381* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
382- source snapshot 20090206
383- dropped mplayer-man-zh_CN.patch
384- updated mplayer-20090206-nodvdcss.patch
385- changed to PreReq:  self-build-faad2 from faad2-devel
386- added PreReq:  self-build-libmad
387
388* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
389- source snapshot 20090131
390
391* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
392- change release to sync with self-build-mplayer
393
394* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
395- source snapshot
396- update mplayer-20090122-nodvdcss.patch
397- added BuildRequires:
398  - faad2-devel
399  - libmpcdec-devel
400  - twolame-devel
401  - yasm
402  - faac-devel (as PreReq in self-build-%{name})
403  - lame-devel (as PreReq in self-build-%{name})
404  - libdca-devel (as PreReq in self-build-%{name})
405  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
406  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
407
408* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
409- source snapshot
410- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
411  --disable-faad-internal in configure options
412- dropped gmplayer-add-flv-extension.patch
413
414* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
415- source snapshot
416- fixed License
417- added some patches from RPM Fusion
418- updated gmplayer-about-vine.patch for 20081001 snapshot
419- added BuildRequires:  libdvdread
420- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
421- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
422  in configure options
423#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
424
425* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
426- fixed License
427- added some devel packages to support OpenGL
428
429* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
430- spec in utf8
431- fix sybolic link of subfont for vl5
432
433* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
434- add "Patch105: CVE-2008-1558.patch".
435
436* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
437- build with new versioning policy.
438- fix Source[01] URLs.
439- add "Patch200: gmplayer-about-vine.patch".
440- add "Patch201: gmplayer-add-flv-extension.patch".
441
442* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
443- add four official security patches (CVE-2008-0485, CVE-2008-0486,
444  CVE-2008-0629, CVE-2008-0630)
445- add mplayer-1.0rc2-20080211-stream_cddb.patch
446
447* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
448- change source download URL. <BTS:VineLinux:603>
449
450* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
451- fix CONFDIR for make install. <BTS:wishes:33>
452
453* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
454- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.