source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 1448

Revision 1448, 14.9 KB checked in by munepi, 14 years ago (diff)

updated self-build-mplayer

Line 
1%define with_vaapi 1
2%define with_libvpx 1
3
4%define name    mplayer
5%define version 1.0
6%define extver  rc3
7#% define release       4%{?extver:.%{extver}}%{?_dist_release}
8%define svndate  20100709
9%define release 39.%{svndate}%{?_dist_release}
10
11%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
12%define ttfontdir   /usr/share/fonts
13%define ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
14                    TrueType-sazanami-gothic/sazanami-gothic
15%endif
16
17Summary:        The Movie Player
18Summary(ja):    動画プレイヤー
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22#Source0:       http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
23Source0:        mplayer-export-%{svndate}.tar.bz2
24Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
25Source10:       mplayer-snapshot-vine.sh
26#Patch2:         %{name}-config.patch
27Patch2:         %{name}-config-20100709-vine.patch
28Patch8:         %{name}-manlinks.patch
29Patch14:        %{name}-nodvdcss.patch
30
31## Vine
32Patch50:       mplayer-20100709-fixed-vo_x11_create_vo_window.patch
33
34License:        GPLv2+
35Group:          Applications/Multimedia
36URL:            http://www.mplayerhq.hu/
37
38BuildRequires:  gtk2-devel
39BuildRequires:  freetype2-devel
40BuildRequires:  SDL-devel
41BuildRequires:  alsa-lib-devel
42BuildRequires:  esound-devel
43BuildRequires:  cdparanoia-devel
44BuildRequires:  libvorbis-devel
45BuildRequires:  pulseaudio-lib-devel
46BuildRequires:  libjpeg-devel
47BuildRequires:  libpng-devel
48BuildRequires:  giflib-devel
49BuildRequires:  zlib-devel
50BuildRequires:  libdvdread
51BuildRequires:  libmpcdec-devel
52BuildRequires:  twolame-devel
53BuildRequires:  yasm
54BuildRequires:  libvdpau-devel
55%{?with_vaapi:BuildRequires:libva-devel}
56%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.1}
57BuildRequires:  libXinerama-devel
58BuildRequires:  libXScrnSaver-devel
59# *-devel packages provided by other self-build-* should only be listed
60# in self-build-%{name}.spec as PreReq.
61##Requires:     self-build-mplayer-codecs
62##BuildRequires:        self-build-libdvdcss
63##BuildRequires:        self-build-libdvdnav
64##BuildRequires:  self-build-faac
65##BuildRequires:  self-build-lame
66##BuildRequires:  self-build-libdca
67##BuildRequires:  self-build-x264 >= 0.0.0-4.20090110
68##BuildRequires:  self-build-xvidcore >= 0.9.2
69##BuildRequires:  self-build-faad2 >= 2.6
70##BuildRequires:  self-build-libmad
71##BuildRequires:  self-build-libmpeg2
72Requires:       TrueType-vlgothic
73%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
74Requires:       mesa-libGL
75BuildRequires:  xorg-x11-devel
76BuildRequires:  mesa-libGL-devel
77%endif
78
79BuildRoot:      %{_tmppath}/%{name}-%{version}-root
80
81
82%description
83MPlayer can play most standard video formats out of the box and almost
84all others with the help of external codecs.
85MPlayer currently works best from the command line, but visual feedback
86for many functions is available from its onscreen status display (OSD),
87which is also used for displaying subtitles.
88MPlayer also has a GUI with skin support and several unofficial alternative
89graphical frontends are available.
90
91MEncoder is a command line video encoder for advanced users that can
92be built from the MPlayer source tree. Unofficial graphical frontends
93exist but arenot included.
94
95MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
96support for some newer codecs are not yet inpmlemented.
97You should install mplayer-codecs package if you want to play videos
98using those new codecs.
99
100%description -l ja
101MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
102またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
103現在の MPlayer はコマンドラインから使うのが一番便利ですが、
104多くの操作は字幕と同様に、
105オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
106MPlayer には スキンを変更できる GUI も用意されていますし、
107また複数の非公式なフロントエンドも利用できます。
108
109MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
110非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
111
112MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
113を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
114いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
115をインストールする必要があります。
116
117
118%prep
119#% setup -q -n MPlayer-%{version}%{extver}
120%setup -q -n mplayer-export-%{svndate}
121
122%patch2 -p1 -b .config
123%patch8 -p1 -b .manlinks
124%patch14 -p1 -b .nodvdcss
125
126%patch50 -p1 -b .x11
127
128%build
129./configure \
130    --prefix=%{_prefix} \
131    --confdir=%{_sysconfdir}/mplayer \
132    --enable-runtime-cpudetection \
133    --extra-cflags="$RPM_OPT_FLAGS" \
134    --disable-libdvdcss-internal \
135    --disable-dvdread-internal \
136    --enable-dvdread \
137    --enable-dvdnav \
138    \
139    --disable-faac-lavc \
140    --disable-mp3lame-lavc \
141    --disable-x264-lavc \
142    \
143    --disable-faad-internal \
144    \
145    --disable-libopenjpeg \
146    \
147    --disable-bitmap-font \
148    --disable-termcap \
149    --enable-xvmc \
150    --with-xvmclib=XvMCW \
151    \
152    --enable-largefiles \
153    --enable-menu \
154    --enable-gui \
155    --language=ja,en \
156    ;
157
158%{__make} %{?_smp_mflags}
159
160%install
161%{__rm} -rf ${RPM_BUILD_ROOT}
162%{__make} install INSTALLSTRIP= \
163    prefix=${RPM_BUILD_ROOT}%{_prefix} \
164    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
165    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
166    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
167    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
168    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
169    ;
170
171## install some default config files
172%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
173%{__install} -pm 644 etc/example.conf \
174    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
175%{__install} -pm 644 etc/{input,menu,codecs}.conf \
176    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
177
178# install default skin
179%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
180pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
181%{__tar} xjf %{SOURCE1}
182%{__ln_s} Blue default
183popd
184
185# make sybolic link to ttf font for subtitle
186for i in %{ttfontlist}; do
187    if [ -e %{ttfontdir}/$i.ttf ];then
188        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
189        break;
190    fi;
191done
192
193## install TOOLS
194for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
195%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
196done
197
198for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
199%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
200done
201
202for file in vobshift.py ; do
203%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
204done
205
206%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
207%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
208
209
210%clean
211%{__rm} -rf ${RPM_BUILD_ROOT}
212
213
214%files
215%defattr(-,root,root)
216%doc AUTHORS Changelog Copyright LICENSE README
217%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
218%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
219%config(noreplace) %{_sysconfdir}/mplayer/input.conf
220%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
221%{_bindir}/mplayer
222%{_bindir}/gmplayer
223%{_bindir}/mencoder
224%{_datadir}/mplayer/skins/Blue
225%{_datadir}/mplayer/skins/default
226%{_datadir}/mplayer/subfont.ttf
227%{_datadir}/applications/mplayer.desktop
228%{_datadir}/pixmaps/mplayer.xpm
229%{_mandir}/man1/mplayer.1*
230%{_mandir}/man1/mencoder.1*
231## TOOLS
232%{_bindir}/aconvert
233%{_bindir}/calcbpp
234%{_bindir}/countquant
235%{_bindir}/divx2svcd
236%{_bindir}/dvd2divxscript
237%{_bindir}/mencvcd
238%{_bindir}/midentify
239%{_bindir}/mpconsole
240%{_bindir}/qepdvcd
241%{_bindir}/subsearch
242%{_bindir}/vobshift
243%{_datadir}/mplayer/*.fp
244
245
246%changelog
247* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
248- updated fixed %{name}-config.patch
249  - applied %{name}-config-20100709-vine.patch
250
251* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
252- change release to sync with self-build-mplayer
253
254* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
255- updated source snapshot 20100709
256- renamed %%Source10 to mplayer-snapshot-vine.sh
257- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
258- added BuildRequires: libvpx-devel >= 0.9.1
259
260* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
261- updated source snapshot 20100621
262
263* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
264- updated source snapshot 20100615
265- added BuildRequires: libXinerama-devel
266- dropped vl4 support
267
268* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
269- updated source snapshot 20100410
270
271* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
272- updated source snapshot 20100401
273
274* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
275- updated source snapshot 20100326
276
277* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
278- updated source snapshot 20100317
279
280* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
281- updated source snapshot 20100216
282- moved scripts from TOOLS
283- added --disable-libopenjpeg in configure options
284
285* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
286- updated source snapshot 20100201
287- dropped obsolete patches
288- added BuildRequires:
289  - libvdpau-devel
290  - libXScrnSaver-devel
291
292* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
293- update mplayer-config-20091215-vine.patch
294- update mplayer-20091215-x86_32-compile.patch
295- added --enable-runtime-cpudetection in configure options
296
297* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
298- source snapshot 20091031
299  - updated mplayer-20091031-x86_32-compile.patch
300
301* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
302- source snapshot 20091003
303
304* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
305- change release to sync with self-build-mplayer
306
307* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
308- source snapshot 20090905
309- added settings for vl6
310
311* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
312- source snapshot 20090821
313- replaced BR: libungif-devel with BR: giflib-devel
314
315* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
316- source snapshot 20090722
317
318* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
319- source snapshot 20090702
320
321* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
322- source snapshot 20090611
323
324* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
325- added Requires: TrueType-vlgothic
326
327* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
328- source snapshot 20090522
329  - build with x264 >= 0.0.0-9.20090522
330  - updated mplayer-20090522-nodvdcss.patch
331
332* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
333- change release to sync with self-build-mplayer
334
335* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
336- source snapshot 20090502
337- updated mplayer-20090503-x86_32-compile.patch
338- updated mplayer-20090502-nodvdcss.patch
339
340* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
341- applied mplayer-config-vine.patch
342
343* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
344- source snapshot 20090327
345- updated mplayer-20090327-x86_32-compile.patch
346- updated mplayer-20090325-nodvdcss.patch
347- dropped gmplayer-about-vine.patch
348- install some default config files
349- added configure options:
350  - --disable-termcap
351  - --enable-xvmc
352  - --with-xvmclib=XvMCW
353- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
354- fixed %%files for *.conf
355
356* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
357- source snapshot 20090305
358
359* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
360- source snapshot 20090227
361
362* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
363- source snapshot 20090216
364
365* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
366- source snapshot 20090206
367- dropped mplayer-man-zh_CN.patch
368- updated mplayer-20090206-nodvdcss.patch
369- changed to PreReq:  self-build-faad2 from faad2-devel
370- added PreReq:  self-build-libmad
371
372* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
373- source snapshot 20090131
374
375* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
376- change release to sync with self-build-mplayer
377
378* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
379- source snapshot
380- update mplayer-20090122-nodvdcss.patch
381- added BuildRequires:
382  - faad2-devel
383  - libmpcdec-devel
384  - twolame-devel
385  - yasm
386  - faac-devel (as PreReq in self-build-%{name})
387  - lame-devel (as PreReq in self-build-%{name})
388  - libdca-devel (as PreReq in self-build-%{name})
389  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
390  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
391
392* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
393- source snapshot
394- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
395  --disable-faad-internal in configure options
396- dropped gmplayer-add-flv-extension.patch
397
398* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
399- source snapshot
400- fixed License
401- added some patches from RPM Fusion
402- updated gmplayer-about-vine.patch for 20081001 snapshot
403- added BuildRequires:  libdvdread
404- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
405- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
406  in configure options
407#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
408
409* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
410- fixed License
411- added some devel packages to support OpenGL
412
413* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
414- spec in utf8
415- fix sybolic link of subfont for vl5
416
417* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
418- add "Patch105: CVE-2008-1558.patch".
419
420* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
421- build with new versioning policy.
422- fix Source[01] URLs.
423- add "Patch200: gmplayer-about-vine.patch".
424- add "Patch201: gmplayer-add-flv-extension.patch".
425
426* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
427- add four official security patches (CVE-2008-0485, CVE-2008-0486,
428  CVE-2008-0629, CVE-2008-0630)
429- add mplayer-1.0rc2-20080211-stream_cddb.patch
430
431* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
432- change source download URL. <BTS:VineLinux:603>
433
434* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
435- fix CONFDIR for make install. <BTS:wishes:33>
436
437* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
438- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.