source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 1258

Revision 1258, 14.0 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define name    mplayer
2%define version 1.0
3%define extver  rc3
4#% define release       4%{?extver:.%{extver}}%{?_dist_release}
5%define svndate  20100621
6%define release 36.%{svndate}%{?_dist_release}
7
8%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
9%define ttfontdir   /usr/share/fonts
10%define ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
11                    TrueType-sazanami-gothic/sazanami-gothic
12%endif
13
14Summary:        The Movie Player
15Summary(ja):    動画プレイヤー
16Name:           %{name}
17Version:        %{version}
18Release:        %{release}
19#Source0:       http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
20Source0:        mplayer-export-%{svndate}.tar.bz2
21Source1:        http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
22Source10:       mplayer-snapshot.sh
23Patch2:         %{name}-config.patch
24Patch8:         %{name}-manlinks.patch
25Patch14:        %{name}-nodvdcss.patch
26
27License:        GPLv2+
28Group:          Applications/Multimedia
29URL:            http://www.mplayerhq.hu/
30
31BuildRequires:  gtk2-devel
32BuildRequires:  freetype2-devel
33BuildRequires:  SDL-devel
34BuildRequires:  alsa-lib-devel
35BuildRequires:  esound-devel
36BuildRequires:  cdparanoia-devel
37BuildRequires:  libvorbis-devel
38BuildRequires:  pulseaudio-lib-devel
39BuildRequires:  libjpeg-devel
40BuildRequires:  libpng-devel
41BuildRequires:  giflib-devel
42BuildRequires:  zlib-devel
43BuildRequires:  libdvdread
44BuildRequires:  libmpcdec-devel
45BuildRequires:  twolame-devel
46BuildRequires:  yasm
47BuildRequires:  libvdpau-devel
48BuildRequires:  libXinerama-devel
49BuildRequires:  libXScrnSaver-devel
50# *-devel packages provided by other self-build-* should only be listed
51# in self-build-%{name}.spec as PreReq.
52##Requires:     self-build-mplayer-codecs
53##BuildRequires:        self-build-libdvdcss
54##BuildRequires:        self-build-libdvdnav
55##BuildRequires:  self-build-faac
56##BuildRequires:  self-build-lame
57##BuildRequires:  self-build-libdca
58##BuildRequires:  self-build-x264 >= 0.0.0-4.20090110
59##BuildRequires:  self-build-xvidcore >= 0.9.2
60##BuildRequires:  self-build-faad2 >= 2.6
61##BuildRequires:  self-build-libmad
62Requires:       TrueType-vlgothic
63%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
64Requires:       mesa-libGL
65BuildRequires:  xorg-x11-devel
66BuildRequires:  mesa-libGL-devel
67%endif
68
69BuildRoot:      %{_tmppath}/%{name}-%{version}-root
70
71
72%description
73MPlayer can play most standard video formats out of the box and almost
74all others with the help of external codecs.
75MPlayer currently works best from the command line, but visual feedback
76for many functions is available from its onscreen status display (OSD),
77which is also used for displaying subtitles.
78MPlayer also has a GUI with skin support and several unofficial alternative
79graphical frontends are available.
80
81MEncoder is a command line video encoder for advanced users that can
82be built from the MPlayer source tree. Unofficial graphical frontends
83exist but arenot included.
84
85MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
86support for some newer codecs are not yet inpmlemented.
87You should install mplayer-codecs package if you want to play videos
88using those new codecs.
89
90%description -l ja
91MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
92またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
93で生できます。
94現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
95は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
96面上で確認できます。
97MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
98非公式なフロントエンドも利用できます。
99
100MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
101非公式な GUI フロントエンドもありますが、このパッケージには含まれて
102いません。
103
104MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
105を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
106いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
107をインストールする必要があります。
108
109
110%prep
111#% setup -q -n MPlayer-%{version}%{extver}
112%setup -q -n mplayer-export-%{svndate}
113
114%patch2 -p1 -b .config
115%patch8 -p1 -b .manlinks
116%patch14 -p1 -b .nodvdcss
117
118%build
119./configure \
120    --prefix=%{_prefix} \
121    --confdir=%{_sysconfdir}/mplayer \
122    --enable-runtime-cpudetection \
123    --extra-cflags="$RPM_OPT_FLAGS" \
124    --disable-libdvdcss-internal \
125    --disable-dvdread-internal \
126    --enable-dvdread \
127    --enable-dvdnav \
128    \
129    --disable-faac-lavc \
130    --disable-mp3lame-lavc \
131    --disable-x264-lavc \
132    \
133    --disable-faad-internal \
134    \
135    --disable-libopenjpeg \
136    \
137    --disable-bitmap-font \
138    --disable-termcap \
139    --enable-xvmc \
140    --with-xvmclib=XvMCW \
141    \
142    --enable-largefiles \
143    --enable-menu \
144    --enable-gui \
145    --language=ja,en \
146    ;
147
148%{__make} %{?_smp_mflags}
149
150%install
151%{__rm} -rf ${RPM_BUILD_ROOT}
152%{__make} install prefix=${RPM_BUILD_ROOT}%{_prefix} \
153                  BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
154                  DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
155                  CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
156                  LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
157                  MANDIR=${RPM_BUILD_ROOT}%{_mandir}
158
159## install some default config files
160%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
161%{__install} -pm 644 etc/example.conf \
162    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
163%{__install} -pm 644 etc/{input,menu,codecs}.conf \
164    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
165
166# install default skin
167%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
168pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
169%{__tar} xjf %{SOURCE1}
170%{__ln_s} Blue default
171popd
172
173# make sybolic link to ttf font for subtitle
174for i in %{ttfontlist}; do
175    if [ -e %{ttfontdir}/$i.ttf ];then
176        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
177        break;
178    fi;
179done
180
181## install TOOLS
182for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
183%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
184done
185
186for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
187%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
188done
189
190for file in vobshift.py ; do
191%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
192done
193
194%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
195%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
196
197
198%clean
199%{__rm} -rf ${RPM_BUILD_ROOT}
200
201
202%files
203%defattr(-,root,root)
204%doc AUTHORS Changelog Copyright LICENSE README
205%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
206%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
207%config(noreplace) %{_sysconfdir}/mplayer/input.conf
208%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
209%{_bindir}/mplayer
210%{_bindir}/gmplayer
211%{_bindir}/mencoder
212%{_datadir}/mplayer/skins/Blue
213%{_datadir}/mplayer/skins/default
214%{_datadir}/mplayer/subfont.ttf
215%{_datadir}/applications/mplayer.desktop
216%{_datadir}/pixmaps/mplayer.xpm
217%{_mandir}/man1/mplayer.1*
218%{_mandir}/man1/mencoder.1*
219## TOOLS
220%{_bindir}/aconvert
221%{_bindir}/calcbpp
222%{_bindir}/countquant
223%{_bindir}/divx2svcd
224%{_bindir}/dvd2divxscript
225%{_bindir}/mencvcd
226%{_bindir}/midentify
227%{_bindir}/mpconsole
228%{_bindir}/qepdvcd
229%{_bindir}/subsearch
230%{_bindir}/vobshift
231%{_datadir}/mplayer/*.fp
232
233
234%changelog
235* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
236- updated source snapshot 20100621
237
238* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
239- updated source snapshot 20100615
240- added BuildRequires: libXinerama-devel
241- dropped vl4 support
242
243* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
244- updated source snapshot 20100410
245
246* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
247- updated source snapshot 20100401
248
249* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
250- updated source snapshot 20100326
251
252* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
253- updated source snapshot 20100317
254
255* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
256- updated source snapshot 20100216
257- moved scripts from TOOLS
258- added --disable-libopenjpeg in configure options
259
260* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
261- updated source snapshot 20100201
262- dropped obsolete patches
263- added BuildRequires:
264  - libvdpau-devel
265  - libXScrnSaver-devel
266
267* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
268- update mplayer-config-20091215-vine.patch
269- update mplayer-20091215-x86_32-compile.patch
270- added --enable-runtime-cpudetection in configure options
271
272* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
273- source snapshot 20091031
274  - updated mplayer-20091031-x86_32-compile.patch
275
276* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
277- source snapshot 20091003
278
279* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
280- change release to sync with self-build-mplayer
281
282* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
283- source snapshot 20090905
284- added settings for vl6
285
286* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
287- source snapshot 20090821
288- replaced BR: libungif-devel with BR: giflib-devel
289
290* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
291- source snapshot 20090722
292
293* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
294- source snapshot 20090702
295
296* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
297- source snapshot 20090611
298
299* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
300- added Requires: TrueType-vlgothic
301
302* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
303- source snapshot 20090522
304  - build with x264 >= 0.0.0-9.20090522
305  - updated mplayer-20090522-nodvdcss.patch
306
307* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
308- change release to sync with self-build-mplayer
309
310* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
311- source snapshot 20090502
312- updated mplayer-20090503-x86_32-compile.patch
313- updated mplayer-20090502-nodvdcss.patch
314
315* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
316- applied mplayer-config-vine.patch
317
318* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
319- source snapshot 20090327
320- updated mplayer-20090327-x86_32-compile.patch
321- updated mplayer-20090325-nodvdcss.patch
322- dropped gmplayer-about-vine.patch
323- install some default config files
324- added configure options:
325  - --disable-termcap
326  - --enable-xvmc
327  - --with-xvmclib=XvMCW
328- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
329- fixed %%files for *.conf
330
331* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
332- source snapshot 20090305
333
334* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
335- source snapshot 20090227
336
337* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
338- source snapshot 20090216
339
340* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
341- source snapshot 20090206
342- dropped mplayer-man-zh_CN.patch
343- updated mplayer-20090206-nodvdcss.patch
344- changed to PreReq:  self-build-faad2 from faad2-devel
345- added PreReq:  self-build-libmad
346
347* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
348- source snapshot 20090131
349
350* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
351- change release to sync with self-build-mplayer
352
353* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
354- source snapshot
355- update mplayer-20090122-nodvdcss.patch
356- added BuildRequires:
357  - faad2-devel
358  - libmpcdec-devel
359  - twolame-devel
360  - yasm
361  - faac-devel (as PreReq in self-build-%{name})
362  - lame-devel (as PreReq in self-build-%{name})
363  - libdca-devel (as PreReq in self-build-%{name})
364  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
365  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
366
367* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
368- source snapshot
369- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
370  --disable-faad-internal in configure options
371- dropped gmplayer-add-flv-extension.patch
372
373* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
374- source snapshot
375- fixed License
376- added some patches from RPM Fusion
377- updated gmplayer-about-vine.patch for 20081001 snapshot
378- added BuildRequires:  libdvdread
379- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
380- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
381  in configure options
382#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
383
384* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
385- fixed License
386- added some devel packages to support OpenGL
387
388* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
389- spec in utf8
390- fix sybolic link of subfont for vl5
391
392* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
393- add "Patch105: CVE-2008-1558.patch".
394
395* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
396- build with new versioning policy.
397- fix Source[01] URLs.
398- add "Patch200: gmplayer-about-vine.patch".
399- add "Patch201: gmplayer-add-flv-extension.patch".
400
401* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
402- add four official security patches (CVE-2008-0485, CVE-2008-0486,
403  CVE-2008-0629, CVE-2008-0630)
404- add mplayer-1.0rc2-20080211-stream_cddb.patch
405
406* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
407- change source download URL. <BTS:VineLinux:603>
408
409* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
410- fix CONFDIR for make install. <BTS:wishes:33>
411
412* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
413- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.