source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 12251

Revision 12251, 19.1 KB checked in by ara_t, 4 years ago (diff)

self-build-mplayer: change BuildRequires?

Line 
1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
4
5#% global with_ffmpeg 1
6%global ffmpegver 2.8.5
7
8#% global svndate  20120525
9
10%define codecdir   %{_libdir}/codecs
11
12%global ttfontdir   %{_datadir}/fonts
13%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
14                    TrueType-sazanami-gothic/sazanami-gothic
15
16Summary:        The Movie Player
17Summary(ja):    動画プレイヤー
18Name:           mplayer
19Version:        1.2
20Release:        3%{?svndate:.%svndate}%{?_dist_release}
21Source0:        http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
22#Source0:       mplayer-export-%{svndate}.tar.xz
23Source1:        http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
24
25Source10:       mplayer-snapshot-vine.sh
26
27Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
28Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.8.tar.bz2
29Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.11.tar.bz2
30Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
31
32# set defaults for Vine Linux
33Patch2:         %{name}-1.1.1-config-vine.patch
34# use roff include statements instead of symlinks
35Patch8:         %{name}-1.1.1-manlinks.patch
36# NOTE: need not this patch against v1.2
37# # erase any trace of libdvdcss
38# Patch14:        %{name}-1.1.1-nodvdcss.patch
39# use system FFmpeg libraries
40Patch18:        %{name}-1.1.1-ffmpeg.patch
41
42## Vine
43
44
45%if 0%{!?_without_amr:1}
46License:        GPLv3+
47%else
48License:        GPLv2+
49%endif
50Group:          Applications/Multimedia
51URL:            http://www.mplayerhq.hu/
52
53BuildRequires:  SDL-devel
54BuildRequires:  aalib-devel
55BuildRequires:  alsa-lib-devel
56BuildRequires:  cdparanoia-devel
57BuildRequires:  desktop-file-utils
58##!!BuildRequires:  em8300-devel
59BuildRequires:  libdvdnav-devel
60BuildRequires:  enca-devel
61BuildRequires:  fontconfig-devel
62BuildRequires:  freetype2-devel >= 2.0.9
63BuildRequires:  fribidi-devel
64BuildRequires:  giflib-devel
65BuildRequires:  gtk2-devel
66BuildRequires:  mesa-libGL-devel
67BuildRequires:  libXinerama-devel
68BuildRequires:  libXScrnSaver-devel
69BuildRequires:  libXv-devel
70BuildRequires:  libXvMC-devel
71BuildRequires:  libXxf86dga-devel
72BuildRequires:  libXxf86vm-devel
73BuildRequires:  libass-devel
74BuildRequires:  libpng-devel
75BuildRequires:  libjpeg-devel
76BuildRequires:  libdvdread
77BuildRequires:  libmpcdec-devel >= 1.2.1
78BuildRequires:  librtmp-devel >= 2.3
79BuildRequires:  speex-devel >= 1.1
80%{?with_vaapi:BuildRequires:libva-devel}
81BuildRequires:  libvdpau-devel
82BuildRequires:  libvorbis-devel
83%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
84BuildRequires:  lzo-devel >= 2
85BuildRequires:  pulseaudio-lib-devel
86BuildRequires:  speex-devel >= 1.1
87BuildRequires:  twolame-devel
88BuildRequires:  xorg-x11-devel
89BuildRequires:  yasm
90BuildRequires:  zlib-devel
91
92# *-devel packages provided by other self-build-* should only be listed
93# in self-build-%{name}.spec as PreReq.
94##Requires:     self-build-mplayer-codecs
95##BuildRequires:        self-build-libdvdcss
96###BuildRequires:  self-build-lame
97##BuildRequires:  self-build-libdca
98##BuildRequires:  self-build-x264 >= 0.129
99##BuildRequires:  self-build-xvidcore >= 0.9.2
100##BuildRequires:  self-build-faad2 >= 2.6.1
101###BuildRequires:  self-build-libmpeg2
102
103Requires:       TrueType-vlgothic
104Requires:       mesa-libGL
105
106BuildRoot:      %{_tmppath}/%{name}-%{version}-root
107
108Obsoletes:      mplayer < %{version}-%{release}
109
110%description
111MPlayer can play most standard video formats out of the box and almost
112all others with the help of external codecs.
113MPlayer currently works best from the command line, but visual feedback
114for many functions is available from its onscreen status display (OSD),
115which is also used for displaying subtitles.
116MPlayer also has a GUI with skin support and several unofficial alternative
117graphical frontends are available.
118
119MEncoder is a command line video encoder for advanced users that can
120be built from the MPlayer source tree. Unofficial graphical frontends
121exist but arenot included.
122
123MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
124support for some newer codecs are not yet inpmlemented.
125You should install mplayer-codecs package if you want to play videos
126using those new codecs.
127
128%description -l ja
129MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
130またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
131で再生できます。
132現在の MPlayer はコマンドラインから使うのが一番便利ですが、
133多くの操作は字幕と同様に、
134オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
135MPlayer には スキンを変更できる GUI も用意されていますし、
136また複数の非公式なフロントエンドも利用できます。
137
138MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
139非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
140
141MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
142を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
143いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
144をインストールする必要があります。
145
146
147%prep
148#% setup -q -n mplayer-export-%{svndate}
149%setup -q -n MPlayer-%{version}
150%__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
151
152%patch2 -p1 -b .vine
153%patch8 -p1 -b .manlinks
154#%patch14 -p1 -b .nodvdcss
155%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
156
157%build
158./configure \
159    --prefix=%{_prefix} \
160    --bindir=%{_bindir} \
161    --datadir=%{_datadir}/mplayer \
162    --mandir=%{_mandir} \
163    --confdir=%{_sysconfdir}/mplayer \
164    --libdir=%{_libdir} \
165    --codecsdir=%{codecdir} \
166    \
167    --extra-cflags="$RPM_OPT_FLAGS" \
168    --language=ja,en \
169    --enable-joystick \
170    --enable-gui --enable-menu \
171    --enable-radio --enable-radio-capture \
172    --enable-runtime-cpudetection \
173    --enable-unrarexec \
174    \
175    --disable-nemesi \
176    \
177    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
178    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
179    %{!?with_faac:--disable-faac} \
180    --disable-libmpeg2-internal \
181    --disable-libopenjpeg \
182    \
183    --disable-bitmap-font \
184    --disable-dga1 --disable-dga2 \
185    --disable-directfb \
186    --disable-svga \
187    --disable-termcap \
188    --enable-xvmc \
189    --with-xvmclib=XvMCW \
190    \
191    --disable-arts --disable-esd --disable-jack --disable-openal \
192    --disable-live \
193    ;
194
195%{__make} V=1 %{?_smp_mflags}
196
197%install
198%{__rm} -rf ${RPM_BUILD_ROOT}
199%{__make} install INSTALLSTRIP= \
200    prefix=${RPM_BUILD_ROOT}%{_prefix} \
201    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
202    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
203    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
204    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
205    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
206    ;
207
208## install some default config files
209%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
210%{__install} -pm 644 etc/example.conf \
211    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
212%{__install} -pm 644 etc/{input,menu,codecs}.conf \
213    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
214
215# # Icons
216# for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
217#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
218#     install -pm 644 etc/mplayer$iconsize.png \
219#         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
220# done
221
222# install skins and set the default skin
223%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
224pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
225  for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
226    %__tar xf ${x} || exit 1
227  done
228  %__ln_s Blue default || exit 1
229popd
230
231# make sybolic link to ttf font for subtitle
232for i in %{ttfontlist}; do
233    if [ -e %{ttfontdir}/$i.ttf ];then
234        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
235        break;
236    fi;
237done
238
239## install TOOLS
240for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
241%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
242done
243
244for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
245%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
246done
247
248for file in vobshift.py ; do
249%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
250done
251
252%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
253%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
254
255
256%clean
257%{__rm} -rf ${RPM_BUILD_ROOT}
258
259%post
260touch --no-create %{_datadir}/icons/hicolor
261if [ -x %{_bindir}/gtk-update-icon-cache ]; then
262  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
263fi
264%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
265
266%postun
267%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
268touch --no-create %{_datadir}/icons/hicolor
269if [ -x %{_bindir}/gtk-update-icon-cache ]; then
270  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
271fi || :
272
273
274%files
275%defattr(-,root,root)
276#%doc AUTHORS Changelog Copyright LICENSE README
277%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
278%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
279%config(noreplace) %{_sysconfdir}/mplayer/input.conf
280%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
281%{_bindir}/mplayer
282%{_bindir}/gmplayer
283%{_bindir}/mencoder
284%{_datadir}/mplayer/skins/default
285%{_datadir}/mplayer/skins/Blue
286%{_datadir}/mplayer/skins/Blue-small
287%{_datadir}/mplayer/skins/OSX-Mod
288%{_datadir}/mplayer/skins/standard
289%{_datadir}/mplayer/subfont.ttf
290%{_datadir}/applications/mplayer.desktop
291%{_datadir}/icons/hicolor/*/apps/mplayer.png
292%{_mandir}/man1/mplayer.1*
293%{_mandir}/man1/mencoder.1*
294## TOOLS
295%{_bindir}/aconvert
296%{_bindir}/calcbpp
297%{_bindir}/countquant
298%{_bindir}/divx2svcd
299%{_bindir}/dvd2divxscript
300%{_bindir}/mencvcd
301%{_bindir}/midentify
302%{_bindir}/mpconsole
303%{_bindir}/qepdvcd
304%{_bindir}/subsearch
305%{_bindir}/vobshift
306%{_datadir}/mplayer/*.fp
307
308
309%changelog
310* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 1.2-3
311- change BR: self-build-{lame,libmpeg2} to {lame,a52dec}-devel
312
313* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
314- rebuild with libcdio-0.93
315
316* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
317- new upstream release
318
319* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-4
320- rebuilt
321
322* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
323- rebuilt with ffmpeg-0.11.5
324
325* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
326- remove some obsolete comments
327
328* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
329- updated to 1.1.1
330- build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
331
332* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
333- rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
334
335* Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
336- updated to 1.1
337  - built with ffmpeg-0.11.1
338- added some skins
339
340* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
341- updated snapshot 20120525 with ffmpeg 0.11
342
343* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
344- updated snapshot 20120102
345
346* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
347- updated snapshot 20111217 (with ffmpeg 0.9)
348
349* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
350- s/self-build-libdvdnav/libdvdnav/
351
352* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
353- updated %%SOURCE1
354  - update to 1.8
355
356* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
357- dropped BuildRequires: esound-devel
358
359* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
360- new upstream release
361  - ready for Vine Linux 6
362  - revived support for Vine Linux 5
363- added BuildRequires:
364  - libass-devel
365  - librtmp-devel >= 2.3
366  - speex-devel >= 1.1
367
368* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
369- added BuildRequires:
370  - aalib-devel
371  - enca-devel
372  - lzo-devel
373  - speex-devel
374
375* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
376- updated fixed %{name}-config.patch
377  - applied %{name}-config-20100709-vine.patch
378
379* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
380- change release to sync with self-build-mplayer
381
382* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
383- updated source snapshot 20100709
384- renamed %%Source10 to mplayer-snapshot-vine.sh
385- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
386- added BuildRequires: libvpx-devel >= 0.9.1
387
388* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
389- updated source snapshot 20100621
390
391* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
392- updated source snapshot 20100615
393- added BuildRequires: libXinerama-devel
394- dropped vl4 support
395
396* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
397- updated source snapshot 20100410
398
399* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
400- updated source snapshot 20100401
401
402* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
403- updated source snapshot 20100326
404
405* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
406- updated source snapshot 20100317
407
408* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
409- updated source snapshot 20100216
410- moved scripts from TOOLS
411- added --disable-libopenjpeg in configure options
412
413* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
414- updated source snapshot 20100201
415- dropped obsolete patches
416- added BuildRequires:
417  - libvdpau-devel
418  - libXScrnSaver-devel
419
420* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
421- update mplayer-config-20091215-vine.patch
422- update mplayer-20091215-x86_32-compile.patch
423- added --enable-runtime-cpudetection in configure options
424
425* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
426- source snapshot 20091031
427  - updated mplayer-20091031-x86_32-compile.patch
428
429* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
430- source snapshot 20091003
431
432* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
433- change release to sync with self-build-mplayer
434
435* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
436- source snapshot 20090905
437- added settings for vl6
438
439* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
440- source snapshot 20090821
441- replaced BR: libungif-devel with BR: giflib-devel
442
443* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
444- source snapshot 20090722
445
446* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
447- source snapshot 20090702
448
449* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
450- source snapshot 20090611
451
452* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
453- added Requires: TrueType-vlgothic
454
455* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
456- source snapshot 20090522
457  - build with x264 >= 0.0.0-9.20090522
458  - updated mplayer-20090522-nodvdcss.patch
459
460* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
461- change release to sync with self-build-mplayer
462
463* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
464- source snapshot 20090502
465- updated mplayer-20090503-x86_32-compile.patch
466- updated mplayer-20090502-nodvdcss.patch
467
468* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
469- applied mplayer-config-vine.patch
470
471* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
472- source snapshot 20090327
473- updated mplayer-20090327-x86_32-compile.patch
474- updated mplayer-20090325-nodvdcss.patch
475- dropped gmplayer-about-vine.patch
476- install some default config files
477- added configure options:
478  - --disable-termcap
479  - --enable-xvmc
480  - --with-xvmclib=XvMCW
481- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
482- fixed %%files for *.conf
483
484* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
485- source snapshot 20090305
486
487* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
488- source snapshot 20090227
489
490* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
491- source snapshot 20090216
492
493* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
494- source snapshot 20090206
495- dropped mplayer-man-zh_CN.patch
496- updated mplayer-20090206-nodvdcss.patch
497- changed to PreReq:  self-build-faad2 from faad2-devel
498- added PreReq:  self-build-libmad
499
500* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
501- source snapshot 20090131
502
503* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
504- change release to sync with self-build-mplayer
505
506* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
507- source snapshot
508- update mplayer-20090122-nodvdcss.patch
509- added BuildRequires:
510  - faad2-devel
511  - libmpcdec-devel
512  - twolame-devel
513  - yasm
514  - faac-devel (as PreReq in self-build-%{name})
515  - lame-devel (as PreReq in self-build-%{name})
516  - libdca-devel (as PreReq in self-build-%{name})
517  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
518  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
519
520* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
521- source snapshot
522- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
523  --disable-faad-internal in configure options
524- dropped gmplayer-add-flv-extension.patch
525
526* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
527- source snapshot
528- fixed License
529- added some patches from RPM Fusion
530- updated gmplayer-about-vine.patch for 20081001 snapshot
531- added BuildRequires:  libdvdread
532- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
533- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
534  in configure options
535#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
536
537* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
538- fixed License
539- added some devel packages to support OpenGL
540
541* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
542- spec in utf8
543- fix sybolic link of subfont for vl5
544
545* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
546- add "Patch105: CVE-2008-1558.patch".
547
548* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
549- build with new versioning policy.
550- fix Source[01] URLs.
551- add "Patch200: gmplayer-about-vine.patch".
552- add "Patch201: gmplayer-add-flv-extension.patch".
553
554* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
555- add four official security patches (CVE-2008-0485, CVE-2008-0486,
556  CVE-2008-0629, CVE-2008-0630)
557- add mplayer-1.0rc2-20080211-stream_cddb.patch
558
559* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
560- change source download URL. <BTS:VineLinux:603>
561
562* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
563- fix CONFDIR for make install. <BTS:wishes:33>
564
565* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
566- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.