source: projects/specs/trunk/nonfree/self-build-mplayer/mplayer-vl.spec @ 10524

Revision 10524, 19.0 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

RevLine 
[5297]1%global with_faac 1
2%global with_vaapi 1
3%global with_libvpx 1
[1306]4
[6328]5#% global with_ffmpeg 1
[9973]6%global ffmpegver 2.8.5
[615]7
[6328]8#% global svndate  20120525
[5297]9
[6241]10%define codecdir   %{_libdir}/codecs
11
[6328]12%global ttfontdir   %{_datadir}/fonts
[5297]13%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
[615]14                    TrueType-sazanami-gothic/sazanami-gothic
15
16Summary:        The Movie Player
17Summary(ja):    動画プレイヤー
[6328]18Name:           mplayer
[9973]19Version:        1.2
[10524]20Release:        2%{?svndate:.%svndate}%{?_dist_release}
[6328]21Source0:        http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
22#Source0:       mplayer-export-%{svndate}.tar.xz
23Source1:        http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
24
[1306]25Source10:       mplayer-snapshot-vine.sh
[4182]26
[9973]27Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.11.tar.bz2
28Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.8.tar.bz2
29Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.11.tar.bz2
[6328]30Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
31
[6241]32# set defaults for Vine Linux
[7842]33Patch2:         %{name}-1.1.1-config-vine.patch
[6241]34# use roff include statements instead of symlinks
[7842]35Patch8:         %{name}-1.1.1-manlinks.patch
[9973]36# NOTE: need not this patch against v1.2
37# # erase any trace of libdvdcss
38# Patch14:        %{name}-1.1.1-nodvdcss.patch
[6241]39# use system FFmpeg libraries
[7842]40Patch18:        %{name}-1.1.1-ffmpeg.patch
[615]41
[1306]42## Vine
43
[6241]44
45%if 0%{!?_without_amr:1}
46License:        GPLv3+
47%else
48License:        GPLv2+
49%endif
[615]50Group:          Applications/Multimedia
51URL:            http://www.mplayerhq.hu/
52
53BuildRequires:  SDL-devel
[2621]54BuildRequires:  aalib-devel
[615]55BuildRequires:  alsa-lib-devel
[2621]56BuildRequires:  cdparanoia-devel
57BuildRequires:  desktop-file-utils
[6241]58##!!BuildRequires:  em8300-devel
[5085]59BuildRequires:  libdvdnav-devel
[2621]60BuildRequires:  enca-devel
[6241]61BuildRequires:  fontconfig-devel
[3126]62BuildRequires:  freetype2-devel >= 2.0.9
[2621]63BuildRequires:  fribidi-devel
64BuildRequires:  giflib-devel
65BuildRequires:  gtk2-devel
66BuildRequires:  mesa-libGL-devel
67BuildRequires:  libXinerama-devel
68BuildRequires:  libXScrnSaver-devel
69BuildRequires:  libXv-devel
70BuildRequires:  libXvMC-devel
71BuildRequires:  libXxf86dga-devel
72BuildRequires:  libXxf86vm-devel
[3126]73BuildRequires:  libass-devel
[2621]74BuildRequires:  libpng-devel
[615]75BuildRequires:  libjpeg-devel
76BuildRequires:  libdvdread
[3126]77BuildRequires:  libmpcdec-devel >= 1.2.1
78BuildRequires:  librtmp-devel >= 2.3
79BuildRequires:  speex-devel >= 1.1
[2621]80%{?with_vaapi:BuildRequires:libva-devel}
81BuildRequires:  libvdpau-devel
82BuildRequires:  libvorbis-devel
[5297]83%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
[2621]84BuildRequires:  lzo-devel >= 2
85BuildRequires:  pulseaudio-lib-devel
86BuildRequires:  speex-devel >= 1.1
[615]87BuildRequires:  twolame-devel
[2621]88BuildRequires:  xorg-x11-devel
[615]89BuildRequires:  yasm
[2621]90BuildRequires:  zlib-devel
91
[615]92# *-devel packages provided by other self-build-* should only be listed
93# in self-build-%{name}.spec as PreReq.
94##Requires:     self-build-mplayer-codecs
95##BuildRequires:        self-build-libdvdcss
96##BuildRequires:  self-build-lame
97##BuildRequires:  self-build-libdca
[7842]98##BuildRequires:  self-build-x264 >= 0.129
[615]99##BuildRequires:  self-build-xvidcore >= 0.9.2
[5297]100##BuildRequires:  self-build-faad2 >= 2.6.1
[1306]101##BuildRequires:  self-build-libmpeg2
[2621]102
[615]103Requires:       TrueType-vlgothic
104Requires:       mesa-libGL
[1258]105
[615]106BuildRoot:      %{_tmppath}/%{name}-%{version}-root
107
[6241]108Obsoletes:      mplayer < %{version}-%{release}
[615]109
110%description
111MPlayer can play most standard video formats out of the box and almost
112all others with the help of external codecs.
113MPlayer currently works best from the command line, but visual feedback
114for many functions is available from its onscreen status display (OSD),
115which is also used for displaying subtitles.
116MPlayer also has a GUI with skin support and several unofficial alternative
117graphical frontends are available.
118
119MEncoder is a command line video encoder for advanced users that can
120be built from the MPlayer source tree. Unofficial graphical frontends
121exist but arenot included.
122
123MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
124support for some newer codecs are not yet inpmlemented.
125You should install mplayer-codecs package if you want to play videos
126using those new codecs.
127
128%description -l ja
129MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
[5297]130またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
131で再生できます。
[1448]132現在の MPlayer はコマンドラインから使うのが一番便利ですが、
133多くの操作は字幕と同様に、
134オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
135MPlayer には スキンを変更できる GUI も用意されていますし、
136また複数の非公式なフロントエンドも利用できます。
[615]137
138MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
[1448]139非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
[615]140
141MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
142を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
143いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
144をインストールする必要があります。
145
146
147%prep
[6328]148#% setup -q -n mplayer-export-%{svndate}
149%setup -q -n MPlayer-%{version}
150%__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
[615]151
[5297]152%patch2 -p1 -b .vine
[615]153%patch8 -p1 -b .manlinks
[9973]154#%patch14 -p1 -b .nodvdcss
[5297]155%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
[615]156
157%build
158./configure \
159    --prefix=%{_prefix} \
[5297]160    --bindir=%{_bindir} \
161    --datadir=%{_datadir}/mplayer \
162    --mandir=%{_mandir} \
[615]163    --confdir=%{_sysconfdir}/mplayer \
[5297]164    --libdir=%{_libdir} \
[6241]165    --codecsdir=%{codecdir} \
[5297]166    \
167    --extra-cflags="$RPM_OPT_FLAGS" \
168    --language=ja,en \
169    --enable-joystick \
170    --enable-gui --enable-menu \
171    --enable-radio --enable-radio-capture \
[615]172    --enable-runtime-cpudetection \
[6241]173    --enable-unrarexec \
[5297]174    \
175    --disable-nemesi \
[615]176    \
[5297]177    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
178    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
179    %{!?with_faac:--disable-faac} \
180    --disable-libmpeg2-internal \
[615]181    --disable-libopenjpeg \
182    \
183    --disable-bitmap-font \
[5297]184    --disable-dga1 --disable-dga2 \
185    --disable-directfb \
186    --disable-svga \
[615]187    --disable-termcap \
188    --enable-xvmc \
189    --with-xvmclib=XvMCW \
190    \
[5297]191    --disable-arts --disable-esd --disable-jack --disable-openal \
[6241]192    --disable-live \
[615]193    ;
194
[5297]195%{__make} V=1 %{?_smp_mflags}
[615]196
197%install
198%{__rm} -rf ${RPM_BUILD_ROOT}
[1306]199%{__make} install INSTALLSTRIP= \
200    prefix=${RPM_BUILD_ROOT}%{_prefix} \
201    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
202    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
203    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
204    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
205    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
206    ;
[615]207
208## install some default config files
209%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
210%{__install} -pm 644 etc/example.conf \
211    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
212%{__install} -pm 644 etc/{input,menu,codecs}.conf \
213    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
214
[6241]215# # Icons
216# for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
217#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
218#     install -pm 644 etc/mplayer$iconsize.png \
219#         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
220# done
[5297]221
[6328]222# install skins and set the default skin
[615]223%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
224pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
[6328]225  for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
226    %__tar xf ${x} || exit 1
227  done
228  %__ln_s Blue default || exit 1
[615]229popd
230
231# make sybolic link to ttf font for subtitle
232for i in %{ttfontlist}; do
233    if [ -e %{ttfontdir}/$i.ttf ];then
234        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
235        break;
236    fi;
237done
238
239## install TOOLS
240for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
241%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
242done
243
244for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
245%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
246done
247
248for file in vobshift.py ; do
249%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
250done
251
252%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
253%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
254
255
256%clean
257%{__rm} -rf ${RPM_BUILD_ROOT}
258
[5297]259%post
260touch --no-create %{_datadir}/icons/hicolor
261if [ -x %{_bindir}/gtk-update-icon-cache ]; then
262  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
263fi
264%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
[615]265
[5297]266%postun
267%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
268touch --no-create %{_datadir}/icons/hicolor
269if [ -x %{_bindir}/gtk-update-icon-cache ]; then
270  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
271fi || :
272
273
[615]274%files
275%defattr(-,root,root)
[5297]276#%doc AUTHORS Changelog Copyright LICENSE README
[615]277%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
278%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
279%config(noreplace) %{_sysconfdir}/mplayer/input.conf
280%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
281%{_bindir}/mplayer
282%{_bindir}/gmplayer
283%{_bindir}/mencoder
[6328]284%{_datadir}/mplayer/skins/default
[615]285%{_datadir}/mplayer/skins/Blue
[6328]286%{_datadir}/mplayer/skins/Blue-small
287%{_datadir}/mplayer/skins/OSX-Mod
288%{_datadir}/mplayer/skins/standard
[615]289%{_datadir}/mplayer/subfont.ttf
290%{_datadir}/applications/mplayer.desktop
[6241]291%{_datadir}/icons/hicolor/*/apps/mplayer.png
[615]292%{_mandir}/man1/mplayer.1*
293%{_mandir}/man1/mencoder.1*
294## TOOLS
295%{_bindir}/aconvert
296%{_bindir}/calcbpp
297%{_bindir}/countquant
298%{_bindir}/divx2svcd
299%{_bindir}/dvd2divxscript
300%{_bindir}/mencvcd
301%{_bindir}/midentify
302%{_bindir}/mpconsole
303%{_bindir}/qepdvcd
304%{_bindir}/subsearch
305%{_bindir}/vobshift
306%{_datadir}/mplayer/*.fp
307
308
309%changelog
[10524]310* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
311- rebuild with libcdio-0.93
312
[9973]313* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
314- new upstream release
315
[9663]316* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-4
317- rebuilt
318
[9215]319* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-3
320- rebuilt with ffmpeg-0.11.5
321
[7874]322* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
323- remove some obsolete comments
324
[7842]325* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
326- updated to 1.1.1
327- build with new x264 (ABI 0.136) and ffmpeg 0.11.4 (libav 0.8.2 as of 2012-09-19)
328
329* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-2
330- rebuilt with new x264 (ABI 0.129) and ffmpeg 0.11.2 (libav 0.8.2)
331
[6328]332* Wed Jun 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1-1
333- updated to 1.1
334  - built with ffmpeg-0.11.1
335- added some skins
336
[6241]337* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
338- updated snapshot 20120525 with ffmpeg 0.11
339
340* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-46.20120102
341- updated snapshot 20120102
342
343* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111210
[5297]344- updated snapshot 20111217 (with ffmpeg 0.9)
345
[5085]346* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
347- s/self-build-libdvdnav/libdvdnav/
348
[4935]349* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
350- updated %%SOURCE1
351  - update to 1.8
352
[4182]353* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
354- dropped BuildRequires: esound-devel
355
[3126]356* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
357- new upstream release
358  - ready for Vine Linux 6
359  - revived support for Vine Linux 5
360- added BuildRequires:
361  - libass-devel
362  - librtmp-devel >= 2.3
363  - speex-devel >= 1.1
364
[2621]365* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
366- added BuildRequires:
367  - aalib-devel
368  - enca-devel
369  - lzo-devel
370  - speex-devel
371
[1448]372* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
373- updated fixed %{name}-config.patch
374  - applied %{name}-config-20100709-vine.patch
375
[1374]376* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
377- change release to sync with self-build-mplayer
378
[1306]379* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
380- updated source snapshot 20100709
381- renamed %%Source10 to mplayer-snapshot-vine.sh
382- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
383- added BuildRequires: libvpx-devel >= 0.9.1
384
[1258]385* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
386- updated source snapshot 20100621
387
388* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
389- updated source snapshot 20100615
390- added BuildRequires: libXinerama-devel
391- dropped vl4 support
392
393* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
394- updated source snapshot 20100410
395
[785]396* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
397- updated source snapshot 20100401
398
399* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
400- updated source snapshot 20100326
401
[615]402* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
403- updated source snapshot 20100317
404
405* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
406- updated source snapshot 20100216
407- moved scripts from TOOLS
408- added --disable-libopenjpeg in configure options
409
410* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
411- updated source snapshot 20100201
412- dropped obsolete patches
413- added BuildRequires:
414  - libvdpau-devel
415  - libXScrnSaver-devel
416
417* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
418- update mplayer-config-20091215-vine.patch
419- update mplayer-20091215-x86_32-compile.patch
420- added --enable-runtime-cpudetection in configure options
421
422* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
423- source snapshot 20091031
424  - updated mplayer-20091031-x86_32-compile.patch
425
426* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
427- source snapshot 20091003
428
429* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
430- change release to sync with self-build-mplayer
431
432* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
433- source snapshot 20090905
434- added settings for vl6
435
[9973]436* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
[615]437- source snapshot 20090821
438- replaced BR: libungif-devel with BR: giflib-devel
439
440* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
441- source snapshot 20090722
442
443* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
444- source snapshot 20090702
445
446* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
447- source snapshot 20090611
448
449* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
450- added Requires: TrueType-vlgothic
451
452* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
453- source snapshot 20090522
454  - build with x264 >= 0.0.0-9.20090522
455  - updated mplayer-20090522-nodvdcss.patch
456
457* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
458- change release to sync with self-build-mplayer
459
460* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
461- source snapshot 20090502
462- updated mplayer-20090503-x86_32-compile.patch
463- updated mplayer-20090502-nodvdcss.patch
464
465* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
466- applied mplayer-config-vine.patch
467
468* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
469- source snapshot 20090327
470- updated mplayer-20090327-x86_32-compile.patch
471- updated mplayer-20090325-nodvdcss.patch
472- dropped gmplayer-about-vine.patch
473- install some default config files
474- added configure options:
475  - --disable-termcap
476  - --enable-xvmc
477  - --with-xvmclib=XvMCW
478- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
479- fixed %%files for *.conf
480
481* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
482- source snapshot 20090305
483
484* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
485- source snapshot 20090227
486
487* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
488- source snapshot 20090216
489
490* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
491- source snapshot 20090206
492- dropped mplayer-man-zh_CN.patch
493- updated mplayer-20090206-nodvdcss.patch
494- changed to PreReq:  self-build-faad2 from faad2-devel
495- added PreReq:  self-build-libmad
496
497* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
498- source snapshot 20090131
499
500* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
501- change release to sync with self-build-mplayer
502
503* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
504- source snapshot
505- update mplayer-20090122-nodvdcss.patch
506- added BuildRequires:
507  - faad2-devel
508  - libmpcdec-devel
509  - twolame-devel
510  - yasm
511  - faac-devel (as PreReq in self-build-%{name})
512  - lame-devel (as PreReq in self-build-%{name})
513  - libdca-devel (as PreReq in self-build-%{name})
514  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
515  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
516
517* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
518- source snapshot
519- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
520  --disable-faad-internal in configure options
521- dropped gmplayer-add-flv-extension.patch
522
523* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
524- source snapshot
525- fixed License
526- added some patches from RPM Fusion
527- updated gmplayer-about-vine.patch for 20081001 snapshot
528- added BuildRequires:  libdvdread
529- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
530- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
531  in configure options
532#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
533
534* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
535- fixed License
536- added some devel packages to support OpenGL
537
538* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
539- spec in utf8
540- fix sybolic link of subfont for vl5
541
542* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
543- add "Patch105: CVE-2008-1558.patch".
544
545* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
546- build with new versioning policy.
547- fix Source[01] URLs.
548- add "Patch200: gmplayer-about-vine.patch".
549- add "Patch201: gmplayer-add-flv-extension.patch".
550
551* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
552- add four official security patches (CVE-2008-0485, CVE-2008-0486,
553  CVE-2008-0629, CVE-2008-0630)
554- add mplayer-1.0rc2-20080211-stream_cddb.patch
555
556* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
557- change source download URL. <BTS:VineLinux:603>
558
559* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
560- fix CONFDIR for make install. <BTS:wishes:33>
561
562* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
563- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.