source: projects/specs/trunk/nonfree/self-build-mjpegtools/self-build-mjpegtools-vl.spec @ 7842

Revision 7842, 5.4 KB checked in by munepi, 11 years ago (diff)

new x264 (ABI 0.136)

Line 
1%define pkgname mjpegtools
2%define name    self-build-%{pkgname}
3%define version 2.0.0
4%define release 3%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13
14Source0:        %{pkgname}-vl.spec
15Source100:      mjpegtools-2.0.0-no-config-in-public-header.h
16Source101:      mjpegtools_gcc470.patch
17
18License:        GPLv2+
19Group:          Restricted Software
20
21Obsoletes:      mjpegtools < %{version}, mjpegtools-devel < %{version}
22Obsoletes:      self-build-mjpegtools < %{version}-%{release}
23
24# Requires(posttrans) not yet implemented. So we use (post) instead.
25Requires(post): self-build-setup >= 0.9.0
26
27Requires(post):  libjpeg-devel
28Requires(post):  nasm
29Requires(post):  libdv-devel
30Requires(post):  SDL-devel >= 1.1.3
31Requires(post):  SDL_gfx-devel
32Requires(post):  self-build-libquicktime >= 1.2.0
33Requires(post):  libpng-devel
34Requires(post):  gtk2-devel >= 2.4.0
35Requires(post):  self-build-mplayer >= 1.1
36Requires(post):  self-build-ffmpeg >= 1.1.0
37#Requires(post):  y4mscaler
38Requires:  which
39Requires(post): /sbin/install-info
40Requires(preun): /sbin/install-info
41
42BuildArch:      noarch
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44
45Packager:       munepi
46
47%description
48The mjpeg programs are a set of tools that can do recording of videos
49and playback, simple cut-and-paste editing and the MPEG compression of
50audio and video under Linux.
51
52
53If you install this package, it automaticaly downloads source
54code ,compile it, and create rpm packages of %{pkgname}-%{version}.
55And the created rpm packages are automatically installed
56if installation is executed by apt-get command or synaptic
57package manager.
58
59[Note]
60This package requires many other packages to compile
61targetsoftware. So it consume more disk space than usual.
62Also installation takes logner time because of compilation.
63(This will take a few minutes to quarter or half of an hour,
64depends on building environment)
65
66[About self-build package]
67For some kind of software, distributing of binary package
68may viorate the patent or law. Therefore we chose self-build
69packge, create binary package on your machine, for such kind
70of softwares instead of distributing binary package.
71
72Please obey the national law when you use the created binary
73packages. And if you want to use the softwares using patented
74thechnology, it may be required to get a permission, make an
75agreement or purchas a license. Please consider it with your
76purpose or way of use and take appropriate action.
77
78%description -l ja
79mjpegtools は、Linux 上で
80ビデオ録画や再生、
81簡単なカット&ペーストの編集、
82オーディオやビデオの MPEG 圧縮
83ができるツール集です。
84
85
86このパッケージをインストールすると、自動的にソースコードを
87ダウンロードしてコンパイルし、%{pkgname}-%{version}
88の rpm パッケージを作成します。
89また apt-get コマンドや synaptic パッケージマネージャから実行
90した場合は、作成された rpm パッケージのインストールも自動的に
91行います。
92
93[注意]
94コンパイルに必要な多くの関連パッケージを要求するので通常より
95ディスクの領域を多く消費します。
96またインストール時にコンパイルを行うため、通常より時間がかか
97る場合があります。(環境にもよりますが数分から数十分程度)
98
99[self-build パッケージについて]
100ソフトウェアによってはバイナリパッケージの配布が特許や法律に
101違反する可能性があるものがあります。その為、このような問題が
102懸念されるソフトウェアについてはバイナリパッケージを直接配布
103せずに、ユーザの環境でバイナリを作成する self-build パッケー
104ジという方法を採っています。
105
106作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
107アのライセンス、および利用する国の各種法令に従ってください。
108また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
109センスの購入などが必要となる場合がありますので、利用する目的
110や形態に応じて各自で判断し適切な対応を取ってください。
111
112
113%prep
114[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
115
116
117%install
118%{__rm} -rf ${RPM_BUILD_ROOT}
119%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121%{__install} -m 644 %{SOURCE100} %{SOURCE101}  \
122    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
123
124
125%clean
126%{__rm} -rf ${RPM_BUILD_ROOT}
127
128%posttrans
129/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 172000
130/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
131                                 %{pkgname}-devel-%{version}-%{release}
132
133%files
134%defattr(-,root,root)
135%{_datadir}/%{name}/*
136
137
138%changelog
139* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
140- rebuild
141
142* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
143- rebuild
144
145* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
146- new upstream release
147
148* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
149- initial build
150
151### end of file
Note: See TracBrowser for help on using the repository browser.