source: projects/specs/trunk/nonfree/self-build-mjpegtools/self-build-mjpegtools-vl.spec @ 9215

Revision 9215, 5.7 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%define pkgname mjpegtools
2%define name    self-build-%{pkgname}
3%define version 2.1.0
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/mjpeg/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13
14Source0:        %{pkgname}-vl.spec
15Source100:      mjpegtools-2.1.0-sdl-cflags.patch
16Source101:      mjpegtools-2.1.0-no_format.patch
17Source102:      mjpegtools-2.1.0-pic.patch
18
19License:        GPLv2+
20Group:          Restricted Software
21
22Obsoletes:      mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
23Obsoletes:      self-build-mjpegtools < %{version}-%{release}
24
25# Requires(posttrans) not yet implemented. So we use (post) instead.
26Requires(post): self-build-setup >= 0.9.0
27
28Requires(post):  libjpeg-devel
29Requires(post):  nasm
30Requires(post):  libdv-devel
31Requires(post):  SDL-devel >= 1.1.3
32Requires(post):  SDL_gfx-devel
33Requires(post):  self-build-libquicktime >= 1.2.0
34Requires(post):  libpng-devel
35Requires(post):  gtk2-devel >= 2.4.0
36Requires(post):  self-build-mplayer >= 1.1
37Requires(post):  self-build-ffmpeg >= 1.1.0
38#Requires(post):  y4mscaler
39Requires:  which
40Requires(post): /sbin/install-info
41Requires(preun): /sbin/install-info
42
43BuildArch:      noarch
44BuildRoot:      %{_tmppath}/%{name}-%{version}-root
45
46Packager:       munepi
47
48%description
49The mjpeg programs are a set of tools that can do recording of videos
50and playback, simple cut-and-paste editing and the MPEG compression of
51audio and video under Linux.
52
53
54If you install this package, it automaticaly downloads source
55code ,compile it, and create rpm packages of %{pkgname}-%{version}.
56And the created rpm packages are automatically installed
57if installation is executed by apt-get command or synaptic
58package manager.
59
60[Note]
61This package requires many other packages to compile
62targetsoftware. So it consume more disk space than usual.
63Also installation takes logner time because of compilation.
64(This will take a few minutes to quarter or half of an hour,
65depends on building environment)
66
67[About self-build package]
68For some kind of software, distributing of binary package
69may viorate the patent or law. Therefore we chose self-build
70packge, create binary package on your machine, for such kind
71of softwares instead of distributing binary package.
72
73Please obey the national law when you use the created binary
74packages. And if you want to use the softwares using patented
75thechnology, it may be required to get a permission, make an
76agreement or purchas a license. Please consider it with your
77purpose or way of use and take appropriate action.
78
79%description -l ja
80mjpegtools は、Linux 上で
81ビデオ録画や再生、
82簡単なカット&ペーストの編集、
83オーディオやビデオの MPEG 圧縮
84ができるツール集です。
85
86
87このパッケージをインストールすると、自動的にソースコードを
88ダウンロードしてコンパイルし、%{pkgname}-%{version}
89の rpm パッケージを作成します。
90また apt-get コマンドや synaptic パッケージマネージャから実行
91した場合は、作成された rpm パッケージのインストールも自動的に
92行います。
93
94[注意]
95コンパイルに必要な多くの関連パッケージを要求するので通常より
96ディスクの領域を多く消費します。
97またインストール時にコンパイルを行うため、通常より時間がかか
98る場合があります。(環境にもよりますが数分から数十分程度)
99
100[self-build パッケージについて]
101ソフトウェアによってはバイナリパッケージの配布が特許や法律に
102違反する可能性があるものがあります。その為、このような問題が
103懸念されるソフトウェアについてはバイナリパッケージを直接配布
104せずに、ユーザの環境でバイナリを作成する self-build パッケー
105ジという方法を採っています。
106
107作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
108アのライセンス、および利用する国の各種法令に従ってください。
109また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
110センスの購入などが必要となる場合がありますので、利用する目的
111や形態に応じて各自で判断し適切な対応を取ってください。
112
113
114%prep
115[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
116
117
118%install
119%{__rm} -rf ${RPM_BUILD_ROOT}
120%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122%{__install} -m 644 %{SOURCE100} %{SOURCE101} %{SOURCE102} \
123    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
124
125
126%clean
127%{__rm} -rf ${RPM_BUILD_ROOT}
128
129%posttrans
130/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 172000
131/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
132                                 %{pkgname}-devel-%{version}-%{release}
133
134%files
135%defattr(-,root,root)
136%{_datadir}/%{name}/*
137
138
139%changelog
140* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
141- new upstream release
142
143* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-4
144- added Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
145
146* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
147- rebuild
148
149* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
150- rebuild
151
152* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
153- new upstream release
154
155* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
156- initial build
157
158### end of file
Note: See TracBrowser for help on using the repository browser.