source: projects/specs/trunk/nonfree/self-build-mjpegtools/mjpegtools-vl.spec @ 7842

Revision 7842, 9.0 KB checked in by munepi, 11 years ago (diff)

new x264 (ABI 0.136)

Line 
1# -*- coding: utf-8-unix -*-
2Name:           mjpegtools
3Version:        2.0.0
4Release:        3%{?_dist_release}
5Summary:        Tools to manipulate MPEG data
6Summary(ja):    MPEG データを操作するツール集
7
8Group:          Applications/Multimedia
9License:        GPLv2
10URL:            http://mjpeg.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
12Patch0:         mjpegtools-2.0.0-no-config-in-public-header.h
13Patch1:         mjpegtools_gcc470.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Obsoletes:      mjpegtools < %{version}, mjpegtools-devel < %{version}
18
19BuildRequires:  libjpeg-devel
20BuildRequires:  nasm
21BuildRequires:  libdv-devel
22BuildRequires:  SDL-devel >= 1.1.3
23BuildRequires:  SDL_gfx-devel
24#BuildRequires:  libquicktime-devel >= 0.9.8
25#BuildRequires:  self-build-libquicktime >= 0.9.8
26BuildRequires:  libpng-devel
27BuildRequires:  gtk2-devel >= 2.4.0
28# mencoder for lav2avi.sh
29#Requires:       mencoder
30#Requires:       self-build-mplayer
31# ffmpeg main package, y4mscaler and which for anytovcd.sh
32#Requires:       ffmpeg
33#Requires:       self-build-ffmpeg
34#Requires:       y4mscaler
35Requires:       which
36Requires(post): /sbin/install-info
37Requires(preun): /sbin/install-info
38
39%description
40The mjpeg programs are a set of tools that can do recording of videos
41and playback, simple cut-and-paste editing and the MPEG compression of
42audio and video under Linux. 
43
44%description -l ja
45mjpegtools は、Linux 上でビデオ録画や再生、
46簡単なカット&ペーストの編集、オーディオやビデオの MPEG 圧縮ができる
47ツール集です。
48
49%package        devel
50Summary:        Development files for mjpegtools libraries
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       pkgconfig
54
55%description    devel
56The mjpeg programs are a set of tools that can do recording of videos
57and playback, simple cut-and-paste editing and the MPEG compression of
58audio and video under Linux.  This package contains development files
59for building applications that use mjpegtools libraries.
60
61
62%prep
63%setup -q
64%patch0 -p1
65%patch1 -p1
66
67%__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
68%__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
69for f in docs/yuvfps.1 ; do
70    iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
71done
72
73
74%build
75%configure --disable-dependency-tracking --disable-static
76%__make # %{?_smp_mflags}
77
78
79%install
80%__rm -rf $RPM_BUILD_ROOT
81%__make install DESTDIR=$RPM_BUILD_ROOT
82%__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
83# too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
84%__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
85
86
87%clean
88%__rm -rf $RPM_BUILD_ROOT
89
90
91%post
92/sbin/ldconfig
93/sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
94
95%postun
96/sbin/ldconfig
97
98%preun
99[ $1 -eq 0 ] && \
100/sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
101
102
103%files
104%defattr(-,root,root,-)
105%doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
106%{_bindir}/*
107%{_mandir}/man1/*.1*
108%{_mandir}/man5/yuv4mpeg.5*
109%{_infodir}/mjpeg-howto.info*
110## gui
111%doc README.glav
112#%{_bindir}/glav
113# lavplay and yuvplay won't save -libs/console util users from X11 and SDL
114# dependencies as long as liblavplay is in -libs, but they're inherently
115# GUI tools -> include them here
116#%{_bindir}/lavplay
117#%{_bindir}/y4mhist
118#%{_bindir}/yuvplay
119#%{_mandir}/man1/lavplay.1*
120#%{_mandir}/man1/yuvplay.1*
121## libs
122%{_libdir}/lib*.so.*
123
124%files devel
125%defattr(-,root,root,-)
126%{_includedir}/%{name}
127%{_libdir}/lib*.so
128%{_libdir}/pkgconfig/%{name}.pc
129
130
131%changelog
132* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
133- rebuild
134
135* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
136- rebuild
137
138* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
139- new upstream release
140
141* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
142- new upstream release
143
144* Fri Sep  3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
145- Fix a memleak which is causing issues for LiVES
146
147* Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
148- Update to upstream 1.9.0 final release
149
150* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
151- rebuild for new F11 features
152
153* Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
154- initial build
155
156* Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
157- Release bump for rpmfusion
158- Sync with freshrpms (no changes)
159
160* Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
161- Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
162
163* Tue Dec  4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
164- 1.9.0rc3.
165
166* Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
167- Requires: which
168
169* Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
170- License: GPLv2
171
172* Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
173- Rebuild.
174
175* Fri Jun  8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
176- 1.9.0rc2.
177
178* Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
179- Split GUI utilities into -gui subpackage.
180- Don't ship mpegtranscode, it's broken/outdated.
181- Require mencoder for lav2avi.sh.
182
183* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
184- rebuilt for unwind info generation, broken in gcc-4.1.1-21
185
186* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
187- Specfile cleanup.
188
189* Sun Jun  4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
190- Get rid of undefined non-weak symbols in liblav*.
191- Apply upstream fix for compiling with libquicktime 0.9.8.
192
193* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
194- switch to new release field
195
196* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
197- add dist
198
199* Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
200- Include license text in -libs, it can be installed without the main package.
201- Convert yuvfps man page to UTF-8.
202- Fix -devel Group tag.
203
204* Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
205- Added patch to compile with gcc 4.1
206- Dropped 0 Epoch
207
208* Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
209- 1.8.0.
210
211* Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
212- 1.6.3-rc3, Altivec fixes applied upstream.
213
214* Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
215- 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
216- Fix Altivec build, kudos to upstream.
217
218* Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
219- 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
220
221* Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
222- PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
223
224* Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
225- Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
226- Require pkgconfig in -devel.
227
228* Wed Feb  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
229- Add corrected -fPIC tweak from Thorsten.
230
231* Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
232- Include PNG input support.
233- Remove no-op $RPM_OPT_FLAGS setting from %%build.
234- Remove bogus optimization settings from configure script.
235
236* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
237- CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
238  option --with-pic is not enough
239
240* Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
241- Disabling static libraries building
242
243* Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
244- Include quicktime support.
245- Apply patch from ALT Linux to fix info pages, fix typo in %%post.
246- Require /sbin/install-info.
247- Add "--without static" rpmbuild option to work around an issue with FC3 strip
248- Always enable SIMD accelerations, CPU capabilities detected at runtime.
249- Always disable use of cmov.
250
251* Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
252- Added patch to fix gcc3.4 build
253- Detected race condition in Makefiles (disabling _smp_mflags use)
254- Added info files & scriptlets
255- Dropped patch0 and patch1
256
257* Tue Jun  8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
258- Updated to 1.6.2
259
260* Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
261- Removed comment after scriptlets
262
263* Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
264- buildroot -> RPM_BUILD_ROOT
265
266* Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
267- Applied upstream patches to fix build on gcc3.3 systems
268
269* Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
270- Now test arch for configure options (from Ville)
271- Removed ImageMagick-devel BuildRequires
272
273* Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
274- Added missing BuildRequires
275- Added post/postun scriplets for libs package
276
277* Wed Apr 23 2003 Dams <anvil[AT]livna.org>
278- Initial build.
Note: See TracBrowser for help on using the repository browser.