source: projects/specs/trunk/nonfree/self-build-mjpegtools/mjpegtools-vl.spec @ 9215

Revision 9215, 9.3 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1# -*- coding: utf-8-unix -*-
2Name:           mjpegtools
3Version:        2.1.0
4Release:        1%{?_dist_release}
5Summary:        Tools to manipulate MPEG data
6Summary(ja):    MPEG データを操作するツール集
7
8Group:          Applications/Multimedia
9License:        GPLv2
10URL:            http://mjpeg.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
12Patch0:         mjpegtools-2.1.0-sdl-cflags.patch
13Patch1:         mjpegtools-2.1.0-no_format.patch
14Patch2:         mjpegtools-2.1.0-pic.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
19
20BuildRequires:  libjpeg-devel
21BuildRequires:  nasm
22BuildRequires:  libdv-devel
23BuildRequires:  SDL-devel >= 1.1.3
24BuildRequires:  SDL_gfx-devel
25#BuildRequires:  libquicktime-devel >= 0.9.8
26#BuildRequires:  self-build-libquicktime >= 0.9.8
27BuildRequires:  libpng-devel
28BuildRequires:  gtk2-devel >= 2.4.0
29# mencoder for lav2avi.sh
30#Requires:       mencoder
31#Requires:       self-build-mplayer
32# ffmpeg main package, y4mscaler and which for anytovcd.sh
33#Requires:       ffmpeg
34#Requires:       self-build-ffmpeg
35#Requires:       y4mscaler
36Requires:       which
37Requires(post): /sbin/install-info
38Requires(preun): /sbin/install-info
39
40%description
41The mjpeg programs are a set of tools that can do recording of videos
42and playback, simple cut-and-paste editing and the MPEG compression of
43audio and video under Linux. 
44
45%description -l ja
46mjpegtools は、Linux 上でビデオ録画や再生、
47簡単なカット&ペーストの編集、オーディオやビデオの MPEG 圧縮ができる
48ツール集です。
49
50%package        devel
51Summary:        Development files for mjpegtools libraries
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       pkgconfig
55
56%description    devel
57The mjpeg programs are a set of tools that can do recording of videos
58and playback, simple cut-and-paste editing and the MPEG compression of
59audio and video under Linux.  This package contains development files
60for building applications that use mjpegtools libraries.
61
62
63%prep
64%setup -q
65%patch0 -p1 -b .sdl
66%patch1 -p1 -b .format
67%patch2 -p0 -b .fpic
68
69%__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
70%__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
71for f in docs/yuvfps.1 ; do
72    iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
73done
74
75
76%build
77%configure --disable-dependency-tracking --disable-static
78%__make # %{?_smp_mflags}
79
80
81%install
82%__rm -rf $RPM_BUILD_ROOT
83%__make install DESTDIR=$RPM_BUILD_ROOT
84%__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
85# too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
86%__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
87
88
89%clean
90%__rm -rf $RPM_BUILD_ROOT
91
92
93%post
94/sbin/ldconfig
95/sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
96
97%postun
98/sbin/ldconfig
99
100%preun
101[ $1 -eq 0 ] && \
102/sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
103
104
105%files
106%defattr(-,root,root,-)
107%doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
108%{_bindir}/*
109%{_mandir}/man1/*.1*
110%{_mandir}/man5/yuv4mpeg.5*
111%{_infodir}/mjpeg-howto.info*
112## gui
113%doc README.glav
114%{_bindir}/glav
115# lavplay and yuvplay won't save -libs/console util users from X11 and SDL
116# dependencies as long as liblavplay is in -libs, but they're inherently
117# GUI tools -> include them here
118%{_bindir}/lavplay
119%{_bindir}/y4mhist
120%{_bindir}/yuvplay
121%{_mandir}/man1/lavplay.1*
122%{_mandir}/man1/yuvplay.1*
123## libs
124%{_libdir}/lib*.so.*
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/%{name}
129%{_libdir}/lib*.so
130%{_libdir}/pkgconfig/%{name}.pc
131%{_includedir}/%{name}/*lav*.h
132%{_libdir}/liblav*.so
133
134
135%changelog
136* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
137- new upstream release
138
139* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-4
140- added Obsoletes: mjpegtools < %{version}-%{release}, mjpegtools-devel < %{version}-%{release}
141
142* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-3
143- rebuild
144
145* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-2
146- rebuild
147
148* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
149- new upstream release
150
151* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
152- new upstream release
153
154* Fri Sep  3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
155- Fix a memleak which is causing issues for LiVES
156
157* Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
158- Update to upstream 1.9.0 final release
159
160* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
161- rebuild for new F11 features
162
163* Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
164- initial build
165
166* Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
167- Release bump for rpmfusion
168- Sync with freshrpms (no changes)
169
170* Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
171- Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
172
173* Tue Dec  4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
174- 1.9.0rc3.
175
176* Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
177- Requires: which
178
179* Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
180- License: GPLv2
181
182* Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
183- Rebuild.
184
185* Fri Jun  8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
186- 1.9.0rc2.
187
188* Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
189- Split GUI utilities into -gui subpackage.
190- Don't ship mpegtranscode, it's broken/outdated.
191- Require mencoder for lav2avi.sh.
192
193* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
194- rebuilt for unwind info generation, broken in gcc-4.1.1-21
195
196* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
197- Specfile cleanup.
198
199* Sun Jun  4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
200- Get rid of undefined non-weak symbols in liblav*.
201- Apply upstream fix for compiling with libquicktime 0.9.8.
202
203* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
204- switch to new release field
205
206* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
207- add dist
208
209* Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
210- Include license text in -libs, it can be installed without the main package.
211- Convert yuvfps man page to UTF-8.
212- Fix -devel Group tag.
213
214* Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
215- Added patch to compile with gcc 4.1
216- Dropped 0 Epoch
217
218* Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
219- 1.8.0.
220
221* Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
222- 1.6.3-rc3, Altivec fixes applied upstream.
223
224* Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
225- 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
226- Fix Altivec build, kudos to upstream.
227
228* Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
229- 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
230
231* Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
232- PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
233
234* Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
235- Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
236- Require pkgconfig in -devel.
237
238* Wed Feb  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
239- Add corrected -fPIC tweak from Thorsten.
240
241* Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
242- Include PNG input support.
243- Remove no-op $RPM_OPT_FLAGS setting from %%build.
244- Remove bogus optimization settings from configure script.
245
246* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
247- CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
248  option --with-pic is not enough
249
250* Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
251- Disabling static libraries building
252
253* Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
254- Include quicktime support.
255- Apply patch from ALT Linux to fix info pages, fix typo in %%post.
256- Require /sbin/install-info.
257- Add "--without static" rpmbuild option to work around an issue with FC3 strip
258- Always enable SIMD accelerations, CPU capabilities detected at runtime.
259- Always disable use of cmov.
260
261* Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
262- Added patch to fix gcc3.4 build
263- Detected race condition in Makefiles (disabling _smp_mflags use)
264- Added info files & scriptlets
265- Dropped patch0 and patch1
266
267* Tue Jun  8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
268- Updated to 1.6.2
269
270* Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
271- Removed comment after scriptlets
272
273* Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
274- buildroot -> RPM_BUILD_ROOT
275
276* Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
277- Applied upstream patches to fix build on gcc3.3 systems
278
279* Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
280- Now test arch for configure options (from Ville)
281- Removed ImageMagick-devel BuildRequires
282
283* Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
284- Added missing BuildRequires
285- Added post/postun scriplets for libs package
286
287* Wed Apr 23 2003 Dams <anvil[AT]livna.org>
288- Initial build.
Note: See TracBrowser for help on using the repository browser.