source: projects/specs/trunk/nonfree/self-build-minidlna/self-build-minidlna-vl.spec @ 11754

Revision 11754, 5.7 KB checked in by iwaim, 6 years ago (diff)

self-build-minidlna: add files

Line 
1# Basic Information
2%define pkgname minidlna
3%define name    self-build-%{pkgname}
4%define version 1.2.1
5%define release 2%{?_dist_release}
6
7%define sourceurl0 http://sourceforge.net/projects/%{pkgname}/files/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
8
9Name:           %{name}
10Version:        %{version}
11Release:        %{release}
12# COPYING  などを参照して License を修正してください。
13License:        GPLv2+
14# /usr/share/doc/rpm-4.11.1/GROUPS_for_vine.txt を参照して Group を修正してください。
15Group:          Restricted Software
16Source0:        %{pkgname}-vl.spec
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildArch:      noarch
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       Shirow HIGA
23
24Summary:        Package to automatically build %{pkgname} rpm package
25Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
26
27Obsoletes:      minidlna < %{version}
28Obsoletes:      self-build-minidlna < %{version}
29
30# Dependency
31# 以下に依存関係を記述してください 。
32Requires(post): self-build-setup >= 0.9.9
33
34Requires(post): libuuid-devel
35Requires(post): sqlite3-devel
36Requires(post): libvorbis-devel
37Requires(post): flac-devel
38Requires(post): libid3tag-devel
39Requires(post): libjpeg-turbo-devel
40Requires(post): libexif-devel
41Requires(post): gettext-devel
42
43Requires(post): self-build-ffmpegthumbnailer
44
45#追加のソースファイル
46Source1:        minidlna.init.d.script
47Source2:        minidlna.icons.c.custom
48#Source3:       minidlna_configure_v113.patch
49#Source4:       minidlna_make_v116.patch
50Source5:        minidlna_video_thumbnail_v121.patch
51#Source6:       minidlna_bravia_v116.patch
52
53%description
54MiniDLNA (aka ReadyDLNA) is server software with the aim of being fully
55compliant with DLNA/UPnP-AV clients.
56
57The minidlna daemon serves media files (music, pictures, and video) to
58clients on your network.  Example clients include applications such as
59Totem and XBMC, and devices such as portable media players, smartphones,
60and televisions.
61
62[Note]                                                                                                                      This package requires many other packages to compile                                                                        targetsoftware. So it consume more disk space than usual.                                                                   
63Also installation takes logner time because of compilation.                                                                 (This will take a few minutes to quarter or half of an hour,
64depends on building environment)
65                                                                                                                            [About self-build package]                                                                                                  For some kind of software, distributing of binary package                                                                   
66may viorate the patent or law. Therefore we chose self-build
67packge, create binary package on your machine, for such kind
68of softwares instead of distributing binary package.                                                                                                                                                                                                    Please obey the national law when you use the created binary                                                               
69packages. And if you want to use the softwares using patented
70thechnology, it may be required to get a permission, make an
71agreement or purchas a license. Please consider it with your
72purpose or way of use and take appropriate action.
73
74#%description -l ja
75#ここに日本語で詳細を記述してください。
76
77%prep
78[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
79
80%install
81%{__rm} -rf ${RPM_BUILD_ROOT}
82%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
83%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
84%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
85%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
86#%{__install} -m 644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
87#%{__install} -m 644 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
88%{__install} -m 644 %{SOURCE5} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
89#%{__install} -m 644 %{SOURCE6} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
90
91%clean
92%{__rm} -rf ${RPM_BUILD_ROOT}
93
94%posttrans
95/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 34000
96
97/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
98
99%files
100%defattr(-,root,root)
101%{_datadir}/%{name}
102
103%changelog
104* Thu Apr 24 2018 Shirow HIGA <shirowxxx@gmail.com> 1.2.0-2
105- Rebuild with ffmpeg 4.0
106
107* Fri Sep 15 2017 Shirow HIGA <shirowxxx@gmail.com> 1.2.1-1
108- new upstream release 1.2.1
109- Update Source5 (minidlna_video_thumbnail_v120.patch -> minidlna_video_thumbnail_v121.patch)
110
111* Fri May 26 2017 Shirow HIGA <shirowxxx@gmail.com> 1.2.0-1
112- new upstream release 1.2.0
113- Update Source5 (minidlna_video_thumbnail_v116.patch -> minidlna_video_thumbnail_v120.patch)
114
115* Sun Jan 22 2017 Shirow HIGA <shirowxxx@gmail.com> 1.1.6-3
116- Remove Source3 (minidlna_configure_v113.patch)
117- Remove Source4 (minidlna_make_v116.patch)
118- Remove Source6 (minidlna_bravia_v116.patch)
119
120* Mon Sep 19 2016 Shirow HIGA <shirowxxx@gmail.com> 1.1.6-2
121- add new Source6 (minidlna_bravia_v116.patch)
122
123* Mon Sep 12 2016 Shirow HIGA <shirowxxx@gmail.com> 1.1.6-1
124- new upstream release 1.1.6
125
126* Mon Sep 14 2015 Shirow HIGA <shirowxxx@gmail.com> 1.1.5-1
127- new upstream release 1.1.5
128
129* Thu Jan 15 2015 Shirow HIGA <shirowxxx@gmail.com> 1.1.4-1
130- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.