source: projects/specs/trunk/nonfree/self-build-mikutter/self-build-mikutter-vl.spec @ 10002

Revision 10002, 5.5 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define pkgname         mikutter
2
3%define sourceurl       http://mikutter.hachune.net/bin/%{pkgname}.%{version}.tar.gz
4
5Summary:        Package to automatically build %{pkgname} rpm package
6Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
7Name:           self-build-%{pkgname}
8Version:        3.2.12
9Release:        1%{?_dist_release}
10Source0:        %{pkgname}-vl.spec
11License:        GPLv3
12Group:          Restricted Software
13
14Requires(post):         self-build-setup >= 0.9.9
15
16# (build)requies of target package.
17Requires(post):         alsa-utils
18Requires(post):         ruby >= 1.9.3
19Requires(post):         ruby-gtk2 >= 1.5.0
20Requires(post):         rcairo >= 1.10.0
21Requires(post):         desktop-file-utils
22
23# for gem install
24Requires(post):         ruby-devel
25Requires(post):         zlib-devel
26
27BuildArch:      noarch
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Packager:       Takemikaduchi
31
32%description
33mikutter is simple, powerful and moeful twitter client.
34
35If you install this package, it automaticaly downloads source
36code, compile it, and create rpm packages of
37%{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42
43[Note]
44This package requires many other packages to compile
45targetsoftware. So it consume more disk space than usual.
46Also installation takes logner time because of compilation.
47(This will take a few minutes to quarter or half of an hour,
48depends on building environment)
49
50[About self-build package]
51For some kind of software, distributing of binary package
52may viorate the patent or law. Therefore we chose self-build
53packge, create binary package on your machine, for such kind
54of softwares instead of distributing binary package.
55
56Please obey the national law when you use the created binary
57packages. And if you want to use the softwares using patented
58thechnology, it may be required to get a permission, make an
59agreement or purchas a license. Please consider it with your
60purpose or way of use and take appropriate action.
61
62%description -l ja
63全てのミク廃、そして Twitter 中毒者へ贈る、至高の Twitter
64Client を目指す Twitter Client。
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version}
68の rpm パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73
74[注意]
75コンパイルに必要な多くの関連パッケージを要求するので通常より
76ディスクの領域を多く消費します。
77またインストール時にコンパイルを行うため、通常より時間がかか
78る場合があります。(環境にもよりますが数分から数十分程度)
79
80[self-build パッケージについて]
81ソフトウェアによってはバイナリパッケージの配布が特許や法律に
82違反する可能性があるものがあります。その為、このような問題が
83懸念されるソフトウェアについてはバイナリパッケージを直接配布
84せずに、ユーザの環境でバイナリを作成する self-build パッケー
85ジという方法を採っています。
86
87作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
88アのライセンス、および利用する国の各種法令に従ってください。
89また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
90センスの購入などが必要となる場合がありますので、利用する目的
91や形態に応じて各自で判断し適切な対応を取ってください。
92
93
94%prep
95[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
96
97
98%install
99%{__rm} -rf ${RPM_BUILD_ROOT}
100%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107%posttrans
108/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 5000
109gem install nokogiri httpclient moneta
110
111%files
112%{_datadir}/%{name}
113
114%changelog
115* Mon Feb 01 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.12-1
116- new upstream release
117
118* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.9-1
119- new upstream release
120
121* Fri Sep 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-2
122- rebuild with ruby-2.2.3
123
124* Sat Aug 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
125- new upstream release
126
127* Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
128- new upstream release
129
130* Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
131- new upstream release
132
133* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
134- new upstream release
135
136* Sun Oct 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
137- new upstream release
138
139* Tue Sep 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
140- new upstream release
141
142* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.5-1
143- new upstream release
144
145* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
146- new upstream release
147
148* Sun Jun 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
149- new upstream release
150
151* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1537-1
152- new upstream release
153
154* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1476-1
155- new upstream release
156
157* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1430-1
158- new upstream release
159
160* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1410-1
161- initial build
162
Note: See TracBrowser for help on using the repository browser.