source: projects/specs/trunk/nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec @ 7852

Revision 7852, 7.4 KB checked in by munepi, 11 years ago (diff)

added Obsoletes: %{name} <= %{version}-%{release} and so on.

Line 
1%define pkgname libquicktime
2%define name    self-build-%{pkgname}
3%define version 1.2.4
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        LGPLv2+
16Group:          Restricted Software
17
18Obsoletes: %{pkgname} < %{version}
19Obsoletes: %{pkgname}-utils < %{version}
20Obsoletes: %{pkgname}-devel < %{version}
21Obsoletes: %{name} < %{version}-%{release}
22
23Requires(post):         self-build-setup >= 0.9.9
24
25Requires(post):         libvorbis-devel
26Requires(post):         libpng-devel
27Requires(post):         libjpeg-devel
28Requires(post):         gtk2-devel
29Requires(post):         libdv-devel
30Requires(post):         libraw1394-devel
31Requires(post):         libavc1394-devel
32
33Requires(post):         alsa-lib-devel
34Requires(post):         zlib-devel
35Requires(post):         gettext-devel
36Requires(post):         mesa-libGL-devel
37Requires(post):         libX11-devel
38Requires(post):         libICE-devel
39Requires(post):         libSM-devel
40Requires(post):         libXext-devel
41Requires(post):         libXmu-devel
42Requires(post):         libXpm-devel
43Requires(post):         libXt-devel
44Requires(post):         libXaw-devel >= 1.0.5
45Requires(post):         libXv-devel
46
47Requires(post):         self-build-ffmpeg >= 1.2
48Requires(post):         self-build-lame
49Requires(post):         self-build-faad2
50Requires(post):         self-build-faac
51Requires(post):         self-build-x264 >= 0.136
52
53BuildArch:      noarch
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55
56Packager:       munepi
57
58%description
59Libquicktime is based on the quicktime4linux library with several
60enhancements. All 3rd-party libraries were removed from the
61sourcetree. Instead, the systemwide installed libraries are detected
62by the configure script. All original codecs were moved into
63dynamically loadable modules, and new codecs are in
64development. Libquicktime is source-compatible with
65quicktime4linux. Special API extensions allow access to the codec
66registry and more convenient processing of Audio and Video
67data.
68
69
70If you install this package, it automaticaly downloads source
71code ,compile it, and create rpm packages of %{pkgname}-%{version}.
72And the created rpm packages are automatically installed
73if installation is executed by apt-get command or synaptic
74package manager.
75
76[Note]
77This package requires many other packages to compile
78targetsoftware. So it consume more disk space than usual.
79Also installation takes logner time because of compilation.
80(This will take a few minutes to quarter or half of an hour,
81depends on building environment)
82
83[About self-build package]
84For some kind of software, distributing of binary package
85may viorate the patent or law. Therefore we chose self-build
86packge, create binary package on your machine, for such kind
87of softwares instead of distributing binary package.
88
89Please obey the national law when you use the created binary
90packages. And if you want to use the softwares using patented
91thechnology, it may be required to get a permission, make an
92agreement or purchas a license. Please consider it with your
93purpose or way of use and take appropriate action.
94
95%description -l ja
96libquicktime は、quicktime4linux ライブラリを元に拡張しています。
97サードパーティライブラリは、一次元ソースツリーからすべて消えてしまいました。
98その代わりに、システムワイドにインストールされるライブラリは、
99configure スクリプトにより検出されます。
100オリジナルコーデックは、すべて動的読み込み可能なモジュールに
101移行してしまいました。また、新しいコーデックは開発途中です。
102libquicktime は quicktime4linux と互換性を持ったソースです。
103特別な API 拡張は、コーデックレジストリや
104音声や動画のより便利な処理にアクセスができます。
105
106
107このパッケージをインストールすると、自動的にソースコードを
108ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
109パッケージを作成します。
110また apt-get コマンドや synaptic パッケージマネージャから実行
111した場合は、作成された rpm パッケージのインストールも自動的に
112行います。
113
114[注意]
115コンパイルに必要な多くの関連パッケージを要求するので通常より
116ディスクの領域を多く消費します。
117またインストール時にコンパイルを行うため、通常より時間がかか
118る場合があります。(環境にもよりますが数分から数十分程度)
119
120[self-build パッケージについて]
121ソフトウェアによってはバイナリパッケージの配布が特許や法律に
122違反する可能性があるものがあります。その為、このような問題が
123懸念されるソフトウェアについてはバイナリパッケージを直接配布
124せずに、ユーザの環境でバイナリを作成する self-build パッケー
125ジという方法を採っています。
126
127作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
128アのライセンス、および利用する国の各種法令に従ってください。
129また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
130センスの購入などが必要となる場合がありますので、利用する目的
131や形態に応じて各自で判断し適切な対応を取ってください。
132
133%prep
134[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
135
136%install
137%{__rm} -rf ${RPM_BUILD_ROOT}
138%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
139%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
140
141%clean
142%{__rm} -rf ${RPM_BUILD_ROOT}
143
144%posttrans
145/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 197000
146/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
147                                 %{pkgname}-utils-%{version}-%{release} \
148                                 %{pkgname}-devel-%{version}-%{release}
149
150%files
151%defattr(-,root,root)
152%{_datadir}/%{name}
153
154%changelog
155* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-4
156- added Obsoletes: %{name} < %{version}-%{release},
157  Obsoletes: %{pkgname} < %{version} and so on.
158
159* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-3
160- rebuilt with new x264 (ABI 0.136) and ffmpeg (1.2.x)
161
162* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-2
163- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
164
165* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
166- new upstream release
167
168* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-2
169- rebuilt with new x264 (ABI 0.119) and ffmpeg (0.9.x)
170
171* Thu Dec 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
172- new upstream release
173
174* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
175- rebuilt
176
177* Mon Jan 31 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
178- new upstream release
179- added the subpackage utils
180- updated %%description
181
182* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
183- new upstream release
184
185* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
186- renamed %%{Source0} to libquicktime-vl.spec
187
188* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
189- new upstream release
190
191* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
192- initial bulid
Note: See TracBrowser for help on using the repository browser.