source: projects/specs/trunk/nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec @ 1258

Revision 1258, 5.8 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define pkgname libquicktime
2%define name    self-build-%{pkgname}
3%define version 1.1.5
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        LGPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20Requires(post):         libvorbis-devel
21Requires(post):         libpng-devel
22Requires(post):         libjpeg-devel
23Requires(post):         gtk2-devel
24Requires(post):         libdv-devel
25Requires(post):         libraw1394-devel
26Requires(post):         libavc1394-devel
27
28Requires(post):         alsa-lib-devel
29Requires(post):         zlib-devel
30Requires(post):         gettext-devel
31Requires(post):         mesa-libGL-devel
32Requires(post):         libX11-devel
33Requires(post):         libICE-devel
34Requires(post):         libSM-devel
35Requires(post):         libXext-devel
36Requires(post):         libXmu-devel
37Requires(post):         libXpm-devel
38Requires(post):         libXt-devel
39Requires(post):         libXaw-devel >= 1.0.5
40Requires(post):         libXv-devel
41
42Requires(post):         self-build-ffmpeg
43Requires(post):         self-build-lame
44Requires(post):         self-build-faad2
45Requires(post):         self-build-faac
46Requires(post):         self-build-x264
47
48BuildArch:      noarch
49BuildRoot:      %{_tmppath}/%{name}-%{version}-root
50
51Packager:       munepi
52
53%description
54Libquicktime is a library for reading and writing QuickTime files
55on UNIX systems. Video CODECs supported by this library are OpenDivX, MJPA,
56JPEG Photo, PNG, RGB, YUV 4:2:2, and YUV 4:2:0 compression.  Supported
57audio CODECs are Ogg Vorbis, IMA4, ulaw, and any linear PCM format.
58
59Libquicktime is based on the quicktime4linux library.  Libquicktime add
60features such as a GNU build tools-based build process and dynamically
61loadable CODECs.
62
63
64If you install this package, it automaticaly downloads source
65code ,compile it, and create rpm packages of %{pkgname}-%{version}.
66And the created rpm packages are automatically installed
67if installation is executed by apt-get command or synaptic
68package manager.
69
70[Note]
71This package requires many other packages to compile
72targetsoftware. So it consume more disk space than usual.
73Also installation takes logner time because of compilation.
74(This will take a few minutes to quarter or half of an hour,
75depends on building environment)
76
77[About self-build package]
78For some kind of software, distributing of binary package
79may viorate the patent or law. Therefore we chose self-build
80packge, create binary package on your machine, for such kind
81of softwares instead of distributing binary package.
82
83Please obey the national law when you use the created binary
84packages. And if you want to use the softwares using patented
85thechnology, it may be required to get a permission, make an
86agreement or purchas a license. Please consider it with your
87purpose or way of use and take appropriate action.
88
89%description -l ja
90libquicktimeはUNIX 系のシステムでQuickTimeファイルを読み書きするための
91ライブラリです.ビデオエンコード:OpenDivX、MJPA、JPEG Photo、PNG、RGB、
92YUV 4:2:2、YUV 4:2:0、オーディオエンコード:Ogg Vorbis、IMA4、ulaw、そ
93の他線型PCM形式をサポートします.
94
95
96このパッケージをインストールすると、自動的にソースコードを
97ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
98パッケージを作成します。
99また apt-get コマンドや synaptic パッケージマネージャから実行
100した場合は、作成された rpm パッケージのインストールも自動的に
101行います。
102
103[注意]
104コンパイルに必要な多くの関連パッケージを要求するので通常より
105ディスクの領域を多く消費します。
106またインストール時にコンパイルを行うため、通常より時間がかか
107る場合があります。(環境にもよりますが数分から数十分程度)
108
109[self-build パッケージについて]
110ソフトウェアによってはバイナリパッケージの配布が特許や法律に
111違反する可能性があるものがあります。その為、このような問題が
112懸念されるソフトウェアについてはバイナリパッケージを直接配布
113せずに、ユーザの環境でバイナリを作成する self-build パッケー
114ジという方法を採っています。
115
116作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
117アのライセンス、および利用する国の各種法令に従ってください。
118また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
119センスの購入などが必要となる場合がありますので、利用する目的
120や形態に応じて各自で判断し適切な対応を取ってください。
121
122%prep
123[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
124
125%install
126%{__rm} -rf ${RPM_BUILD_ROOT}
127%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
128%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
129
130%clean
131%{__rm} -rf ${RPM_BUILD_ROOT}
132
133%posttrans
134/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 186000
135/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
136                                 %{pkgname}-devel-%{version}-%{release}
137
138%files
139%defattr(-,root,root)
140%{_datadir}/%{name}
141
142%changelog
143* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
144- new upstream release
145
146* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
147- renamed %%{Source0} to libquicktime-vl.spec
148
149* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
150- new upstream release
151
152* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
153- initial bulid
Note: See TracBrowser for help on using the repository browser.