source: projects/specs/trunk/nonfree/self-build-libquicktime/self-build-libquicktime-vl.spec @ 10787

Revision 10787, 7.6 KB checked in by ara_t, 7 years ago (diff)

add ffmpeg2.0.patch

Line 
1%define pkgname libquicktime
2%define name    self-build-%{pkgname}
3%define version 1.2.4
4%define release 5%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source1:        ffmpeg2.0.patch
15
16License:        LGPLv2+
17Group:          Restricted Software
18
19Obsoletes: %{pkgname} < %{version}
20Obsoletes: %{pkgname}-utils < %{version}
21Obsoletes: %{pkgname}-devel < %{version}
22Obsoletes: %{name} < %{version}-%{release}
23
24Requires(post):         self-build-setup >= 0.9.9
25
26Requires(post):         libvorbis-devel
27Requires(post):         libpng-devel
28Requires(post):         libjpeg-devel
29Requires(post):         gtk2-devel
30Requires(post):         libdv-devel
31Requires(post):         libraw1394-devel
32Requires(post):         libavc1394-devel
33
34Requires(post):         alsa-lib-devel
35Requires(post):         zlib-devel
36Requires(post):         gettext-devel
37Requires(post):         mesa-libGL-devel
38Requires(post):         libX11-devel
39Requires(post):         libICE-devel
40Requires(post):         libSM-devel
41Requires(post):         libXext-devel
42Requires(post):         libXmu-devel
43Requires(post):         libXpm-devel
44Requires(post):         libXt-devel
45Requires(post):         libXaw-devel >= 1.0.5
46Requires(post):         libXv-devel
47
48Requires(post):         self-build-ffmpeg >= 1.2
49Requires(post):         self-build-lame
50Requires(post):         self-build-faad2
51Requires(post):         self-build-faac
52Requires(post):         self-build-x264 >= 0.136
53
54BuildArch:      noarch
55BuildRoot:      %{_tmppath}/%{name}-%{version}-root
56
57Packager:       munepi
58
59%description
60Libquicktime is based on the quicktime4linux library with several
61enhancements. All 3rd-party libraries were removed from the
62sourcetree. Instead, the systemwide installed libraries are detected
63by the configure script. All original codecs were moved into
64dynamically loadable modules, and new codecs are in
65development. Libquicktime is source-compatible with
66quicktime4linux. Special API extensions allow access to the codec
67registry and more convenient processing of Audio and Video
68data.
69
70
71If you install this package, it automaticaly downloads source
72code ,compile it, and create rpm packages of %{pkgname}-%{version}.
73And the created rpm packages are automatically installed
74if installation is executed by apt-get command or synaptic
75package manager.
76
77[Note]
78This package requires many other packages to compile
79targetsoftware. So it consume more disk space than usual.
80Also installation takes logner time because of compilation.
81(This will take a few minutes to quarter or half of an hour,
82depends on building environment)
83
84[About self-build package]
85For some kind of software, distributing of binary package
86may viorate the patent or law. Therefore we chose self-build
87packge, create binary package on your machine, for such kind
88of softwares instead of distributing binary package.
89
90Please obey the national law when you use the created binary
91packages. And if you want to use the softwares using patented
92thechnology, it may be required to get a permission, make an
93agreement or purchas a license. Please consider it with your
94purpose or way of use and take appropriate action.
95
96%description -l ja
97libquicktime は、quicktime4linux ライブラリを元に拡張しています。
98サードパーティライブラリは、一次元ソースツリーからすべて消えてしまいました。
99その代わりに、システムワイドにインストールされるライブラリは、
100configure スクリプトにより検出されます。
101オリジナルコーデックは、すべて動的読み込み可能なモジュールに
102移行してしまいました。また、新しいコーデックは開発途中です。
103libquicktime は quicktime4linux と互換性を持ったソースです。
104特別な API 拡張は、コーデックレジストリや
105音声や動画のより便利な処理にアクセスができます。
106
107
108このパッケージをインストールすると、自動的にソースコードを
109ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
110パッケージを作成します。
111また apt-get コマンドや synaptic パッケージマネージャから実行
112した場合は、作成された rpm パッケージのインストールも自動的に
113行います。
114
115[注意]
116コンパイルに必要な多くの関連パッケージを要求するので通常より
117ディスクの領域を多く消費します。
118またインストール時にコンパイルを行うため、通常より時間がかか
119る場合があります。(環境にもよりますが数分から数十分程度)
120
121[self-build パッケージについて]
122ソフトウェアによってはバイナリパッケージの配布が特許や法律に
123違反する可能性があるものがあります。その為、このような問題が
124懸念されるソフトウェアについてはバイナリパッケージを直接配布
125せずに、ユーザの環境でバイナリを作成する self-build パッケー
126ジという方法を採っています。
127
128作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
129アのライセンス、および利用する国の各種法令に従ってください。
130また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
131センスの購入などが必要となる場合がありますので、利用する目的
132や形態に応じて各自で判断し適切な対応を取ってください。
133
134%prep
135[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
136
137%install
138%{__rm} -rf ${RPM_BUILD_ROOT}
139%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
140%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
141%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
142
143%clean
144%{__rm} -rf ${RPM_BUILD_ROOT}
145
146%posttrans
147/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 197000
148/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
149                                 %{pkgname}-utils-%{version}-%{release} \
150                                 %{pkgname}-devel-%{version}-%{release}
151
152%files
153%defattr(-,root,root)
154%{_datadir}/%{name}
155
156%changelog
157* Tue Oct 25 2016 Toshiaki Ara <ara_t@384.jp> 1.2.4-5
158- add Patch1 for [BTS:0002886]
159
160* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-4
161- added Obsoletes: %{name} < %{version}-%{release},
162  Obsoletes: %{pkgname} < %{version} and so on.
163
164* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-3
165- rebuilt with new x264 (ABI 0.136) and ffmpeg (1.2.x)
166
167* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-2
168- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
169
170* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
171- new upstream release
172
173* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-2
174- rebuilt with new x264 (ABI 0.119) and ffmpeg (0.9.x)
175
176* Thu Dec 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
177- new upstream release
178
179* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
180- rebuilt
181
182* Mon Jan 31 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
183- new upstream release
184- added the subpackage utils
185- updated %%description
186
187* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
188- new upstream release
189
190* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
191- renamed %%{Source0} to libquicktime-vl.spec
192
193* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
194- new upstream release
195
196* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
197- initial bulid
Note: See TracBrowser for help on using the repository browser.