source: projects/specs/trunk/nonfree/self-build-libquicktime/libquicktime-vl.spec @ 10787

Revision 10787, 6.8 KB checked in by ara_t, 7 years ago (diff)

add ffmpeg2.0.patch

Line 
1Name:            libquicktime
2Version:         1.2.4
3Release:         5%{?_dist_release}
4License:         LGPLv2+
5Group:           System Environment/Libraries
6Source0:         http://prdownloads.sourceforge.net/libquicktime/%{name}-%{version}.tar.gz
7Patch1:          ffmpeg2.0.patch
8
9URL:             http://libquicktime.sourceforge.net/
10Summary:         Library for reading and writing Quicktime files
11Summary(ja):     QuickTime ファイルを読み書きするためのライブラリ
12
13Vendor:          Project Vine
14Distribution:    Vine Linux
15BuildRoot:       %{_tmppath}/%{name}-%{version}-root
16
17Obsoletes: %{name} < %{version}
18Obsoletes: %{name}-utils < %{version}
19Obsoletes: %{name}-devel < %{version}
20
21BuildRequires:   libvorbis-devel
22BuildRequires:   libpng-devel
23BuildRequires:   libjpeg-devel
24BuildRequires:   gtk2-devel
25BuildRequires:   libdv-devel
26BuildRequires:   libraw1394-devel
27BuildRequires:   libavc1394-devel
28
29BuildRequires:   alsa-lib-devel
30BuildRequires:   zlib-devel
31BuildRequires:   gettext-devel
32BuildRequires:   mesa-libGL-devel
33BuildRequires:   libX11-devel
34BuildRequires:   libICE-devel
35BuildRequires:   libSM-devel
36BuildRequires:   libXext-devel
37BuildRequires:   libXmu-devel
38BuildRequires:   libXpm-devel
39BuildRequires:   libXt-devel
40BuildRequires:   libXaw-devel >= 1.0.5
41BuildRequires:   libXv-devel
42
43##BuildRequires:   ffmpeg-devel
44##BuildRequires:   lame-devel
45##BuildRequires:   faad2-devel
46##BuildRequires:   faac-devel
47##BuildRequires:   x264-devel
48
49%description
50Libquicktime is based on the quicktime4linux library with several
51enhancements. All 3rd-party libraries were removed from the
52sourcetree. Instead, the systemwide installed libraries are detected
53by the configure script. All original codecs were moved into
54dynamically loadable modules, and new codecs are in
55development. Libquicktime is source-compatible with
56quicktime4linux. Special API extensions allow access to the codec
57registry and more convenient processing of Audio and Video
58data.
59
60%description -l ja
61libquicktime は、quicktime4linux ライブラリを元に拡張しています。
62サードパーティライブラリは、一次元ソースツリーからすべて消えてしまいました。
63その代わりに、システムワイドにインストールされるライブラリは、
64configure スクリプトにより検出されます。
65オリジナルコーデックは、すべて動的読み込み可能なモジュールに
66移行してしまいました。また、新しいコーデックは開発途中です。
67libquicktime は quicktime4linux と互換性を持ったソースです。
68特別な API 拡張は、コーデックレジストリや
69音声や動画のより便利な処理にアクセスができます。
70
71%package utils
72Summary:        Utilities for working with Quicktime files
73Summary(ja):    Quicktime ファイルを操作するためのユーティリティ
74Group:          Applications/Multimedia
75Requires:        %{name} = %{version}-%{release}
76
77%description utils
78Libquicktime is based on the quicktime4linux library with several
79enhancements.
80
81This package contains utility programs and additional
82tools, like a commandline player and a GTK configuration utility which
83can configure the parameters of all installed codecs.
84
85%package devel
86Summary:         Development files from the libquicktime library
87Summary(ja):     libquicktime の開発ライブラリ
88Group:           Development/Libraries
89Requires:        %{name} = %{version}-%{release}
90Requires:        zlib-devel
91Requires:        pkgconfig
92
93%description devel
94Libquicktime is based on the quicktime4linux library with several
95enhancements.
96
97This package contains development files for %{name}.
98
99
100%prep
101%setup -q -n %{name}-%{version}
102%patch1 -p1 -b .ffmpeg2.0
103
104%build
105%configure \
106    --enable-gpl \
107    --disable-rpath \
108    --with-cpuflags="$RPM_OPT_FLAGS" \
109    --disable-dependency-tracking \
110    --without-doxygen \
111    --disable-static \
112    --with-libdv \
113    --enable-libswscale \
114    ;
115
116# remove rpath from libtool
117%__sed -i.rpath 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
118%__sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
119
120%__make %{?_smp_mflags}
121
122
123%install
124%{__rm} -rf %{buildroot}
125%makeinstall
126
127## remove unuse files
128find $RPM_BUILD_ROOT%{_libdir} -type f -a -name \*.la -exec %__rm -f {} \;
129
130%find_lang %{name}
131
132%clean
133%{__rm} -rf %{buildroot}
134
135%post -p /sbin/ldconfig
136
137%postun -p /sbin/ldconfig
138
139
140%files -f %{name}.lang
141%defattr(-,root,root,-)
142%doc AUTHORS ChangeLog COPYING NEWS README TODO
143%{_libdir}/%{name}*.so.*
144%dir %{_libdir}/%{name}
145%{_libdir}/%{name}/lqt_*.so
146
147%files utils
148%defattr(-,root,root,-)
149%{_bindir}/libquicktime_config
150%{_bindir}/lqt_transcode
151%{_bindir}/lqtplay
152%{_bindir}/lqtremux
153%{_bindir}/qt2text
154%{_bindir}/qtdechunk
155%{_bindir}/qtdump
156%{_bindir}/qtinfo
157%{_bindir}/qtrechunk
158%{_bindir}/qtstreamize
159%{_bindir}/qtyuv4toyuv
160%{_mandir}/man1/lqtplay.1*
161
162%files devel
163%defattr(-,root,root,-)
164%{_includedir}/lqt/
165%{_libdir}/pkgconfig/libquicktime.pc
166%{_libdir}/%{name}*.so
167
168
169%changelog
170* Tue Oct 25 2016 Toshiaki Ara <ara_t@384.jp> 1.2.4-5
171- add Patch1 for [BTS:0002886]
172
173* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-4
174- added Obsoletes: %{name} < %{version} and so on.
175
176* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-3
177- rebuilt with new x264 (ABI 0.136) and ffmpeg (1.2.x)
178
179* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-2
180- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
181
182* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
183- new upstream release
184
185* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-2
186- rebuilt with new x264 (ABI 0.119) and ffmpeg (0.9.x)
187
188* Thu Dec 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
189- new upstream release
190
191* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-2
192- rebuilt
193
194* Mon Jan 31 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.2-1
195- new upstream release
196- added the subpackage utils
197- updated %%description
198
199* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
200- new upstream release
201
202* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
203- change release to sync with self-build-libquicktime.spec
204
205* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
206- new upstream release
207
208* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
209- new upstream release
210- changed License: LGPLv2
211- added some configure options
212
213* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-2
214- rebuild with libXaw.so.7 (libXaw-1.0.5)
215
216* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
217- applied new versioning policy, spec in utf-8
218- updated libquicktime to 1.0.3
219
220* Thu Aug  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.9-0vl1
221- new upstream release
222- License is LGPL
223- added libquicktime.pc to devel package
224
225* Mon Feb 21 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
226- Inital package for VineLinux3.1
Note: See TracBrowser for help on using the repository browser.