source: projects/specs/trunk/nonfree/self-build-libmpeg2/self-build-libmpeg2-vl.spec @ 620

Revision 620, 4.7 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname libmpeg2
2%define name    self-build-%{pkgname}
3%define version 0.5.1
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://libmpeg2.sourceforge.net/files/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20Requires(post):         SDL-devel
21%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl6"
22Requires(post):         libXt-devel
23Requires(post):         libXv-devel
24%endif
25%if %{?_dist_release} == "vl4"
26Requires(post):         XOrg-devel
27%endif
28
29BuildArch:      noarch
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32Packager:       munepi
33
34%description
35libmpeg2 is a free library for decoding mpeg-2 and mpeg-1 video
36streams. It is released under the terms of the GPL license.
37
38
39If you install this package, it automaticaly downloads source
40code ,compile it, and create rpm packages of %{pkgname}-%{version}.
41And the created rpm packages are automatically installed
42if installation is executed by apt-get command or synaptic
43package manager.
44
45[Note]
46This package requires many other packages to compile
47targetsoftware. So it consume more disk space than usual.
48Also installation takes logner time because of compilation.
49(This will take a few minutes to quarter or half of an hour,
50depends on building environment)
51
52[About self-build package]
53For some kind of software, distributing of binary package
54may viorate the patent or law. Therefore we chose self-build
55packge, create binary package on your machine, for such kind
56of softwares instead of distributing binary package.
57
58Please obey the national law when you use the created binary
59packages. And if you want to use the softwares using patented
60thechnology, it may be required to get a permission, make an
61agreement or purchas a license. Please consider it with your
62purpose or way of use and take appropriate action.
63
64%description -l ja
65libmpeg2 はmpeg-1/2ビデオストリームをデコードするための
66フリーなライブラリです.
67
68
69このパッケージをインストールすると、自動的にソースコードを
70ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
71パッケージを作成します。
72また apt-get コマンドや synaptic パッケージマネージャから実行
73した場合は、作成された rpm パッケージのインストールも自動的に
74行います。
75
76[注意]
77コンパイルに必要な多くの関連パッケージを要求するので通常より
78ディスクの領域を多く消費します。
79またインストール時にコンパイルを行うため、通常より時間がかか
80る場合があります。(環境にもよりますが数分から数十分程度)
81
82[self-build パッケージについて]
83ソフトウェアによってはバイナリパッケージの配布が特許や法律に
84違反する可能性があるものがあります。その為、このような問題が
85懸念されるソフトウェアについてはバイナリパッケージを直接配布
86せずに、ユーザの環境でバイナリを作成する self-build パッケー
87ジという方法を採っています。
88
89作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
90アのライセンス、および利用する国の各種法令に従ってください。
91また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
92センスの購入などが必要となる場合がありますので、利用する目的
93や形態に応じて各自で判断し適切な対応を取ってください。
94
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104%posttrans
105/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 60000
106/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
107                                 %{pkgname}-devel-%{version}-%{release} \
108                                 mpeg2dec-%{version}-%{release}
109
110%files
111%defattr(-,root,root)
112%{_datadir}/%{name}/*
113
114%changelog
115* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-4
116- renamed %%{Source0} to libmpeg2-vl.spec
117
118* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.1-3
119- added BuildArch: noarch
120- avoided to execute self-build-rpm.sh on RPM transaction
121  - moved %%post actions to %%posttrans
122
123* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.1-2
124- initial bulid for self-build
Note: See TracBrowser for help on using the repository browser.