source: projects/specs/trunk/nonfree/self-build-libmp4v2/self-build-libmp4v2-vl.spec @ 615

Revision 615, 5.7 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define projname mp4v2
2
3%define pkgname libmp4v2
4%define name    self-build-%{pkgname}
5%define version 1.9.1
6%define release 4%{?_dist_release}
7
8#% define sourceurl0    http://resare.com/libmp4v2/dist/%{pkgname}-%{version}.tar.bz2
9#% define sourceurl1    http://resare.com/libmp4v2/mklibmp4v2/mklibmp4v2-r51.tar.bz2
10%define sourceurl0      http://mp4v2.googlecode.com/files/%{projname}-%{version}.tar.bz2
11
12Summary:        Package to automatically build %{pkgname} rpm package (with internal libmp4v2)
13Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
14Name:           %{name}
15Version:        %{version}
16Release:        %{release}
17Source0:        %{pkgname}-vl.spec
18
19License:        MPLv1.1
20Group:          Restricted Software
21
22Requires(post):         self-build-setup >= 0.9.9
23
24# (build)requies of target package.
25
26BuildArch:      noarch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Packager:       munepi
30
31%description
32The libmp4v2 library provides an abstraction layer for working with files
33using the mp4 container format. This library is developed by mpeg4ip project
34and is an exact copy of the library distributed in the mpeg4ip package.
35
36
37If you install this package, it automatically downloads
38source code, compile it with internal libmp4v2, and create
39rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
40And the created rpm packages are automatically installed
41if installation is executed by apt-get command or synaptic
42package manager.
43
44[Note]
45This package requires many other packages to compile
46targetsoftware. So it consume more disk space than usual.
47Also installation takes logner time because of compilation.
48(This will take a few minutes to quarter or half of an hour,
49depends on building environment)
50
51[About self-build package]
52For some kind of software, distributing of binary package
53may viorate the patent or law. Therefore we chose self-build
54packge, create binary package on your machine, for such kind
55of softwares instead of distributing binary package.
56
57Please obey the national law when you use the created binary
58packages. And if you want to use the softwares using patented
59thechnology, it may be required to get a permission, make an
60agreement or purchas a license. Please consider it with your
61purpose or way of use and take appropriate action.
62
63%description -l ja
64libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
65ルで動作するものに対して抽象レイヤーを提供します.このライブ
66ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
67ケージに分散されているライブラリの完全なコピーです.
68
69このパッケージをインストールすると、自動的にソースコードを
70ダウンロードして、%{pkgname}-%{version} の rpm パッケージを作成します。
71また apt-get コマンドや synaptic パッケージマネージャから実行
72した場合は、作成された rpm パッケージのインストールも自動的に
73行います。
74
75[注意]
76コンパイルに必要な多くの関連パッケージを要求するので通常より
77ディスクの領域を多く消費します。
78またインストール時にコンパイルを行うため、通常より時間がかか
79る場合があります。(環境にもよりますが数分から数十分程度)
80
81[self-build パッケージについて]
82ソフトウェアによってはバイナリパッケージの配布が特許や法律に
83違反する可能性があるものがあります。その為、このような問題が
84懸念されるソフトウェアについてはバイナリパッケージを直接配布
85せずに、ユーザの環境でバイナリを作成する self-build パッケー
86ジという方法を採っています。
87
88作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
89アのライセンス、および利用する国の各種法令に従ってください。
90また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
91センスの購入などが必要となる場合がありますので、利用する目的
92や形態に応じて各自で判断し適切な対応を取ってください。
93
94
95%prep
96[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
97
98%install
99%{__rm} -rf ${RPM_BUILD_ROOT}
100%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%posttrans
107/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 75000
108/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
109                                 %{pkgname}-devel-%{version}-%{release}
110
111%files
112%defattr(-,root,root)
113%{_datadir}/%{name}
114
115%changelog
116* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-4
117- - renamed %%{Source0} to libmp4v2-vl.spec
118
119* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-3
120- fixed the permission of /usr/include/mp4v2 to access it by group, others
121
122* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-2
123- added --disable-gch in configure options
124
125* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-1
126- new upstream release
127- changed URL: to http://code.google.com/p/mp4v2/
128  MP4v2 was originally bundled with mpeg4ip library,
129  but has been moved into its own maintained library
130  due to a combination of the cessation of support of mpeg4ip
131  and the usefulness of this library on its own.
132
133* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5.0.1-2
134- added BuildArch: noarch
135- avoided to execute self-build-rpm.sh on RPM transaction
136  - moved %%post actions to %%posttrans
137
138* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5.0.1-1
139- initial build
140
141### end of file
Note: See TracBrowser for help on using the repository browser.