source: projects/specs/trunk/nonfree/self-build-libmad/self-build-libmad-vl.spec @ 615

Revision 615, 5.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

RevLine 
[615]1%define pkgname libmad
2%define name    self-build-%{pkgname}
3%define version 0.15.1b
4%define release 7%{?_dist_release}
5
6# define sourceurl0     ftp://ftp.mars.org/pub/mpeg/%{pkgname}-%{version}.tar.gz
7%define sourceurl0      http://prdownloads.sourceforge.net/mad/%{pkgname}-%{version}.tar.gz
8
9Summary:        Package to automatically build %{pkgname} rpm package
10Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
11Name:           %{name}
12Version:        %{version}
13Release:        %{release}
14Source0:        %{pkgname}-vl.spec
15
16License:        GPL
17Group:          Restricted Software
18
19Requires(post):         self-build-setup >= 0.9.9
20
21Requires(post):         gcc-c++
22
23BuildArch:      noarch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Packager:       munepi
27
28%description
29MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
30MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
31the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
32and Layer III a.k.a. MP3) are fully implemented.
33 
34MAD does not yet support MPEG-2 multichannel audio (although it should be
35backward compatible with such streams) nor does it currently support AAC.
36
37
38If you install this package, it automaticaly downloads source
39code ,compile it, and create rpm packages of %{pkgname}-%{version}.
40And the created rpm packages are automatically installed
41if installation is executed by apt-get command or synaptic
42package manager.
43
44[Note]
45This package requires many other packages to compile
46targetsoftware. So it consume more disk space than usual.
47Also installation takes logner time because of compilation.
48(This will take a few minutes to quarter or half of an hour,
49depends on building environment)
50
51[About self-build package]
52For some kind of software, distributing of binary package
53may viorate the patent or law. Therefore we chose self-build
54packge, create binary package on your machine, for such kind
55of softwares instead of distributing binary package.
56
57Please obey the national law when you use the created binary
58packages. And if you want to use the softwares using patented
59thechnology, it may be required to get a permission, make an
60agreement or purchas a license. Please consider it with your
61purpose or way of use and take appropriate action.
62
63%description -l ja
64MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
65MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
66the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
67and Layer III a.k.a. MP3) are fully implemented.
68 
69MAD does not yet support MPEG-2 multichannel audio (although it should be
70backward compatible with such streams) nor does it currently support AAC.
71
72
73このパッケージをインストールすると、自動的にソースコードを
74ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
75パッケージを作成します。
76また apt-get コマンドや synaptic パッケージマネージャから実行
77した場合は、作成された rpm パッケージのインストールも自動的に
78行います。
79
80[注意]
81コンパイルに必要な多くの関連パッケージを要求するので通常より
82ディスクの領域を多く消費します。
83またインストール時にコンパイルを行うため、通常より時間がかか
84る場合があります。(環境にもよりますが数分から数十分程度)
85
86[self-build パッケージについて]
87ソフトウェアによってはバイナリパッケージの配布が特許や法律に
88違反する可能性があるものがあります。その為、このような問題が
89懸念されるソフトウェアについてはバイナリパッケージを直接配布
90せずに、ユーザの環境でバイナリを作成する self-build パッケー
91ジという方法を採っています。
92
93作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
94アのライセンス、および利用する国の各種法令に従ってください。
95また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
96センスの購入などが必要となる場合がありますので、利用する目的
97や形態に応じて各自で判断し適切な対応を取ってください。
98
99%prep
100[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
106%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
107
108%clean
109%{__rm} -rf ${RPM_BUILD_ROOT}
110
111%posttrans
112/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 20000
113/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
114                                 %{pkgname}-devel-%{version}-%{release}
115
116%files
117%defattr(-,root,root)
118%{_datadir}/%{name}
119
120%changelog
121* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-7
122- renamed %%{Source0} to libmad-vl.spec
123
124* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-6
125- rebuild with new toolchain
126
127* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-5
128- changed to download from http://prdownloads.sourceforge.net/mad in %%sourceurl0
129- check version between original spec and self-build spec in %%prep
130
131* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-4
132- added BuildArch: noarch
133- avoided to execute self-build-rpm.sh on RPM transaction
134  - moved %%post actions to %%posttrans
135
136* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-3
137- initial bulid for self-build
Note: See TracBrowser for help on using the repository browser.