source: projects/specs/trunk/nonfree/self-build-libmad/libmad-vl.spec @ 615

Revision 615, 4.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

RevLine 
[615]1# -*- coding: utf-8-unix -*-
2Summary: MPEG audio decoder library.
3Summary(ja): MPEG オーディオ復号化ライブラリ
4Name: libmad
5Version: 0.15.1b
6Release: 7%{?_dist_release}
7Group: System Environment/Libraries
8#Source: ftp://ftp.mars.org/pub/mpeg/%{name}-%{version}.tar.gz
9Source: http://prdownloads.sourceforge.net/mad/%{name}-%{version}.tar.gz
10URL: http://www.underbit.com/products/mad/
11License: GPL
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: gcc-c++
14Provides: mad = %{version}-%{release}
15
16%description
17MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
18MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
19the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
20and Layer III a.k.a. MP3) are fully implemented.
21 
22MAD does not yet support MPEG-2 multichannel audio (although it should be
23backward compatible with such streams) nor does it currently support AAC.
24
25
26%package devel
27Summary: Header and library for developing programs that will use libmad.
28Summary(ja): labmad を使うプログラムを開発するためのライブラリ
29Group: Development/Libraries
30Requires: %{name} = %{version}
31
32%description devel
33MAD (libmad) is a high-quality MPEG audio decoder. It currently supports
34MPEG-1 and the MPEG-2 extension to Lower Sampling Frequencies, as well as
35the so-called MPEG 2.5 format. All three audio layers (Layer I, Layer II,
36and Layer III a.k.a. MP3) are fully implemented.
37
38This package contains the header file as well as the static library needed
39to develop programs that will use libmad for mpeg audio decoding.
40
41
42%prep
43%setup -q
44
45%__sed -i -e /-fforce-mem/d configure* # -fforce-mem gone in gcc 4.2, noop earlier
46touch -r aclocal.m4 configure.ac NEWS AUTHORS ChangeLog
47
48%__cat << EOF > mad.pc
49prefix=%{_prefix}
50exec_prefix=%{_prefix}
51libdir=%{_libdir}
52includedir=%{_includedir}
53
54Name: mad
55Description: MPEG Audio Decoder
56Requires:
57Version: %{version}
58Libs: -L%{_libdir} -lmad -lm
59Cflags: -I%{_includedir}
60EOF
61
62%build
63%configure \
64    --enable-accuracy \
65    --disable-debugging \
66    --disable-static
67%__make %{?_smp_mflags} CPPFLAGS="$RPM_OPT_FLAGS"
68
69%install
70%__rm -rf $RPM_BUILD_ROOT
71%__make install DESTDIR=$RPM_BUILD_ROOT
72%__rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
73%{__install} -D -p -m 0644 mad.pc %{buildroot}%{_libdir}/pkgconfig/mad.pc
74touch -r mad.h.sed %{buildroot}/%{_includedir}/mad.h
75
76%clean
77%__rm -rf %{buildroot}
78
79%post -p /sbin/ldconfig
80
81%postun -p /sbin/ldconfig
82
83
84%files
85%defattr(-, root, root)
86%doc CHANGES COPYING COPYRIGHT CREDITS README TODO
87%{_libdir}/*.so.*
88
89%files devel
90%defattr(-, root, root)
91%{_libdir}/*.so
92%{_libdir}/pkgconfig/*.pc
93%{_includedir}/*
94
95
96%changelog
97* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-7
98- change release to sync with self-build-libmad
99
100* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-6
101- rebuild with new toolchain
102
103* Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.15.1b-5
104- changed Source0: to http://prdownloads.sourceforge.net/mad
105
106* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-4
107- change release to sync with self-build-libmad
108
109* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.15.1b-3
110- added %%configure options: --disable-static
111
112* Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.15.1b-2vl5
113- applied new versioning policy, spec in utf-8
114
115* Thu Jan 03 2007 Satoshi MACHINO <machino@vinelinux.org> 0.15.1b-1vl2
116- rebuilt on new toolchain
117
118* Thu Mar 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.15.1b-1vl1
119- Build for Vine Linux based on freshrpms
120- add Japanese summary
121- add %post and %postun script
122
123* Thu Feb 19 2004 Matthias Saou <http://freshrpms.net/> - 0.15.1b-1.fr
124- Update to 0.15.1b.
125
126* Sun Nov  2 2003 Matthias Saou <http://freshrpms.net/> - 0.15.0b-3.fr
127- Rebuild for Fedora Core 1.
128
129* Thu Aug 28 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
130- Added mad.pc required by gstreamer-plugins.
131
132* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
133- Update to 0.15.0b.
134- Split a devel package.
135
136* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
137- Rebuilt for Red Hat Linux 9.
138- Added mad provides.
139
140* Fri Sep 27 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
141- Rebuild for Red Hat Linux 8.0 (missing because of license issues).
142- Spec file cleanup.
143
144* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 0.14.2b-3
145- ship libid3tag too
146
147* Thu Feb 21 2002 Bill Nottingham <notting@redhat.com>
148- rebuild
149
150* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
151- split libmad off into a separate package
152
Note: See TracBrowser for help on using the repository browser.