source: projects/specs/trunk/nonfree/self-build-libdvdnav/self-build-libdvdnav-vl.spec @ 620

Revision 620, 5.0 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname libdvdnav
2%define name    self-build-%{pkgname}
3%define version 4.1.3
4%define release 5%{?_dist_release}
5
6%define source0path     MPlayer/releases/dvdnav/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        GPLv2+
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20Requires(post):         doxygen
21Requires(post):         libdvdread-devel >= 4.1.3-1
22
23BuildArch:      noarch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Packager:       munepi
27
28%description
29libdvdnav provides a simple library for reading DVD video discs.
30The code is based on Ogle and used in, among others, the Xine dvdnav plug-in.
31
32If you install this package, it automaticaly downloads source
33code ,compile it, and create rpm packages of %{pkgname}-%{version}.
34And the created rpm packages are automatically installed
35if installation is executed by apt-get command or synaptic
36package manager.
37
38[Note]
39This package requires many other packages to compile
40targetsoftware. So it consume more disk space than usual.
41Also installation takes logner time because of compilation.
42(This will take a few minutes to quarter or half of an hour,
43depends on building environment)
44
45[About self-build package]
46For some kind of software, distributing of binary package
47may viorate the patent or law. Therefore we chose self-build
48packge, create binary package on your machine, for such kind
49of softwares instead of distributing binary package.
50
51Please obey the national law when you use the created binary
52packages. And if you want to use the softwares using patented
53thechnology, it may be required to get a permission, make an
54agreement or purchas a license. Please consider it with your
55purpose or way of use and take appropriate action.
56
57%description -l ja
58libdvdnavはDVDビデオディスクを読み取るためのシンプルなライブラリを
59提供しています。
60そのコードは Ogle をベースにしていて、他の間で、xine dvdnav プラグインで、
61使用されています。
62
63このパッケージをインストールすると、自動的にソースコードを
64ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
65パッケージを作成します。
66また apt-get コマンドや synaptic パッケージマネージャから実行
67した場合は、作成された rpm パッケージのインストールも自動的に
68行います。
69
70[注意]
71コンパイルに必要な多くの関連パッケージを要求するので通常より
72ディスクの領域を多く消費します。
73またインストール時にコンパイルを行うため、通常より時間がかか
74る場合があります。(環境にもよりますが数分から数十分程度)
75
76[self-build パッケージについて]
77ソフトウェアによってはバイナリパッケージの配布が特許や法律に
78違反する可能性があるものがあります。その為、このような問題が
79懸念されるソフトウェアについてはバイナリパッケージを直接配布
80せずに、ユーザの環境でバイナリを作成する self-build パッケー
81ジという方法を採っています。
82
83作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
84アのライセンス、および利用する国の各種法令に従ってください。
85また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
86センスの購入などが必要となる場合がありますので、利用する目的
87や形態に応じて各自で判断し適切な対応を取ってください。
88
89
90%prep
91[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
92
93%install
94%{__rm} -rf ${RPM_BUILD_ROOT}
95%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
96%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97
98%clean
99%{__rm} -rf ${RPM_BUILD_ROOT}
100
101%posttrans
102/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
103        http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 15000
104/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
105                                 %{pkgname}-devel-%{version}-%{release}
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}/*
110
111%changelog
112* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 4.1.3-5
113- renamed %%{Source0} to libdvdnav-vl.spec
114
115* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-4
116- added BuildArch: noarch
117- avoided to execute self-build-rpm.sh on RPM transaction
118  - moved %%post actions to %%posttrans
119
120* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-3
121- added BuildRequires: doxygen
122
123* Sat Dec 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
124- added PreReq: libdvdread-devel >= 4.1.3-1
125
126* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
127- initial bulid based on Fedora package
Note: See TracBrowser for help on using the repository browser.