source: projects/specs/trunk/nonfree/self-build-libdvdnav/libdvdnav-vl.spec @ 620

Revision 620, 5.1 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1Name:           libdvdnav
2Version:        4.1.3
3Release:        5%{?_dist_release}
4Summary:        A library for reading DVD video discs based on Ogle code
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8Source:         http://www.mplayerhq.hu/MPlayer/releases/dvdnav/libdvdnav-%{version}.tar.bz2
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10
11BuildRequires:  doxygen
12BuildRequires:  libdvdread-devel >= 4.1.3-1
13
14%description
15libdvdnav provides a simple library for reading DVD video discs.
16The code is based on Ogle and used in, among others, the Xine dvdnav plug-in.
17
18%package        devel
19Summary:        Development files for libdvdnav
20Group:          Development/Libraries
21Requires:       %{name} = %{version}-%{release}
22Requires:       libdvdread-devel >= 4.1.3-1
23Requires:       pkgconfig
24
25%description    devel
26libdvdnav-devel contains the files necessary to build packages that use the
27libdvdnav library.
28
29%prep
30%setup -q
31
32%build
33./configure2 \
34    --disable-opts \
35    --disable-static \
36    --disable-strip \
37    --extra-cflags="%{optflags}" \
38    --libdir=%{_libdir} \
39    --prefix=%{_prefix} \
40    --shlibdir=%{_libdir} \
41    --with-dvdread-config="pkg-config dvdread" \
42
43%{__make} %{?_smp_mflags}
44pushd doc
45doxygen doxy.conf
46popd
47
48%install
49%{__rm} -rf %{buildroot}
50%{__make} install DESTDIR=%{buildroot}
51%{__install} -d -m 755 %{buildroot}/%{_datadir}/aclocal
52%{__install} -p -m 644 m4/dvdnav.m4 %{buildroot}/%{_datadir}/aclocal
53
54%clean
55%{__rm} -rf %{buildroot}
56
57%post -p /sbin/ldconfig
58
59%postun -p /sbin/ldconfig
60
61%files
62%defattr(-,root,root,-)
63%doc AUTHORS ChangeLog COPYING NEWS README TODO
64%{_libdir}/libdvdnav.so.*
65%{_libdir}/libdvdnavmini.so.*
66
67%files devel
68%defattr(-,root,root,-)
69%doc doc/html/*
70%{_bindir}/dvdnav-config
71%{_libdir}/libdvdnav.so
72%{_libdir}/libdvdnavmini.so
73%{_includedir}/dvdnav
74%{_datadir}/aclocal/dvdnav.m4
75%{_libdir}/pkgconfig/dvdnav.pc
76%{_libdir}/pkgconfig/dvdnavmini.pc
77
78%changelog
79* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 4.1.3-5
80- change release to sync with self-build-libdvdnav
81
82* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-4
83- change release to sync with self-build-libdvdnav
84
85* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-3
86- change release to sync with self-build-libdvdnav
87
88* Sat Dec 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-2
89- change release to sync with self-build-libdvdnav
90
91* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.1.3-1
92- initial bulid based on Fedora package
93
94* Tue Sep 09 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.3-1
95- update to 4.1.3 final
96
97* Sun Aug 31 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.3-0.4.rc1
98- update to 4.1.3rc1
99- require libdvdread with fixed API
100
101* Fri Jul 25 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.3-0.3
102- add missing file to -devel
103
104* Thu Jul 17 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.3-0.2
105- update to current SVN
106- use new external libdvdread
107
108* Fri Jun 06 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.3-0.1
109- update to current SVN (pre-4.1.3)
110- macroize
111- re-enable parallel make
112
113* Sun Apr 13 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.2-1
114- update to 4.1.2
115- drop obsolete patches (merged upstream)
116
117* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.1.1-6
118- Autorebuild for GCC 4.3
119
120* Sun Jan 27 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.1-5
121- fix missing <inttypes.h> include (bug 428910)
122
123* Sun Jan 06 2008 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.1-4
124- make sure -devel requires our version of libdvdread-devel
125
126* Thu Nov 22 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.1-3
127- fix build with internal libdvdread
128
129* Wed Nov 21 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.1-2
130- use upstream non-autotools buildsystem
131- build with external libdvdread for older releases
132- fix version.h
133- fix soname
134- fix lib paths on 64bit
135
136* Thu Nov 01 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 4.1.1-1
137- switch to new upstream
138- libdvdread comes from here now
139- apply dvdread udf-related fixes from upstream SVN
140
141* Sun Aug 19 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 0.1.10-4.20070819
142- update to current snapshot
143- specfile cleanups
144
145* Thu May 03 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 0.1.10-3.20070503
146- update to current snapshot from new upstream
147- clean up some specfile cruft
148- disable static libs
149- drop unnecessary explicit dependency on libdvdread
150
151* Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.1.10-2
152- Drop Epoch completely
153
154* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
155- switch to new release field
156- drop Epoch
157
158* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
159- add dist
160
161* Wed Oct 13 2004 Ville Skytt霎ー <ville.skytta at iki.fi> - 0:0.1.10-0.lvn.1
162- Update to 0.1.10.
163- Disable dependency tracking to speed up the build.
164
165* Wed Jun 25 2003 Thomas Vander Stichele <thomas at apestaart dot org>
166- 0:0.1.9-0.fdr.2: incorporated bugzilla suggestions, new release
167
168* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
169- 0:0.1.9-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.