source: projects/specs/trunk/nonfree/self-build-libdvdcss/libdvdcss-vl.spec @ 1906

Revision 1906, 6.7 KB checked in by munepi, 14 years ago (diff)

update self-build-libdvdcss

RevLine 
[615]1%define name    libdvdcss
2%define version 1.2.10
[1906]3%define release 4%{?_dist_release}
[615]4
5%define major   2
6%define libname %{name}%{major}
7
8Summary:        Library for accessing DVDs like block devices with transparent decryption
9Summary(ja):    CSS を解除し DVD をブロックデバイスのように利用できるライブラリ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{name}-%{version}.tar.bz2
14Patch0:         libdvdcss-1.2.10-doxygen-fix.patch
15# (See http://mailman.videolan.org/pipermail/libdvdcss-devel/2007-July/000471.html)
16
17License:        GPL
18Group:          System Environment/Libraries
19URL:            http://www.videolan.org/developers/libdvdcss.html
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23
24%description
25libdvdcss is a simple library designed for accessing DVDs like a block device
26without having to bother about the decryption. The important features are:
27 * Portability: currently supported platforms are GNU/Linux, FreeBSD, NetBSD,
28   OpenBSD, BSD/OS, BeOS, Windows 95/98/ME, Windows NT/2000/XP, MacOS X,
29   Solaris, HP-UX and OS/2.
30 * Adaptability: unlike most similar projects, libdvdcss doesn't require the
31   region of your drive to be set and will try its best to read from the disc
32   even in the case of a region mismatch.
33 * Simplicity: a DVD player can be built around the libdvdcss API using no
34   more than 6 library calls.
35
36%description -l ja
37libdvdcss は CSS (Content Scranble System) の解除に煩わされずに DVD を
38ブロックデバイスのように利用するためのシンプルなライブラリです。
39主要な特徴は以下の通り:
40 * 可搬性; 現在サポートされているプラットフォームは GNU/Linux、FreeBSD、
41   NetBSD、OpenBSD、BSD/OS、BeOS、Windows 95/98/ME、Windows NT/2000/XP、
42   MacOS X、Solaris、HP-UX と OS/2 です。
43 * 適応性: 似たような他のプロジェクトとは違い、libdvdcss は DVD ドライブ
44   にリージョンコードが設定されている必要が無く、またリージョンが異なる
45   場合でもできるだけディスクを読み込もうと努力します。
46 * シンプル: libdvdcss を使えば 6種類の API を使うだけで DVD プレイヤー
47   を作成することができます。
48
49#-------------------------------------------------------------------------------
50%package -n %{libname}
51Summary:        Library for accessing DVDs like block devices with transparent decryption
52Summary(ja):    CSS を解除し DVD をブロックデバイスのように利用できるライブラリ
53Group:          System Environment/Libraries
54Provides:       %name = %version-%release
55
56%description -n %{libname}
57libdvdcss is a simple library designed for accessing DVDs like a block device
58without having to bother about the decryption. The important features are:
59 * Portability: currently supported platforms are GNU/Linux, FreeBSD, NetBSD,
60   OpenBSD, BSD/OS, BeOS, Windows 95/98/ME, Windows NT/2000/XP, MacOS X,
61   Solaris, HP-UX and OS/2.
62 * Adaptability: unlike most similar projects, libdvdcss doesn't require the
63   region of your drive to be set and will try its best to read from the disc
64   even in the case of a region mismatch.
65 * Simplicity: a DVD player can be built around the libdvdcss API using no
66   more than 6 library calls.
67
68%description -n %{libname} -l ja
69libdvdcss は CSS (Content Scranble System) の解除に煩わされずに DVD を
70ブロックデバイスのように利用するためのシンプルなライブラリです。
71主要な特徴は以下の通り:
72 * 可搬性; 現在サポートされているプラットフォームは GNU/Linux、FreeBSD、
73   NetBSD、OpenBSD、BSD/OS、BeOS、Windows 95/98/ME、Windows NT/2000/XP、
74   MacOS X、Solaris、HP-UX と OS/2 です。
75 * 適応性: 似たような他のプロジェクトとは違い、libdvdcss は DVD ドライブ
76   にリージョンコードが設定されている必要が無く、またリージョンが異なる
77   場合でもできるだけディスクを読み込もうと努力します。
78 * シンプル: libdvdcss を使えば 6種類の API を使うだけで DVD プレイヤー
79   を作成することができます。
80
81#-------------------------------------------------------------------------------
82%package -n %{libname}-devel
83Summary:        Development tools for programs which will use the %{name} library
84Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
85Group:          Development/Libraries
86Requires:       %{libname} = %version-%release
87Provides:       %{name}-devel = %version-%release
88 
89%description -n %{libname}-devel
90The %{name}-devel package includes the header files and static libraries
91necessary for developing programs which will manipulate DVDs files using
92the %{name} library.
93 
94If you are going to develop programs which will manipulate DVDs, you
95should install %{name}-devel.  You'll also need to have the %{name}
96package installed.
97
98%description -n %{libname}-devel -l ja
99%{name}-devel パッケージは %{name} ライブラリを使って DCD を操作する
100アプリケーションを開発するのに必要なライブラリやヘッダファイルを含ん
101でいます。
102
103もし DVD を操作するプログラムを開発するなら、 %{name}-devel パッケージ
104をインストールしてください。また %{name} パッケージもインストールされて
105いる必要があります。
106
107#'
108
109%prep
110%setup -q
111%patch0 -p0 -b .doxygen-fix
112
[1906]113
[615]114%build
[1906]115%configure --disable-static --disable-doc
[615]116%{__make}
117
118
119%install
120%{__rm} -rf ${RPM_BUILD_ROOT}
121%makeinstall
122
123# remove unnecessary file.
124%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libdvdcss.la
125
126%clean
127%{__rm} -rf ${RPM_BUILD_ROOT}
128
129
130%post -n %{libname} -p /sbin/ldconfig
131 
132%postun -n %{libname} -p /sbin/ldconfig
133
134
135%files -n %{libname}
136%defattr(-,root,root)
137%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
138%{_libdir}/libdvdcss.so.*
139
140%files -n %{libname}-devel
141%defattr(-,root,root)
142%{_includedir}/dvdcss/dvdcss.h
143%{_libdir}/libdvdcss.so
144%{_libdir}/pkgconfig/lib*.pc
145
146%changelog
[1906]147* Sun Sep 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.10-4
148- added configure options: --disable-static --disable-doc
149- excluded %%{_libdir}/libdvdcss.a from libdvdcss2-devel
150
[615]151* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.10-3
152- change release to sync with self-build-libdvdcss
153
154* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.10-2
155- change release to sync with self-build-libdvdcss
156
157* Tue Nov 25 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.10-1
158- new upstream release
159- applied libdvdcss-1.2.10-doxygen-fix.patch
160
161* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-2
162- spec in utf8
163
164* Sat May 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.2.9-1
165- apply new versioning policy
166
167* Thu Nov  1 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.2.9-0vl1
168- initial build for Vine Linux
169- add Patch0 to fix doxygen error
Note: See TracBrowser for help on using the repository browser.