source: projects/specs/trunk/nonfree/self-build-libdvbpsi/self-build-libdvbpsi-vl.spec @ 620

Revision 620, 4.5 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname libdvbpsi
2%define name    self-build-%{pkgname}
3%define version 0.1.6
4%define release 2%{?_dist_release}
5
6%define real_name libdvbpsi5
7
8%define sourceurl0      http://download.videolan.org/pub/libdvbpsi/%{version}/%{real_name}-%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           %{name}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16
17License:        GPLv2+
18Group:          Restricted Software
19
20# Requires(posttrans) not yet implemented. So we use (post) instead.
21Requires(post):         self-build-setup >= 0.9.9
22
23Requires(post):         graphviz
24Requires(post):         doxygen
25
26BuildArch:      noarch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Packager:       munepi
30
31%description
32libdvbpsi is a very simple and fully portable library designed for
33MPEG TS and DVB PSI table decoding and generation.
34
35
36If you install this package, it automaticaly downloads source
37code ,compile it, and create rpm packages of %{pkgname}-%{version}.
38And the created rpm packages are automatically installed
39if installation is executed by apt-get command or synaptic
40package manager.
41
42[Note]
43This package requires many other packages to compile
44targetsoftware. So it consume more disk space than usual.
45Also installation takes logner time because of compilation.
46(This will take a few minutes to quarter or half of an hour,
47depends on building environment)
48
49[About self-build package]
50For some kind of software, distributing of binary package
51may viorate the patent or law. Therefore we chose self-build
52packge, create binary package on your machine, for such kind
53of softwares instead of distributing binary package.
54
55Please obey the national law when you use the created binary
56packages. And if you want to use the softwares using patented
57thechnology, it may be required to get a permission, make an
58agreement or purchas a license. Please consider it with your
59purpose or way of use and take appropriate action.
60
61%description -l ja
62libdvbpsi は MPEG TS と DVB PSI テーブル復号と生成のために設計された
63とても単純で完全な汎用ライブラリです。
64
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
68パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73[注意]
74コンパイルに必要な多くの関連パッケージを要求するので通常より
75ディスクの領域を多く消費します。
76またインストール時にコンパイルを行うため、通常より時間がかか
77る場合があります。(環境にもよりますが数分から数十分程度)
78
79[self-build パッケージについて]
80ソフトウェアによってはバイナリパッケージの配布が特許や法律に
81違反する可能性があるものがあります。その為、このような問題が
82懸念されるソフトウェアについてはバイナリパッケージを直接配布
83せずに、ユーザの環境でバイナリを作成する self-build パッケー
84ジという方法を採っています。
85
86作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
87アのライセンス、および利用する国の各種法令に従ってください。
88また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
89センスの購入などが必要となる場合がありますので、利用する目的
90や形態に応じて各自で判断し適切な対応を取ってください。
91
92%prep
93[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
94
95
96%install
97%{__rm} -rf ${RPM_BUILD_ROOT}
98%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104%posttrans
105/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 95000
106/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
107                                 %{pkgname}-devel-%{version}-%{release}
108
109%files
110%defattr(-,root,root)
111%{_datadir}/%{name}
112
113%changelog
114* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
115- renamed %%{Source0} to libdvbpsi-vl.spec
116
117* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
118- initial bulid for self-build
Note: See TracBrowser for help on using the repository browser.