source: projects/specs/trunk/nonfree/self-build-libdvbpsi/self-build-libdvbpsi-vl.spec @ 9215

Revision 9215, 4.8 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%define pkgname libdvbpsi
2%define name    self-build-%{pkgname}
3%define version 1.2.0
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://download.videolan.org/pub/libdvbpsi/%{version}/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14
15License:        LGPLv2+
16Group:          Restricted Software
17
18# Requires(posttrans) not yet implemented. So we use (post) instead.
19Requires(post):         self-build-setup >= 0.9.9
20
21Requires(post):         graphviz
22#Requires(post):        doxygen
23
24BuildArch:      noarch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Packager:       munepi
28
29%description
30libdvbpsi is a very simple and fully portable library designed for
31MPEG TS and DVB PSI table decoding and generation.
32
33
34If you install this package, it automaticaly downloads source
35code ,compile it, and create rpm packages of %{pkgname}-%{version}.
36And the created rpm packages are automatically installed
37if installation is executed by apt-get command or synaptic
38package manager.
39
40[Note]
41This package requires many other packages to compile
42targetsoftware. So it consume more disk space than usual.
43Also installation takes logner time because of compilation.
44(This will take a few minutes to quarter or half of an hour,
45depends on building environment)
46
47[About self-build package]
48For some kind of software, distributing of binary package
49may viorate the patent or law. Therefore we chose self-build
50packge, create binary package on your machine, for such kind
51of softwares instead of distributing binary package.
52
53Please obey the national law when you use the created binary
54packages. And if you want to use the softwares using patented
55thechnology, it may be required to get a permission, make an
56agreement or purchas a license. Please consider it with your
57purpose or way of use and take appropriate action.
58
59%description -l ja
60libdvbpsi は MPEG TS と DVB PSI テーブル復号と生成のために設計された
61とても単純で完全な汎用ライブラリです。
62
63
64このパッケージをインストールすると、自動的にソースコードを
65ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
66パッケージを作成します。
67また apt-get コマンドや synaptic パッケージマネージャから実行
68した場合は、作成された rpm パッケージのインストールも自動的に
69行います。
70
71[注意]
72コンパイルに必要な多くの関連パッケージを要求するので通常より
73ディスクの領域を多く消費します。
74またインストール時にコンパイルを行うため、通常より時間がかか
75る場合があります。(環境にもよりますが数分から数十分程度)
76
77[self-build パッケージについて]
78ソフトウェアによってはバイナリパッケージの配布が特許や法律に
79違反する可能性があるものがあります。その為、このような問題が
80懸念されるソフトウェアについてはバイナリパッケージを直接配布
81せずに、ユーザの環境でバイナリを作成する self-build パッケー
82ジという方法を採っています。
83
84作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
85アのライセンス、および利用する国の各種法令に従ってください。
86また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
87センスの購入などが必要となる場合がありますので、利用する目的
88や形態に応じて各自で判断し適切な対応を取ってください。
89
90%prep
91[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
92
93
94%install
95%{__rm} -rf ${RPM_BUILD_ROOT}
96%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
97%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102%posttrans
103/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 92000
104/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
105                                 %{pkgname}-devel-%{version}-%{release}
106
107%files
108%defattr(-,root,root)
109%{_datadir}/%{name}
110
111%changelog
112* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.0-1
113- new upstream release
114
115* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.2-1
116- updated to 0.2.2
117- Switch to LGPLv2+
118- dropped BuildRequires: doxygen
119
120* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.7-1
121- updated to 0.1.7
122
123* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
124- renamed %%{Source0} to libdvbpsi-vl.spec
125
126* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
127- initial bulid for self-build
Note: See TracBrowser for help on using the repository browser.