source: projects/specs/trunk/nonfree/self-build-libdvbpsi/libdvbpsi-vl.spec @ 620

Revision 620, 3.2 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1## -*- coding: utf-8-unix -*-
2%define real_name libdvbpsi5
3
4Summary:        Library for MPEG TS and DVB PSI tables decoding and generation
5Name:           libdvbpsi
6Version:        0.1.6
7Release:        2%{?_dist_release}
8License:        GPLv2+
9Group:          System Environment/Libraries
10URL:            http://www.videolan.org/developers/libdvbpsi.html
11Source0:        http://download.videolan.org/pub/libdvbpsi/%{version}/%{real_name}-%{version}.tar.bz2
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  graphviz doxygen
14
15%description
16libdvbpsi is a very simple and fully portable library designed for
17MPEG TS and DVB PSI table decoding and generation.
18
19%package devel
20Summary:        Development package for %{name}
21Group:          Development/Libraries
22Requires:       %{name} = %{version}-%{release}
23
24%description devel
25libdvbpsi is a very simple and fully portable library designed for
26MPEG TS and DVB PSI table decoding and generation.
27This package contains development files for %{name}
28
29%prep
30%setup -q -n %{real_name}-%{version}
31
32
33%build
34%configure \
35    --disable-dependency-tracking \
36    --disable-static
37%__make %{?_smp_mflags}
38%__make doc
39
40
41%install
42%__rm -rf $RPM_BUILD_ROOT
43%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
44%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
45
46
47%clean
48%__rm -rf $RPM_BUILD_ROOT
49
50
51%post -p /sbin/ldconfig
52%postun -p /sbin/ldconfig
53
54%files
55%defattr(-,root,root,-)
56%doc AUTHORS COPYING ChangeLog README
57%{_libdir}/%{name}.so.*
58
59%files devel
60%defattr(-,root,root,-)
61%doc doc/doxygen/html
62%{_includedir}/dvbpsi/
63%{_libdir}/lib*.so
64
65
66%changelog
67* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-2
68- change release to sync with self-build-libdvbpsi
69
70* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.1.6-1
71- built based on RPM Fusion development
72
73* Sat Oct 17 2009 kwizart < kwizart at gmail.com > - 0.1.6-6
74- Rebuild
75
76* Sun Apr  5 2009 kwizart < kwizart at gmail.com > - 0.1.6-5
77- Rebuild
78
79* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.1.6-4
80- rebuild for new F11 features
81
82* Mon Aug 04 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.1.6-3
83- rebuild
84
85* Tue Feb 26 2008 kwizart < kwizart at gmail.com > - 0.1.6-2
86- Rebuild for gcc43
87
88* Mon Oct 22 2007 kwizart < kwizart at gmail.com > - 0.1.6-1
89- Update to 0.1.6
90
91* Sun Oct 14 2007 kwizart < kwizart at gmail.com > - 0.1.5-3
92- Rpmfusion Merge Review
93
94* Mon Mar 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> 0.1.5-2
95- Drop Epoch completely
96
97* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
98- switch to new release field
99
100* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
101- add dist
102
103* Tue Jul 12 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 0:0.1.5-0.lvn.1
104- 0.1.5.
105- Build with dependency tracking disabled.
106- Miscellaneous specfile cleanups.
107
108* Mon May 17 2004 Dams <anvil[AT]livna.org> - 0:0.1.3-0.lvn.4
109- Added url in Source0
110
111* Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.3
112- Removed comment after scriptlets
113
114* Mon Aug 18 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.2
115- Moved some doc to devel package
116
117* Sat Aug 16 2003 Dams <anvil[AT]livna.org> 0:0.1.3-0.fdr.1
118- Added post/postun scriptlets
119- Using RPM_OPT_FLAGS
120- Updated to 0.1.3
121
122* Sun Jun 29 2003 Dams <anvil[AT]livna.org>
123- Initial build.
Note: See TracBrowser for help on using the repository browser.