source: projects/specs/trunk/nonfree/self-build-libdca/self-build-libdca-vl.spec @ 620

Revision 620, 5.3 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname libdca
2%define name    self-build-%{pkgname}
3%define version 0.0.5
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source1:        libdca-0.0.5-relsymlinks.patch
15
16License:        GPLv2+
17Group:          Restricted Software
18
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):         automake, libtool
23
24BuildArch:      noarch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26
27Packager:       munepi
28
29%description
30libdca is a free library for decoding DTS Coherent Acoustics
31streams. It is released under the terms of the GPL license.
32The DTS Coherent Acoustics standard is used in a variety of
33applications, including DVD, DTS audio CD and radio broadcasting.
34
35If you install this package, it automaticaly downloads source
36code ,compile it, and create rpm packages of %{pkgname}-%{version}.
37And the created rpm packages are automatically installed
38if installation is executed by apt-get command or synaptic
39package manager.
40
41[Note]
42This package requires many other packages to compile
43targetsoftware. So it consume more disk space than usual.
44Also installation takes logner time because of compilation.
45(This will take a few minutes to quarter or half of an hour,
46depends on building environment)
47
48[About self-build package]
49For some kind of software, distributing of binary package
50may viorate the patent or law. Therefore we chose self-build
51packge, create binary package on your machine, for such kind
52of softwares instead of distributing binary package.
53
54Please obey the national law when you use the created binary
55packages. And if you want to use the softwares using patented
56thechnology, it may be required to get a permission, make an
57agreement or purchas a license. Please consider it with your
58purpose or way of use and take appropriate action.
59
60%description -l ja
61libdca は DTS Coherent Acoustics ストリームをデコードするため
62のフリーなライブラリです.GPL の下でリリースされています.
63DTS Coherent Acoustics は DVD や DTS オーディオ,ラジオ放送に
64含まれており、多様なアプリケーションで使われています.
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version}
68の rpm パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73[注意]
74コンパイルに必要な多くの関連パッケージを要求するので通常より
75ディスクの領域を多く消費します。
76またインストール時にコンパイルを行うため、通常より時間がかか
77る場合があります。(環境にもよりますが数分から数十分程度)
78
79[self-build パッケージについて]
80ソフトウェアによってはバイナリパッケージの配布が特許や法律に
81違反する可能性があるものがあります。その為、このような問題が
82懸念されるソフトウェアについてはバイナリパッケージを直接配布
83せずに、ユーザの環境でバイナリを作成する self-build パッケー
84ジという方法を採っています。
85
86作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
87アのライセンス、および利用する国の各種法令に従ってください。
88また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
89センスの購入などが必要となる場合がありますので、利用する目的
90や形態に応じて各自で判断し適切な対応を取ってください。
91
92%prep
93[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
94
95%install
96%{__rm} -rf ${RPM_BUILD_ROOT}
97%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104%posttrans
105/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 30000
106/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
107                                 %{pkgname}-devel-%{version}-%{release}
108
109%files
110%defattr(-,root,root)
111%{_datadir}/%{name}
112
113%changelog
114* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.5-4
115- renamed %%{Source0} to libdca-vl.spec
116
117* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-3
118- added BuildArch: noarch
119- avoided to execute self-build-rpm.sh on RPM transaction
120  - moved %%post actions to %%posttrans
121
122* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-2
123- spec in utf8
124- remove *.la
125
126* Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.5-1
127- run pre-allocate-rpm.sh in %%post
128- set PreReq: self-build-setup >= 0.8
129- apply new versioning policy
130
131* Tue Feb 19 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.5-0vl1
132- initial build for Vine Linux 4.2
133
134### end of file
Note: See TracBrowser for help on using the repository browser.