source: projects/specs/trunk/nonfree/self-build-lame/self-build-lame-vl.spec @ 10524

Revision 10524, 6.4 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1%define pkgname lame
2%define name    self-build-%{pkgname}
3%define version 3.99.5
4%define release 2%{?_dist_release}
5
6#% define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
7%define sourceurl http://prdownloads.sourceforge.net/lame/lame-%{version}.tar.gz
8
9Summary:        Package to automatically build %{pkgname} rpm package
10Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
11Name:           %{name}
12Version:        %{version}
13Release:        %{release}
14Source0:        %{pkgname}-vl.spec
15Source101:      lame-noexecstack.patch
16Source110:      lame-3.99-libs-termcap.patch
17
18License:        GPLv2+
19Group:          Restricted Software
20
21Requires(post):         self-build-setup >= 1.0.0
22
23# (build)requies of target package.
24%{?enable_brhist:Requires(post):        ncurses}
25%{?enable_brhist:Requires(post):        ncurses-devel}
26Requires(post):         gtk+
27Requires(post):         gtk+-devel
28Requires(post):         nasm
29
30BuildArch:      noarch
31BuildRoot:      %{_tmppath}/%{name}-%{version}-root
32
33Packager:       munepi
34
35%description
36Lame is an open source developing mp3 encoder.
37
38If you install this package, it automaticaly downloads source
39code ,compile it, and create rpm packages of %{pkgname}-%{version}.
40And the created rpm packages are automatically installed
41if installation is executed by apt-get command or synaptic
42package manager.
43
44[Note]
45This package requires many other packages to compile
46targetsoftware. So it consume more disk space than usual.
47Also installation takes logner time because of compilation.
48(This will take a few minutes to quarter or half of an hour,
49depends on building environment)
50
51[About self-build package]
52For some kind of software, distributing of binary package
53may viorate the patent or law. Therefore we chose self-build
54packge, create binary package on your machine, for such kind
55of softwares instead of distributing binary package.
56
57Please obey the national law when you use the created binary
58packages. And if you want to use the softwares using patented
59thechnology, it may be required to get a permission, make an
60agreement or purchas a license. Please consider it with your
61purpose or way of use and take appropriate action.
62
63%description -l ja
64lame はオープンソースで開発されている mp3 エンコーダです。
65
66このパッケージをインストールすると、自動的にソースコードを
67ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
68パッケージを作成します。
69また apt-get コマンドや synaptic パッケージマネージャから実行
70した場合は、作成された rpm パッケージのインストールも自動的に
71行います。
72
73[注意]
74コンパイルに必要な多くの関連パッケージを要求するので通常より
75ディスクの領域を多く消費します。
76またインストール時にコンパイルを行うため、通常より時間がかか
77る場合があります。(環境にもよりますが数分から数十分程度)
78
79[self-build パッケージについて]
80ソフトウェアによってはバイナリパッケージの配布が特許や法律に
81違反する可能性があるものがあります。その為、このような問題が
82懸念されるソフトウェアについてはバイナリパッケージを直接配布
83せずに、ユーザの環境でバイナリを作成する self-build パッケー
84ジという方法を採っています。
85
86作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
87アのライセンス、および利用する国の各種法令に従ってください。
88また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
89センスの購入などが必要となる場合がありますので、利用する目的
90や形態に応じて各自で判断し適切な対応を取ってください。
91
92%prep
93[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
94
95%install
96%{__rm} -rf ${RPM_BUILD_ROOT}
97%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
98%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
99%{__install} -m 644 %{SOURCE101} %{SOURCE110} \
100    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
101
102
103%clean
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%posttrans
107/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 61000
108/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
109                                 %{pkgname}-mp3x-%{version}-%{release} \
110                                 %{pkgname}-devel-%{version}-%{release}
111
112
113%files
114%defattr(-,root,root)
115%{_datadir}/%{name}
116
117%changelog
118* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.99.5-2
119- fix lame-vl.spec for i686
120
121* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.99.5
122- new upstream release
123
124* Sun Sep 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.4-2
125- added BuildArch: noarch
126- disable the VBR bitrate histgrum feature
127
128* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.4-1
129- new upstream release
130
131* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.3-1
132- new upstream release
133- renamed %%{Source0} to lame-vl.spec
134
135* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-2
136- rebuilt to add signature
137
138* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.98.2-1
139- new upstream release
140
141* Fri Jun 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-5
142- dropped BuildArch: noarch
143  (because if BuildArch: noarch, %%ifarch is invalid)
144
145* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-4
146- added BuildArch: noarch
147- avoided to execute self-build-rpm.sh on RPM transaction
148  - moved %%post actions to %%posttrans
149
150* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.97-3
151- spec in utf8
152- remove *.la
153
154* Wed May 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-2
155- change %%{__make} option to -j1 in Source0 <BTS:VineLinux:611>
156- remove trailing /* in %%files <BTS:VineLinux:622>
157
158* Sat May 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-1
159- run pre-allocate-rpm.sh in %%post
160- set PreReq: self-build-setup >= 0.8
161- apply new versioning policy
162
163* Thu Nov 01 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl3
164- update description about self-build package
165
166* Mon Oct 22 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl2
167- unset BuildArch: noarch
168
169* Thu Oct 18 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.97-0vl1
170- initial build for Vine Linux
171  (using same version number of target software)
Note: See TracBrowser for help on using the repository browser.