source: projects/specs/trunk/nonfree/self-build-k9copy/self-build-k9copy-vl.spec @ 6071

Revision 6071, 6.2 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname k9copy
2%define name    self-build-%{pkgname}
3%define version 2.3.8
4%define release 1%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/%{pkgname}/%{pkgname}-%{version}-Source.tar.gz
7
8%define _kde4_bindir            %{_bindir}
9%define _kde4_iconsdir          %{_datadir}/icons
10%define _kde4_datadir           %{_datadir}
11%define _kde4_docdir            %{_datadir}/doc
12%define _kde4_appsdir           %{_datadir}/kde4/apps
13
14%define _qt4_qmake              %{_libdir}/qt4/bin/qmake
15
16Summary:        Package to automatically build %{pkgname} rpm package
17Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
18Name:           %{name}
19Version:        %{version}
20Release:        %{release}
21
22Obsoletes:      k9copy < 2.0.0
23Obsoletes:      self-build-k9copy < 2.0.0
24
25Source0:        %{pkgname}-vl.spec
26## vine
27Source100:      k9copy-2.3.5-ja.po
28# upstreamable patches
29#Source151:      k9copy-2.3.5-dso.patch
30#Source152:      k9copy-2.3.5-mimetype.patch
31
32License:        GPLv2+
33Group:          Restricted Software
34
35Requires(post):         self-build-setup >= 0.9.0
36
37Requires(post): qt4-devel
38Requires(post): cmake
39Requires(post): desktop-file-utils
40Requires(post): self-build-ffmpeg
41Requires(post): gettext
42Requires(post): hal-devel
43Requires(post): kdelibs4-devel >= 4.4.3
44Requires(post): libdvdread-devel
45Requires(post): self-build-libmpeg2
46Requires(post): pkgconfig
47Requires(post): xine-lib-devel
48
49Requires:       dvd+rw-tools
50Requires:       dvdauthor
51Requires:       kdebase-runtime >= 4.4.3
52
53##
54Requires(post): self-build-mplayer
55
56BuildArch:      noarch
57BuildRoot:      %{_tmppath}/%{name}-%{version}-root
58
59Packager:       munepi
60
61%description
62Video DVD backup and creation program, features include:
63* Video stream compression for fit onto a single layer 4.7GB DVD
64* DVD Burning
65* Creation of ISO images
66* Audio tracks and subtitle selection
67* Video title preview
68* Preservation of the original menus
69
70
71If you install this package, it automaticaly downloads source
72code ,compile it, and create rpm packages of %{pkgname}-%{version}.
73And the created rpm packages are automatically installed
74if installation is executed by apt-get command or synaptic
75package manager.
76
77[Note]
78This package requires many other packages to compile
79targetsoftware. So it consume more disk space than usual.
80Also installation takes logner time because of compilation.
81(This will take a few minutes to quarter or half of an hour,
82depends on building environment)
83
84[About self-build package]
85For some kind of software, distributing of binary package
86may viorate the patent or law. Therefore we chose self-build
87packge, create binary package on your machine, for such kind
88of softwares instead of distributing binary package.
89
90Please obey the national law when you use the created binary
91packages. And if you want to use the softwares using patented
92thechnology, it may be required to get a permission, make an
93agreement or purchas a license. Please consider it with your
94purpose or way of use and take appropriate action.
95
96%description -l ja
97ビデオDVDバックアップと作成プログラム。
98特徴は:
99* 片面一層4.7GB DVDへ収めるためのビデオストリーム圧縮
100* DVD書き込み
101* ISOイメージの作成
102* オーディオトラックとサブタイトル選択
103* ビデオタイトルプレビュー
104* オリジナルのメニューの保存
105
106
107このパッケージをインストールすると、自動的にソースコードを
108ダウンロードしてコンパイルし、%{pkgname}-%{version}
109の rpm パッケージを作成します。
110また apt-get コマンドや synaptic パッケージマネージャから実行
111した場合は、作成された rpm パッケージのインストールも自動的に
112行います。
113
114[注意]
115コンパイルに必要な多くの関連パッケージを要求するので通常より
116ディスクの領域を多く消費します。
117またインストール時にコンパイルを行うため、通常より時間がかか
118る場合があります。(環境にもよりますが数分から数十分程度)
119
120[self-build パッケージについて]
121ソフトウェアによってはバイナリパッケージの配布が特許や法律に
122違反する可能性があるものがあります。その為、このような問題が
123懸念されるソフトウェアについてはバイナリパッケージを直接配布
124せずに、ユーザの環境でバイナリを作成する self-build パッケー
125ジという方法を採っています。
126
127作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
128アのライセンス、および利用する国の各種法令に従ってください。
129また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
130センスの購入などが必要となる場合がありますので、利用する目的
131や形態に応じて各自で判断し適切な対応を取ってください。
132
133
134%prep
135[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
136
137
138%install
139%{__rm} -rf ${RPM_BUILD_ROOT}
140%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
141%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
142%{__install} -m 644 \
143    %{SOURCE100} \
144    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
145
146
147%clean
148%{__rm} -rf ${RPM_BUILD_ROOT}
149
150%posttrans
151/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 71000
152
153%files
154%defattr(-,root,root)
155%{_datadir}/%{name}/*
156
157
158%changelog
159* Tue Apr  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.8-1
160- new upstream release
161- dropped upstreamed/unused patches
162
163* Sun May 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.7-1
164- new upstream release
165
166* Sat Aug 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.6-1
167- new upstream release
168
169* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.3.5-1
170- new upstream release
171- added k9copy-2.3.5-ja.po
172- check version between original spec and self-build spec in %%prep
173
174* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-4
175- added Requires(post): arts-devel
176
177* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-3
178- added BuildArch: noarch
179- avoided to execute self-build-rpm.sh on RPM transaction
180  - moved %%post actions to %%posttrans
181
182* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.4-2
183- initial build
184
185### end of file
Note: See TracBrowser for help on using the repository browser.