source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/self-build-gstreamer1-plugins-ugly-vl.spec @ 9097

Revision 9097, 8.0 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define pkgname gstreamer1-plugins-ugly
2%define major           1.0
3%define _gst_ver        1.4.4
4%define _gstpb_ver      1.4.4
5%define version         1.4.4
6%define release         1%{?_dist_release}
7
8%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           self-build-%{pkgname}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16License:        LGPLv2+
17Group:          Restricted Software
18
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
23Requires(post):         gstreamer1-devel >= %{_gst_ver}
24Requires(post):         gstreamer1-plugins-base-devel >= %{_gstpb_ver}
25#Requires(post):                gtk-doc >= 1.3
26Requires(post):         python >= 2.1, python-pyxml
27Requires(post):         glib2-devel >= 2.6
28Requires(post):         twolame-devel
29Requires(post):         liboil-devel >= 0.3.0
30Requires(post):         libcdio-devel >= 0.82
31Requires(post):         libdvdread-devel
32Requires(post):         PyXML
33Requires(post):         self-build-libmad >= 0.15
34Requires(post):         libid3tag-devel >= 0.15
35Requires(post):         self-build-ffmpeg
36Requires(post):         self-build-x264
37Requires(post):         self-build-libmpeg2
38Requires(post):         self-build-a52dec
39Requires(post):         self-build-lame
40Requires(post):         self-build-libmad
41
42Obsoletes:              gstreamer1-plugins-ugly < %{version}-%{release}
43
44
45BuildArch:      noarch
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48Packager:       Takemikaduchi
49
50%description
51gstreamer1-plugins-ugly is a set of ugly plugins for Gstreamer
52streaming-media framework.
53
54If you install this package, it automaticaly downloads source
55code, compile it, and create rpm packages of
56%{pkgname}-%{version}.
57And the created rpm packages are automatically installed
58if installation is executed by apt-get command or synaptic
59package manager.
60
61
62[Note]
63This package requires many other packages to compile
64targetsoftware. So it consume more disk space than usual.
65Also installation takes logner time because of compilation.
66(This will take a few minutes to quarter or half of an hour,
67depends on building environment)
68
69[About self-build package]
70For some kind of software, distributing of binary package
71may viorate the patent or law. Therefore we chose self-build
72packge, create binary package on your machine, for such kind
73of softwares instead of distributing binary package.
74
75Please obey the national law when you use the created binary
76packages. And if you want to use the softwares using patented
77thechnology, it may be required to get a permission, make an
78agreement or purchas a license. Please consider it with your
79purpose or way of use and take appropriate action.
80
81%description -l ja
82gstreamer1-plugins-ugly は GStreamer ストリーミングメディア
83フレームワーク用 ugly プラグイン集です。
84
85このパッケージをインストールすると、自動的にソースコードを
86ダウンロードしてコンパイルし、%{pkgname}-%{version}
87の rpm パッケージを作成します。
88また apt-get コマンドや synaptic パッケージマネージャから実行
89した場合は、作成された rpm パッケージのインストールも自動的に
90行います。
91
92
93[注意]
94コンパイルに必要な多くの関連パッケージを要求するので通常より
95ディスクの領域を多く消費します。
96またインストール時にコンパイルを行うため、通常より時間がかか
97る場合があります。(環境にもよりますが数分から数十分程度)
98
99[self-build パッケージについて]
100ソフトウェアによってはバイナリパッケージの配布が特許や法律に
101違反する可能性があるものがあります。その為、このような問題が
102懸念されるソフトウェアについてはバイナリパッケージを直接配布
103せずに、ユーザの環境でバイナリを作成する self-build パッケー
104ジという方法を採っています。
105
106作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
107アのライセンス、および利用する国の各種法令に従ってください。
108また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
109センスの購入などが必要となる場合がありますので、利用する目的
110や形態に応じて各自で判断し適切な対応を取ってください。
111
112
113%prep
114[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
115
116
117%install
118%{__rm} -rf ${RPM_BUILD_ROOT}
119%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121
122
123%clean
124%{__rm} -rf ${RPM_BUILD_ROOT}
125
126%posttrans
127/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
128
129%files
130%defattr(-,root,root)
131%{_datadir}/%{name}
132
133%changelog
134* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
135- new upstream release
136
137* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
138- new upstream release
139
140* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
141- rebuild with libcdio-0.92
142
143* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
144- new upstream release
145
146* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
147- new upstream release
148
149* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
150- new upstream release
151
152* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
153- new upstream release
154
155* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
156- new upstream release
157
158* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
159- new upstream release
160
161* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
162- new upstream release
163
164* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
165- new upstream release
166
167* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
168- new upstream release
169
170* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
171- new upstream release
172
173* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
174- new upstream release
175
176* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
177- new upstream release
178
179* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
180- new upstream release
181- rename package
182
183* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
184- new upstream relase
185
186* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
187- new upstream relase
188- built with new x264
189- License: LGPLv2+
190
191* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
192- new upstream relase
193
194* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
195- new upstream relase
196
197* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
198- new upstream relase
199
200* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
201- new upstream relase
202- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
203
204* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
205- new upstream relase
206
207* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
208- new upstream relase
209- added Requires(post): self-build-libmpeg2
210  - enable mpeg2dec with libmpeg2-devel in %%configure
211- check version between original spec and self-build spec in %%prep
212
213* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
214- avoided to execute self-build-rpm.sh on RPM transaction
215  - moved %%post actions to %%posttrans
216
217* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
218- added BuildArch: noarch
219- dropped PreReq: gtk-doc >= 1.3
220
221* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
222- new upstream relase
223
224* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
225- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
226
227* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
228- new upstream relase
229
230* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
231- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.