source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 8369

Revision 8369, 12.4 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.2.4
5%define _gstpb_ver      1.2.4
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.2.4
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109
110%find_lang gst-plugins-ugly-%{major}
111
112%clean
113%__rm -rf %{buildroot}
114
115
116%files -f gst-plugins-ugly-%{major}.lang
117%defattr(-,root,root)
118%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
119%{_datadir}/gstreamer-%{major}/presets
120# ugly plugins without external dependencies
121%{_libdir}/gstreamer-%{major}/*.so
122
123# ugly plugins with external dependencies, but in the main package
124# %{_libdir}/gstreamer-%{major}/libgstmad.so
125
126# %files devel
127# %defattr(-,root,root)
128# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
129
130
131%changelog
132* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
133- new upstream relase
134
135* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
136- new upstream relase
137
138* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
139- new upstream relase
140
141* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
142- new upstream relase
143
144* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
145- new upstream relase
146
147* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
148- new upstream relase
149
150* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
151- new upstream relase
152
153* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
154- new upstream relase
155
156* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
157- new upstream relase
158
159* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
160- new upstream relase
161
162* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
163- new upstream relase
164
165* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
166- new upstream relase
167
168* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
169- new upstream relase
170- rename package
171
172* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
173- new upstream relase
174
175* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
176- new upstream relase
177- built with new x264
178- License: LGPLv2+
179
180* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
181- new upstream relase
182
183* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
184- new upstream relase
185
186* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
187- new upstream relase
188
189* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
190- new upstream relase
191
192* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
193- new upstream relase
194
195* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
196- new upstream relase
197- enable mpeg2dec with libmpeg2-devel in %%configure
198
199* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
200- change release to sync with self-build-gstreamer-plugins-ugly
201
202* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
203- dropped BuildRequires: gtk-doc >= 1.3
204  - disable-gtk-doc in configure options
205  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
206
207* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
208- new upstream relase
209
210* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
211- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
212
213* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
214- new upstream relase
215
216* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
217- upstream release
218- delete --disable-a52dec configure option
219- delete %%with_lame macro
220- added japanase summary and description
221
222* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
223- upstream release
224- update %%_gst_ver
225
226* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
227- add NoSource: 0
228
229* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
230- add %%with_lame macro
231  - enable lame support if rpmbuild with '--with lame'
232
233* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
234- upstream release
235
236* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
237- upstream release
238- add libgstdvdsub.so
239
240* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
241- upstream release
242- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
243- add libgstasf.so
244
245* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
246- fix typo
247
248* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
249- initial package based on gstreamer-plugins
250- new upstream release
251  - change major to 0.10
252- update dependencies
253- update %%configure options
254
255* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
256- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
257
258* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
259- added missing alsa plugin
260
261* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
262- new upstream release
263- added alsa and cairo plugins
264
265* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
266- new upstream release
267
268* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
269- new upstream release
270
271* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
272- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
273
274* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
275- added libgstcdparania.so for gnome-cd (gnome-media)
276- BuildRequires: cdparanoia-devel
277
278* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
279- drop BuildRequires: xmms-devel, Requires: xmms
280
281* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
282- libgstvideo4linux2.so temoporally omitted for ppc
283  (will be back later, I hope)
284
285* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
286- new upstream release
287- s/Copyright/License/
288- includes plugins depend on main package libraries only
289
290* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
291- new upstream release
292
293* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
294- new upstream release
295
296* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
297- new upstream release
298
299* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
300- new upstream release
301
302* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
303- build with -fPIC on alpha
304
305* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
306- modified scripts
307
308* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
309- new upstream release
310
311* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
312- disable some plugins.
313
314* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
315- new upstream release
316- initial build for Vine Linux
317
318* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
319- Include ia64
320- Add BuildRequires: autoconf automake
321
322* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
323- rebuild
324
325* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
326- rebuild
327
328* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
329- rebuild
330- disable tests
331
332* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
333- rebuild
334
335* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
336- fix libdir for ia64.
337
338* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
339- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
340- Add devel package
341
342* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
343- 0.5.0
344- apparently, festival-devel isn't needed.
345
346* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
347- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
348
349* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
350- excludearch the arches that can't build gstreamer cothreads
351- well it isn't really SMP-safe
352- add patch for including pthread.h when required
353- prereq gconftool
354- fix typo that broke schema installation in post
355
356* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
357- initial "official" import
358- munge tarball for legal cleanliness
359
360* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
361- 0.4.2
362
363* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
364- 0.4.1
365- install the gconf schema
366- use %%configure
367
368* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
369- update to 0.4.0
370- give explicit vorbis include path, don't run vorbis test
371
372* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
373- collapse into one package to preserve some sanity
374
375* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
376- added more BuildRequires and Requires
377- rearranged some plugins
378- added changelog ;)
Note: See TracBrowser for help on using the repository browser.