source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 7756

Revision 7756, 11.9 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.0.9
5%define _gstpb_ver      1.0.9
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.0.9
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109
110%find_lang gst-plugins-ugly-%{major}
111
112%clean
113%__rm -rf %{buildroot}
114
115
116%files -f gst-plugins-ugly-%{major}.lang
117%defattr(-,root,root)
118%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
119%{_datadir}/gstreamer-%{major}/presets
120# ugly plugins without external dependencies
121%{_libdir}/gstreamer-%{major}/*.so
122
123# ugly plugins with external dependencies, but in the main package
124# %{_libdir}/gstreamer-%{major}/libgstmad.so
125
126# %files devel
127# %defattr(-,root,root)
128# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
129
130
131%changelog
132* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
133- new upstream relase
134
135* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
136- new upstream relase
137
138* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
139- new upstream relase
140
141* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
142- new upstream relase
143
144* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
145- new upstream relase
146
147* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
148- new upstream relase
149
150* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
151- new upstream relase
152- rename package
153
154* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
155- new upstream relase
156
157* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
158- new upstream relase
159- built with new x264
160- License: LGPLv2+
161
162* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
163- new upstream relase
164
165* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
166- new upstream relase
167
168* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
169- new upstream relase
170
171* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
172- new upstream relase
173
174* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
175- new upstream relase
176
177* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
178- new upstream relase
179- enable mpeg2dec with libmpeg2-devel in %%configure
180
181* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
182- change release to sync with self-build-gstreamer-plugins-ugly
183
184* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
185- dropped BuildRequires: gtk-doc >= 1.3
186  - disable-gtk-doc in configure options
187  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
188
189* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
190- new upstream relase
191
192* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
193- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
194
195* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
196- new upstream relase
197
198* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
199- upstream release
200- delete --disable-a52dec configure option
201- delete %%with_lame macro
202- added japanase summary and description
203
204* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
205- upstream release
206- update %%_gst_ver
207
208* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
209- add NoSource: 0
210
211* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
212- add %%with_lame macro
213  - enable lame support if rpmbuild with '--with lame'
214
215* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
216- upstream release
217
218* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
219- upstream release
220- add libgstdvdsub.so
221
222* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
223- upstream release
224- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
225- add libgstasf.so
226
227* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
228- fix typo
229
230* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
231- initial package based on gstreamer-plugins
232- new upstream release
233  - change major to 0.10
234- update dependencies
235- update %%configure options
236
237* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
238- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
239
240* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
241- added missing alsa plugin
242
243* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
244- new upstream release
245- added alsa and cairo plugins
246
247* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
248- new upstream release
249
250* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
251- new upstream release
252
253* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
254- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
255
256* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
257- added libgstcdparania.so for gnome-cd (gnome-media)
258- BuildRequires: cdparanoia-devel
259
260* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
261- drop BuildRequires: xmms-devel, Requires: xmms
262
263* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
264- libgstvideo4linux2.so temoporally omitted for ppc
265  (will be back later, I hope)
266
267* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
268- new upstream release
269- s/Copyright/License/
270- includes plugins depend on main package libraries only
271
272* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
273- new upstream release
274
275* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
276- new upstream release
277
278* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
279- new upstream release
280
281* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
282- new upstream release
283
284* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
285- build with -fPIC on alpha
286
287* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
288- modified scripts
289
290* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
291- new upstream release
292
293* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
294- disable some plugins.
295
296* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
297- new upstream release
298- initial build for Vine Linux
299
300* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
301- Include ia64
302- Add BuildRequires: autoconf automake
303
304* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
305- rebuild
306
307* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
308- rebuild
309
310* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
311- rebuild
312- disable tests
313
314* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
315- rebuild
316
317* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
318- fix libdir for ia64.
319
320* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
321- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
322- Add devel package
323
324* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
325- 0.5.0
326- apparently, festival-devel isn't needed.
327
328* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
329- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
330
331* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
332- excludearch the arches that can't build gstreamer cothreads
333- well it isn't really SMP-safe
334- add patch for including pthread.h when required
335- prereq gconftool
336- fix typo that broke schema installation in post
337
338* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
339- initial "official" import
340- munge tarball for legal cleanliness
341
342* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
343- 0.4.2
344
345* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
346- 0.4.1
347- install the gconf schema
348- use %%configure
349
350* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
351- update to 0.4.0
352- give explicit vorbis include path, don't run vorbis test
353
354* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
355- collapse into one package to preserve some sanity
356
357* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
358- added more BuildRequires and Requires
359- rearranged some plugins
360- added changelog ;)
Note: See TracBrowser for help on using the repository browser.