source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 10524

Revision 10524, 13.2 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.6.4
5%define _gstpb_ver      1.6.4
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.6.4
11Release:        2%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109%__rm -rf %{buildroot}%{_datadir}/gtk-doc
110
111%find_lang gst-plugins-ugly-%{major}
112
113%clean
114%__rm -rf %{buildroot}
115
116
117%files -f gst-plugins-ugly-%{major}.lang
118%defattr(-,root,root)
119%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
120%{_datadir}/gstreamer-%{major}/presets
121# ugly plugins without external dependencies
122%{_libdir}/gstreamer-%{major}/*.so
123
124# ugly plugins with external dependencies, but in the main package
125# %{_libdir}/gstreamer-%{major}/libgstmad.so
126
127# %files devel
128# %defattr(-,root,root)
129# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
130
131
132%changelog
133* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
134- rebuild with libcdio-0.93
135
136* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
137- new upstream relase
138
139* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
140- new upstream relase
141
142* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
143- new upstream relase
144
145* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
146- new upstream relase
147
148* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
149- new upstream relase
150
151* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
152- new upstream relase
153
154* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
155- new upstream relase
156
157* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
158- rebuild with libcdio-0.92
159
160* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
161- new upstream relase
162
163* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
164- new upstream relase
165
166* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
167- new upstream relase
168
169* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
170- new upstream relase
171
172* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
173- new upstream relase
174
175* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
176- new upstream relase
177
178* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
179- new upstream relase
180
181* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
182- new upstream relase
183
184* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
185- new upstream relase
186
187* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
188- new upstream relase
189
190* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
191- new upstream relase
192
193* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
194- new upstream relase
195
196* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
197- new upstream relase
198- rename package
199
200* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
201- new upstream relase
202
203* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
204- new upstream relase
205- built with new x264
206- License: LGPLv2+
207
208* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
209- new upstream relase
210
211* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
212- new upstream relase
213
214* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
215- new upstream relase
216
217* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
218- new upstream relase
219
220* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
221- new upstream relase
222
223* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
224- new upstream relase
225- enable mpeg2dec with libmpeg2-devel in %%configure
226
227* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
228- change release to sync with self-build-gstreamer-plugins-ugly
229
230* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
231- dropped BuildRequires: gtk-doc >= 1.3
232  - disable-gtk-doc in configure options
233  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
234
235* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
236- new upstream relase
237
238* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
239- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
240
241* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
242- new upstream relase
243
244* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
245- upstream release
246- delete --disable-a52dec configure option
247- delete %%with_lame macro
248- added japanase summary and description
249
250* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
251- upstream release
252- update %%_gst_ver
253
254* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
255- add NoSource: 0
256
257* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
258- add %%with_lame macro
259  - enable lame support if rpmbuild with '--with lame'
260
261* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
262- upstream release
263
264* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
265- upstream release
266- add libgstdvdsub.so
267
268* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
269- upstream release
270- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
271- add libgstasf.so
272
273* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
274- fix typo
275
276* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
277- initial package based on gstreamer-plugins
278- new upstream release
279  - change major to 0.10
280- update dependencies
281- update %%configure options
282
283* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
284- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
285
286* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
287- added missing alsa plugin
288
289* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
290- new upstream release
291- added alsa and cairo plugins
292
293* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
294- new upstream release
295
296* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
297- new upstream release
298
299* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
300- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
301
302* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
303- added libgstcdparania.so for gnome-cd (gnome-media)
304- BuildRequires: cdparanoia-devel
305
306* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
307- drop BuildRequires: xmms-devel, Requires: xmms
308
309* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
310- libgstvideo4linux2.so temoporally omitted for ppc
311  (will be back later, I hope)
312
313* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
314- new upstream release
315- s/Copyright/License/
316- includes plugins depend on main package libraries only
317
318* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
319- new upstream release
320
321* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
322- new upstream release
323
324* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
325- new upstream release
326
327* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
328- new upstream release
329
330* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
331- build with -fPIC on alpha
332
333* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
334- modified scripts
335
336* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
337- new upstream release
338
339* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
340- disable some plugins.
341
342* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
343- new upstream release
344- initial build for Vine Linux
345
346* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
347- Include ia64
348- Add BuildRequires: autoconf automake
349
350* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
351- rebuild
352
353* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
354- rebuild
355
356* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
357- rebuild
358- disable tests
359
360* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
361- rebuild
362
363* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
364- fix libdir for ia64.
365
366* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
367- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
368- Add devel package
369
370* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
371- 0.5.0
372- apparently, festival-devel isn't needed.
373
374* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
375- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
376
377* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
378- excludearch the arches that can't build gstreamer cothreads
379- well it isn't really SMP-safe
380- add patch for including pthread.h when required
381- prereq gconftool
382- fix typo that broke schema installation in post
383
384* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
385- initial "official" import
386- munge tarball for legal cleanliness
387
388* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
389- 0.4.2
390
391* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
392- 0.4.1
393- install the gconf schema
394- use %%configure
395
396* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
397- update to 0.4.0
398- give explicit vorbis include path, don't run vorbis test
399
400* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
401- collapse into one package to preserve some sanity
402
403* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
404- added more BuildRequires and Requires
405- rearranged some plugins
406- added changelog ;)
Note: See TracBrowser for help on using the repository browser.