source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 12254

Revision 12254, 13.3 KB checked in by ara_t, 4 years ago (diff)

self-build-gstreamer1-plugins-ugly: change BR

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.8.2
5%define _gstpb_ver      1.8.2
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.8.2
11Release:        2%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmad-devel >= 0.15
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51This package contains a set of plug-ins that have good quality and
52correct functionality, but distributing them might pose problems. The
53license on either the plug-ins or the supporting libraries might not
54be how the GStreamer authors like. The code might be widely known to
55present patent problems.
56
57%description -l ja
58GStreamer はメディアデータ操作用の filter graph をベースにしたスト
59リーミングメディアフレームワークです。 このライブラリを使用すれば
60アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
61メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
62イン方式を採用していることから、新しい種類のデータや機能への対応が、
63プラグインを追加することで簡単に実現できます。
64
65このパッケージは品質も機能も問題は無いものの、配布すると問題になる
66可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
67ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
68関連するコードとして良く知られています。
69
70# %package devel
71# Summary:      Documentation files for GStreamer ugly plugins.
72# Summary(ja):  GStreamer ugly プラグインのドキュメント
73# Group:                Development/Libraries
74# Requires:     %{name} = %{version}-%{release}
75
76# %description devel
77# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
78# リーミングメディアフレームワークです。 このライブラリを使用すれば
79# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
80# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
81# イン方式を採用していることから、新しい種類のデータや機能への対応が、
82# プラグインを追加することで簡単に実現できます。
83
84# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
85
86
87%prep
88%setup -q -n gst-plugins-ugly-%{version}
89
90
91%build
92%configure \
93    --disable-static \
94    --disable-amrnb \
95    --disable-sidplay \
96
97%__make %{?_smp_mflags}
98
99%install
100%__rm -rf %{buildroot}
101%makeinstall
102
103# Clean out files that should not be part of the rpm.
104%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
105%__rm -f %{buildroot}%{_libdir}/*.{a,la}
106%__rm -rf %{buildroot}%{_datadir}/gtk-doc
107
108%find_lang gst-plugins-ugly-%{major}
109
110%clean
111%__rm -rf %{buildroot}
112
113
114%files -f gst-plugins-ugly-%{major}.lang
115%defattr(-,root,root)
116%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
117%{_datadir}/gstreamer-%{major}/presets
118# ugly plugins without external dependencies
119%{_libdir}/gstreamer-%{major}/*.so
120
121# ugly plugins with external dependencies, but in the main package
122# %{_libdir}/gstreamer-%{major}/libgstmad.so
123
124# %files devel
125# %defattr(-,root,root)
126# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
127
128
129%changelog
130* Thu Oct 10 2019 Toshiaki Ara <ara_t@384.jp> 1.8.2-2
131- change BR: self-build-{a52dec,lame,libmpeg2} to {a52dec,lame,libmpeg2}-devel
132
133* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
134- new upstream relase
135
136* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-2
137- rebuild with libcdio-0.93
138
139* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
140- new upstream relase
141
142* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
143- new upstream relase
144
145* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
146- new upstream relase
147
148* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
149- new upstream relase
150
151* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
152- new upstream relase
153
154* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
155- new upstream relase
156
157* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
158- new upstream relase
159
160* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
161- rebuild with libcdio-0.92
162
163* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
164- new upstream relase
165
166* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
167- new upstream relase
168
169* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
170- new upstream relase
171
172* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
173- new upstream relase
174
175* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
176- new upstream relase
177
178* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
179- new upstream relase
180
181* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
182- new upstream relase
183
184* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
185- new upstream relase
186
187* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
188- new upstream relase
189
190* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
191- new upstream relase
192
193* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
194- new upstream relase
195
196* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
197- new upstream relase
198
199* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
200- new upstream relase
201- rename package
202
203* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
204- new upstream relase
205
206* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
207- new upstream relase
208- built with new x264
209- License: LGPLv2+
210
211* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
212- new upstream relase
213
214* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
215- new upstream relase
216
217* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
218- new upstream relase
219
220* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
221- new upstream relase
222
223* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
224- new upstream relase
225
226* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
227- new upstream relase
228- enable mpeg2dec with libmpeg2-devel in %%configure
229
230* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
231- change release to sync with self-build-gstreamer-plugins-ugly
232
233* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
234- dropped BuildRequires: gtk-doc >= 1.3
235  - disable-gtk-doc in configure options
236  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
237
238* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
239- new upstream relase
240
241* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
242- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
243
244* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
245- new upstream relase
246
247* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
248- upstream release
249- delete --disable-a52dec configure option
250- delete %%with_lame macro
251- added japanase summary and description
252
253* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
254- upstream release
255- update %%_gst_ver
256
257* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
258- add NoSource: 0
259
260* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
261- add %%with_lame macro
262  - enable lame support if rpmbuild with '--with lame'
263
264* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
265- upstream release
266
267* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
268- upstream release
269- add libgstdvdsub.so
270
271* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
272- upstream release
273- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
274- add libgstasf.so
275
276* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
277- fix typo
278
279* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
280- initial package based on gstreamer-plugins
281- new upstream release
282  - change major to 0.10
283- update dependencies
284- update %%configure options
285
286* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
287- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
288
289* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
290- added missing alsa plugin
291
292* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
293- new upstream release
294- added alsa and cairo plugins
295
296* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
297- new upstream release
298
299* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
300- new upstream release
301
302* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
303- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
304
305* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
306- added libgstcdparania.so for gnome-cd (gnome-media)
307- BuildRequires: cdparanoia-devel
308
309* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
310- drop BuildRequires: xmms-devel, Requires: xmms
311
312* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
313- libgstvideo4linux2.so temoporally omitted for ppc
314  (will be back later, I hope)
315
316* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
317- new upstream release
318- s/Copyright/License/
319- includes plugins depend on main package libraries only
320
321* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
322- new upstream release
323
324* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
325- new upstream release
326
327* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
328- new upstream release
329
330* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
331- new upstream release
332
333* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
334- build with -fPIC on alpha
335
336* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
337- modified scripts
338
339* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
340- new upstream release
341
342* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
343- disable some plugins.
344
345* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
346- new upstream release
347- initial build for Vine Linux
348
349* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
350- Include ia64
351- Add BuildRequires: autoconf automake
352
353* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
354- rebuild
355
356* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
357- rebuild
358
359* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
360- rebuild
361- disable tests
362
363* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
364- rebuild
365
366* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
367- fix libdir for ia64.
368
369* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
370- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
371- Add devel package
372
373* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
374- 0.5.0
375- apparently, festival-devel isn't needed.
376
377* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
378- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
379
380* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
381- excludearch the arches that can't build gstreamer cothreads
382- well it isn't really SMP-safe
383- add patch for including pthread.h when required
384- prereq gconftool
385- fix typo that broke schema installation in post
386
387* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
388- initial "official" import
389- munge tarball for legal cleanliness
390
391* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
392- 0.4.2
393
394* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
395- 0.4.1
396- install the gconf schema
397- use %%configure
398
399* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
400- update to 0.4.0
401- give explicit vorbis include path, don't run vorbis test
402
403* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
404- collapse into one package to preserve some sanity
405
406* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
407- added more BuildRequires and Requires
408- rearranged some plugins
409- added changelog ;)
Note: See TracBrowser for help on using the repository browser.