source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-ugly/gstreamer1-plugins-ugly-vl.spec @ 8011

Revision 8011, 12.1 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1## TODO: build with opencore-amr
2
3%define major           1.0
4%define _gst_ver        1.2.1
5%define _gstpb_ver      1.2.1
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer1-plugins-ugly
10Version:        1.2.1
11Release:        1%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Requires:       gstreamer1 >= %{_gst_ver}
19Requires:       gstreamer1-plugins-base >= %{_gstpb_ver}
20Requires:       glib2
21Requires:       libid3tag
22# Don't require libmad because they are provided by
23# self-build-libmad packages.
24#Requires:      libmad
25
26BuildRequires:  gstreamer1-devel >= %{_gst_ver}
27BuildRequires:  gstreamer1-plugins-base-devel >= %{_gstpb_ver}
28#BuildRequires: gtk-doc >= 1.3
29BuildRequires:  python >= 2.1, python-pyxml
30BuildRequires:  glib2-devel >= 2.6
31BuildRequires:  twolame-devel
32BuildRequires:  libid3tag-devel >= 0.15
33BuildRequires:  liboil-devel >= 0.3.0
34BuildRequires:  libcdio-devel >= 0.82
35BuildRequires:  libdvdread-devel
36BuildRequires:  PyXML
37
38# *-devel packages provided by other self-build-* should only be listed
39# in self-build-%{name}.spec as PreReq.
40##BuildRequires:        x264-devel
41##BuildRequires:        libmpeg2-devel
42##BuildRequires:        a52dec-devel
43##BuildRequires:        lame-devel
44##BuildRequires:        libmad-devel >= 0.15
45
46%description
47GStreamer is a streaming-media framework, based on graphs of filters which
48operate on media data. Applications using this library can do anything
49from real-time sound processing to playing videos, and just about anything
50else media-related.  Its plugin-based architecture means that new data
51types or processing capabilities can be added simply by installing new
52plugins.
53
54This package contains a set of plug-ins that have good quality and
55correct functionality, but distributing them might pose problems. The
56license on either the plug-ins or the supporting libraries might not
57be how the GStreamer authors like. The code might be widely known to
58present patent problems.
59
60%description -l ja
61GStreamer はメディアデータ操作用の filter graph をベースにしたスト
62リーミングメディアフレームワークです。 このライブラリを使用すれば
63アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
64メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
65イン方式を採用していることから、新しい種類のデータや機能への対応が、
66プラグインを追加することで簡単に実現できます。
67
68このパッケージは品質も機能も問題は無いものの、配布すると問題になる
69可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
70ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
71関連するコードとして良く知られています。
72
73# %package devel
74# Summary:      Documentation files for GStreamer ugly plugins.
75# Summary(ja):  GStreamer ugly プラグインのドキュメント
76# Group:                Development/Libraries
77# Requires:     %{name} = %{version}-%{release}
78
79# %description devel
80# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
81# リーミングメディアフレームワークです。 このライブラリを使用すれば
82# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
83# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
84# イン方式を採用していることから、新しい種類のデータや機能への対応が、
85# プラグインを追加することで簡単に実現できます。
86
87# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
88
89
90%prep
91%setup -q -n gst-plugins-ugly-%{version}
92
93
94%build
95%configure \
96    --disable-static \
97    --disable-amrnb \
98    --disable-sidplay \
99
100%__make %{?_smp_mflags}
101
102%install
103%__rm -rf %{buildroot}
104%makeinstall
105
106# Clean out files that should not be part of the rpm.
107%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
108%__rm -f %{buildroot}%{_libdir}/*.{a,la}
109
110%find_lang gst-plugins-ugly-%{major}
111
112%clean
113%__rm -rf %{buildroot}
114
115
116%files -f gst-plugins-ugly-%{major}.lang
117%defattr(-,root,root)
118%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
119%{_datadir}/gstreamer-%{major}/presets
120# ugly plugins without external dependencies
121%{_libdir}/gstreamer-%{major}/*.so
122
123# ugly plugins with external dependencies, but in the main package
124# %{_libdir}/gstreamer-%{major}/libgstmad.so
125
126# %files devel
127# %defattr(-,root,root)
128# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
129
130
131%changelog
132* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
133- new upstream relase
134
135* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
136- new upstream relase
137
138* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
139- new upstream relase
140
141* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
142- new upstream relase
143
144* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
145- new upstream relase
146
147* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
148- new upstream relase
149
150* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
151- new upstream relase
152
153* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
154- new upstream relase
155
156* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
157- new upstream relase
158
159* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
160- new upstream relase
161- rename package
162
163* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
164- new upstream relase
165
166* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
167- new upstream relase
168- built with new x264
169- License: LGPLv2+
170
171* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
172- new upstream relase
173
174* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
175- new upstream relase
176
177* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
178- new upstream relase
179
180* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
181- new upstream relase
182
183* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
184- new upstream relase
185
186* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
187- new upstream relase
188- enable mpeg2dec with libmpeg2-devel in %%configure
189
190* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
191- change release to sync with self-build-gstreamer-plugins-ugly
192
193* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
194- dropped BuildRequires: gtk-doc >= 1.3
195  - disable-gtk-doc in configure options
196  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
197
198* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
199- new upstream relase
200
201* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
202- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
203
204* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
205- new upstream relase
206
207* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
208- upstream release
209- delete --disable-a52dec configure option
210- delete %%with_lame macro
211- added japanase summary and description
212
213* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
214- upstream release
215- update %%_gst_ver
216
217* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
218- add NoSource: 0
219
220* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
221- add %%with_lame macro
222  - enable lame support if rpmbuild with '--with lame'
223
224* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
225- upstream release
226
227* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
228- upstream release
229- add libgstdvdsub.so
230
231* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
232- upstream release
233- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
234- add libgstasf.so
235
236* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
237- fix typo
238
239* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
240- initial package based on gstreamer-plugins
241- new upstream release
242  - change major to 0.10
243- update dependencies
244- update %%configure options
245
246* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
247- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
248
249* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
250- added missing alsa plugin
251
252* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
253- new upstream release
254- added alsa and cairo plugins
255
256* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
257- new upstream release
258
259* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
260- new upstream release
261
262* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
263- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
264
265* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
266- added libgstcdparania.so for gnome-cd (gnome-media)
267- BuildRequires: cdparanoia-devel
268
269* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
270- drop BuildRequires: xmms-devel, Requires: xmms
271
272* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
273- libgstvideo4linux2.so temoporally omitted for ppc
274  (will be back later, I hope)
275
276* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
277- new upstream release
278- s/Copyright/License/
279- includes plugins depend on main package libraries only
280
281* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
282- new upstream release
283
284* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
285- new upstream release
286
287* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
288- new upstream release
289
290* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
291- new upstream release
292
293* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
294- build with -fPIC on alpha
295
296* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
297- modified scripts
298
299* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
300- new upstream release
301
302* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
303- disable some plugins.
304
305* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
306- new upstream release
307- initial build for Vine Linux
308
309* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
310- Include ia64
311- Add BuildRequires: autoconf automake
312
313* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
314- rebuild
315
316* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
317- rebuild
318
319* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
320- rebuild
321- disable tests
322
323* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
324- rebuild
325
326* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
327- fix libdir for ia64.
328
329* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
330- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
331- Add devel package
332
333* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
334- 0.5.0
335- apparently, festival-devel isn't needed.
336
337* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
338- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
339
340* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
341- excludearch the arches that can't build gstreamer cothreads
342- well it isn't really SMP-safe
343- add patch for including pthread.h when required
344- prereq gconftool
345- fix typo that broke schema installation in post
346
347* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
348- initial "official" import
349- munge tarball for legal cleanliness
350
351* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
352- 0.4.2
353
354* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
355- 0.4.1
356- install the gconf schema
357- use %%configure
358
359* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
360- update to 0.4.0
361- give explicit vorbis include path, don't run vorbis test
362
363* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
364- collapse into one package to preserve some sanity
365
366* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
367- added more BuildRequires and Requires
368- rearranged some plugins
369- added changelog ;)
Note: See TracBrowser for help on using the repository browser.