source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-libav/self-build-gstreamer1-plugins-libav-vl.spec @ 10716

Revision 10716, 5.5 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define pkgname gstreamer1-plugins-libav
2%define major           1.0
3%define _gst_ver        1.8.2
4%define _gstpb_ver      1.8.2
5%define version         1.8.2
6%define release         1%{?_dist_release}
7
8%define sourceurl       http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-%{version}.tar.xz
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           self-build-%{pkgname}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16License:        LGPLv2
17Group:          Restricted Software
18
19Requires(post):         self-build-setup >= 0.9.9
20
21# (build)requies of target package.
22Requires(post):         gstreamer1-devel >= %{_gst_ver}
23Requires(post):         gstreamer1-plugins-base-devel >= %{_gstpb_ver}
24Requires(post):         orc-devel >= 0.4.16
25Requires(post):         self-build-ffmpeg
26
27Obsoletes:      gstreamer1-plugins-libav < %{version}-%{release}
28
29BuildArch:      noarch
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32Packager:               Takemikaduchi
33
34%description
35gstreamer1-plugins-libav is a set of libav(FFmpeg) plugins for
36GStreamer streaming-media framework.
37
38If you install this package, it automaticaly downloads source
39code, compile it, and create rpm packages of
40%{pkgname}-%{version}.
41And the created rpm packages are automatically installed
42if installation is executed by apt-get command or synaptic
43package manager.
44
45
46[Note]
47This package requires many other packages to compile
48targetsoftware. So it consume more disk space than usual.
49Also installation takes logner time because of compilation.
50(This will take a few minutes to quarter or half of an hour,
51depends on building environment)
52
53[About self-build package]
54For some kind of software, distributing of binary package
55may viorate the patent or law. Therefore we chose self-build
56packge, create binary package on your machine, for such kind
57of softwares instead of distributing binary package.
58
59Please obey the national law when you use the created binary
60packages. And if you want to use the softwares using patented
61thechnology, it may be required to get a permission, make an
62agreement or purchas a license. Please consider it with your
63purpose or way of use and take appropriate action.
64
65%description -l ja
66gstreamer1-plugins-libav は GStreamer ストリーミングメディア
67フレームワーク用 libav プラグイン集です。
68
69このパッケージをインストールすると、自動的にソースコードを
70ダウンロードしてコンパイルし、%{pkgname}-%{version}
71の rpm パッケージを作成します。
72また apt-get コマンドや synaptic パッケージマネージャから実行
73した場合は、作成された rpm パッケージのインストールも自動的に
74行います。
75
76
77[注意]
78コンパイルに必要な多くの関連パッケージを要求するので通常より
79ディスクの領域を多く消費します。
80またインストール時にコンパイルを行うため、通常より時間がかか
81る場合があります。(環境にもよりますが数分から数十分程度)
82
83[self-build パッケージについて]
84ソフトウェアによってはバイナリパッケージの配布が特許や法律に
85違反する可能性があるものがあります。その為、このような問題が
86懸念されるソフトウェアについてはバイナリパッケージを直接配布
87せずに、ユーザの環境でバイナリを作成する self-build パッケー
88ジという方法を採っています。
89
90作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
91アのライセンス、および利用する国の各種法令に従ってください。
92また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
93センスの購入などが必要となる場合がありますので、利用する目的
94や形態に応じて各自で判断し適切な対応を取ってください。
95
96
97%prep
98[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
99
100
101%install
102%{__rm} -rf ${RPM_BUILD_ROOT}
103%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
104%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
105
106
107%clean
108%{__rm} -rf ${RPM_BUILD_ROOT}
109
110%posttrans
111/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 90000
112
113%files
114%defattr(-,root,root)
115%{_datadir}/%{name}
116
117%changelog
118* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
119- new upstream release
120
121* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
122- new upstream release
123
124* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
125- new upstream release
126
127* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
128- new upstream release
129
130* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
131- new upstream release
132
133* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
134- new upstream release
135
136* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
137- new upstream release
138
139* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
140- new upstream release
141
142* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
143- new upstream release
144
145* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
146- new upstream release
147
148* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
149- new upstream release
150
151* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
152- new upstream release
153
154* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
155- new upstream release
156
157* Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
158- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.