source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 9900

Revision 9900, 16.4 KB checked in by Takemikaduchi, 8 years ago (diff)

firefox: new upstream release
others: rebuild with nettle-3.1.1

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.6.2
5%define gstpb_minver 1.6.2
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Summary(ja): GStreamer ストリーミングメディアフレームワーク用 bad プラグイン集
9Name: gstreamer1-plugins-bad
10Version: 1.6.2
11Release: 2%{?_dist_release}
12# The freeze and nfs plugins are LGPLv2 (only)
13License: LGPLv2+
14Group: System Environment/Libraries
15URL: http://gstreamer.freedesktop.org/
16Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires: %{gstreamer} >= %{gst_minver}
19BuildRequires: %{gstreamer}-devel >= %{gst_minver}
20BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
21BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
22
23BuildRequires: check
24BuildRequires: gettext
25BuildRequires: PyXML
26BuildRequires: libXt-devel
27
28BuildRequires: bzip2-devel
29BuildRequires: celt-devel
30BuildRequires: exempi-devel
31BuildRequires: jasper-devel
32#BuildRequires: ladspa-devel
33BuildRequires: libass-devel
34BuildRequires: libdc1394-devel
35BuildRequires: libdvdnav-devel
36BuildRequires: libexif-devel
37#BuildRequires: libiptcdata-devel
38BuildRequires: kate-devel
39BuildRequires: libmodplug-devel
40BuildRequires: libmpcdec-devel
41#BuildRequires: libofa-devel
42BuildRequires: librsvg2-devel
43BuildRequires: libsndfile-devel
44#BuildRequires: libtimidity-devel
45BuildRequires: libvpx-devel
46BuildRequires: mesa-libGLU-devel
47BuildRequires: openssl-devel
48BuildRequires: orc-devel
49#BuildRequires: schroedinger-devel
50BuildRequires: SDL-devel
51#BuildRequires: slv2-devel
52BuildRequires: soundtouch-devel
53BuildRequires: wavpack-devel
54#BuildRequires: wildmidi-devel
55#BuildRequires: zbar-devel
56BuildRequires: libmms-devel
57BuildRequires: twolame-devel
58#BuildRequires: libmimic-devel
59
60# self build
61#BuildRequires: libdca-devel
62#BuildRequires: faad2-devel
63#BuildRequires: xvidcore-devel
64#BuildRequires: mjpegtools-devel
65
66
67%description
68GStreamer is a streaming media framework, based on graphs of elements which
69operate on media data.
70
71This package contains plug-ins that have licensing issues, aren't tested
72well enough, or the code is not of good enough quality.
73
74
75# %package extras
76# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
77# Group: Applications/Multimedia
78# Requires: %{name} = %{version}-%{release}
79
80# %description extras
81# GStreamer is a streaming media framework, based on graphs of elements which
82# operate on media data.
83
84# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
85# tested well enough, or the code is not of good enough quality.
86
87# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
88# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
89# very much and require additional libraries to be installed.
90
91
92%prep
93%setup -q -n gst-plugins-bad-%{version}
94
95%build
96%configure \
97        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
98
99# Don't use rpath!
100%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
101%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
102%{__make} %{?_smp_mflags}
103
104
105%install
106%{__rm} -rf %{buildroot}
107%{__make} install DESTDIR="%{buildroot}"
108
109# Clean out files that should not be part of the rpm.
110%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
111%{__rm} -f %{buildroot}%{_libdir}/*.la
112
113# conflict with gstreamer1-plugins-bad
114%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
116%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h
117%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
118%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
119%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
120
121REMOVE_MODULE_LIST=" \
122        libgstadpcmdec.so \
123        libgstadpcmenc.so \
124        libgstasfmux.so \
125        libgstaudiomixer.so \
126        libgstaudiovisualizers.so \
127        libgstautoconvert.so \
128        libgstbayer.so \
129        libgstbz2.so \
130        libgstcamerabin2.so \
131        libgstcoloreffects.so \
132        libgstcompositor.so \
133        libgstdataurisrc.so \
134        libgstdebugutilsbad.so \
135        libgstdtmf.so \
136        libgstdvb.so \
137        libgstfestival.so \
138        libgstfieldanalysis.so \
139        libgstfragmented.so \
140        libgstfrei0r.so \
141        libgstgaudieffects.so \
142        libgstgdp.so \
143        libgstgeometrictransform.so \
144        libgstgsm.so \
145        libgstid3tag.so \
146        libgstinter.so \
147        libgstinterlace.so \
148        libgstivfparse.so \
149        libgstjp2kdecimator.so \
150        libgstjpegformat.so \
151        libgstliveadder.so \
152        libgstmpegpsdemux.so \
153        libgstmpegtsdemux.so \
154        libgstmpegpsmux.so \
155        libgstmpegtsmux.so \
156        libgstmidi.so \
157        libgstneonhttpsrc.so \
158        libgstopengl.so \
159        libgstpcapparse.so \
160        libgstpnm.so \
161        libgstrawparse.so \
162        libgstremovesilence.so \
163        libgstresindvd.so \
164        libgstrfbsrc.so \
165        libgstrtpmux.so \
166        libgstrtpvp8.so \
167        libgstscaletempoplugin.so \
168        libgstsdpelem.so \
169        libgstsegmentclip.so \
170        libgstshm.so \
171        libgstsmooth.so \
172        libgstsndfile.so \
173        libgstsoundtouch.so \
174        libgstspeed.so \
175        libgststereo.so \
176        libgstsubenc.so \
177        libgsty4mdec.so \
178        libgstaccurip.so \
179        libgstaiff.so \
180        libgstaudiofxbad \
181        libgstfreeverb.so \
182        libgstivtc.so \
183        libgstmfc.so \
184        libgstmxf.so \
185        libgstrsvg.so \
186        libgstvideofiltersbad.so \
187        libgstvideoparsersbad.so \
188        libgstvideosignal.so \
189        libgstvmnc.so \
190        libgstaudiofxbad.so \
191        libgstyadif.so \
192        libgstdtls.so \
193        libgstrtpbad.so \
194        libgstrtponvif.so \
195        libgstvcdsrc.so"
196
197for file in $REMOVE_MODULE_LIST; do
198        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
199done
200
201%clean
202%{__rm} -rf %{buildroot}
203
204
205%post -p /sbin/ldconfig
206
207%postun -p /sbin/ldconfig
208
209
210%files
211%defattr(-,root,root,-)
212%doc AUTHORS COPYING README REQUIREMENTS
213%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
214%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
215%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
216%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
217%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
218%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
219%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
220%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
221%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
222%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
223%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
224%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
225%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
226%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
227%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
228%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
229%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
230%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
231%{_libdir}/gstreamer-%{majorminor}/libgstx265.so
232
233
234%changelog
235* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-2
236- rebuild with nettle-3.1.1
237
238* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
239- new upstream release
240
241* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
242- new upstream release
243
244* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-2
245- changed Group to System Environment/Libraries
246
247* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
248- new upstream release
249
250* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
251- new upstream release
252
253* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
254- new upstream release
255
256* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
257- new upstream release
258
259* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
260- new upstream release
261
262* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
263- new upstream release
264
265* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
266- new upstream release
267
268* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
269- new upstream release
270
271* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
272- new upstream release
273
274* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
275- new upstream release
276
277* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
278- new upstream release
279
280* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
281- new upstream release
282
283* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
284- new upstream release
285
286* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
287- new upstream release
288
289* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
290- new upstream release
291
292* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
293- new upstream release
294- rename package
295
296* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
297- new upstream release
298- added BuildRequires: libvpx-devel
299
300* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
301- s/self-build-libdvdnav/libdvdnav/
302
303* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
304- new upstream release
305- added BuildRequires:
306  - libmms-devel
307  - librtmp-devel
308
309* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
310- new upstream release
311
312* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
313- new upstream release
314
315* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
316- new upstream release
317- added BuildRequires: libvdpau-devel
318
319* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
320- new upstream release
321
322* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
323- new upstream release
324- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
325  gst-plugins-bad-0.10.5-mms-seek.patch
326
327* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
328- new upstream release
329- dropped devel and devel-docs subpackages
330
331* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
332- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
333- changed to BuildRequires:  self-build-faad2 from faad2-devel
334
335* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
336- initial build based on RPM Fusion package
337
338* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
339- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
340
341* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
342- Rebuild for new x264 (using patch from Rathann)
343
344* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
345- New upstream release 0.10.9
346- Rebuild for new directfb
347
348* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
349- Rebuild for new x264 and to generate new magic gstreamer provides
350
351* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
352- Enable DVD navigation plugin
353
354* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
355- Release bump to keep rpmfusion version higher then livna
356
357* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
358- New upstream release 0.10.8
359- Merge changes from latest freshrpms package: enable ofa and dirac plugins
360
361* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
362- Rebuild for new x264
363
364* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
365- New upstream release 0.10.7
366- Drop many upstreamed patches
367
368* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
369- Rebuild for new x264
370
371* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
372- Enable dc1394 plugin
373
374* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
375- New upstream release 0.10.6-1
376- Drop many upstreamed patches
377- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
378
379* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
380- Fix compilation with gcc 4.3
381
382* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
383- Add flv demuxer from CVS (livna bug 1846)
384
385* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
386- Add patch fixing compilation with mjpegtools 1.9.0rc3
387
388* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
389- Add patch from upstream vcs which makes mms honor your connection speed
390  settings
391- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
392
393* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
394- Rebuild for new faad2
395
396* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
397- Rebuild for new libdca
398
399* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
400- Rebuild for new (old) faad2 (livna bug 1679)
401
402* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
403- Update mythtvsrc code to CVS version (livna bug 1660)
404
405* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
406- No libgstreal.so on ppc / ppc64
407
408* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
409- Fix detection of libdts with current livna libtds, this might need to be
410  changed back again for rpmfusion, depending on how libdts will look there
411
412* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
413- Add mythtvsrc plugin (livna 1646)
414- Put some less often used plugins, which bring in also usually not installed
415  deps in a -extras package
416
417* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
418- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
419- Set release to 4 to be higher as both livna and freshrpms latest release
420- Set package name and origin to rpmfusion
421- Make mpeg2enc plugin compile with current mjpegtools
422- Make the real plugins search for the RealPlayer .so files in various
423  known possible locations instead of using only one hardcoded path to them
424- Make the wildmidi plugin work with the default Fedora timidity patch set
425- Add a couple of missing modtracker mimetypes to the modplug plugin
426- Use the system version of libmodplug
427- Fix building of the neonsrc plugin with the latest (rawhide) neon
428- Disable the ladspa plugin as this has been added to Fedora's rawhide
429  gstreamer-plugins-good
430- Don't put an rpath in the .so's on x86_64
431- Re-enable gtk-doc now that we have a -devel package again
432- Enable libtimidity plugin
433- Fix detection of (and linking with) libdca for the dtsdec plugin
434
435* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
436- Update to 0.10.5.
437- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
438- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
439- Enable new nas, x264, wildmidi and libsndfile plugins.
440- Re-add devel package now that we have a main shared lib and header files.
441- Add check build requirement.
442
443* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
444- Update to 0.10.4 for F7.
445- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
446  somewhat more, maybe then it'll be worth re-enabling.
447- Re-enable wavpack, it works again now.
448- Enable libcdaudio support.
449- Enable jack support.
450- Enable ladspa support.
451- Enable mpeg2enc (mjpegtools) support.
452- Remove no longer present libgstvideo4linux2.so and add all new plugins.
453- Remove all gtk-doc references (all gone...?) and devel package too.
454
455* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
456- Update faad2 patch to also update the plugin sources, not just configure.
457
458* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
459- Try to rebuild against new wavpack 4.40 from Extras : Fails.
460- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
461- Try to include patch to update wavpack plugin source from 0.10.3.2
462  pre-release : Fails to find wavpack/md5.h.
463- Give up and disable wavpack support for now, sorry! Patches welcome.
464- Include patch to fix faad2 2.5 detection.
465- Add soundtouch support.
466
467* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
468- Update to 0.10.3.
469- Add new translations.
470- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
471- Add new libmusicbrainz support.
472
473* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
474- Add libmms support, thanks to Daniel S. Rogers.
475
476* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
477- Update to 0.10.1.
478- Add libgstcdxaparse.so and libgstfreeze.so.
479- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
480
481* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
482- Update to 0.10.0.1, add new plugins.
483- Spec file cleanup and rebuild for FC5.
484
485* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
486- 0.10.0-0.gst.1
487- new release
488
489* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
490- 0.9.7-0.gst.1
491- new release with 0.10 major/minor
492
493* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
494- new release
495- remove tta patch
496- don't check for languages, no translations yet
497- added gtk-doc
498
499* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
500- 0.9.4-0.gst.1
501- new release
502- added speed plugin
503
504* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
505- 0.9.3-0.gst.1
506- new release
507
Note: See TracBrowser for help on using the repository browser.