source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 9440

Revision 9440, 15.9 KB checked in by inagaki, 9 years ago (diff)

2015-03-19 Ryoichi INAGAKI <ryo1@…>

  • self-build-faac: added patch
  • self-build-gstreamer1-plugins-bad: changed Group


Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.4.5
5%define gstpb_minver 1.4.5
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Summary(ja): GStreamer ストリーミングメディアフレームワーク用 bad プラグイン集
9Name: gstreamer1-plugins-bad
10Version: 1.4.5
11Release: 2%{?_dist_release}
12# The freeze and nfs plugins are LGPLv2 (only)
13License: LGPLv2+
14Group: System Environment/Libraries
15URL: http://gstreamer.freedesktop.org/
16Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires: %{gstreamer} >= %{gst_minver}
19BuildRequires: %{gstreamer}-devel >= %{gst_minver}
20BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
21BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
22
23BuildRequires: check
24BuildRequires: gettext
25BuildRequires: PyXML
26BuildRequires: libXt-devel
27
28BuildRequires: bzip2-devel
29BuildRequires: celt-devel
30BuildRequires: exempi-devel
31BuildRequires: jasper-devel
32#BuildRequires: ladspa-devel
33BuildRequires: libass-devel
34BuildRequires: libdc1394-devel
35BuildRequires: libdvdnav-devel
36BuildRequires: libexif-devel
37#BuildRequires: libiptcdata-devel
38BuildRequires: kate-devel
39BuildRequires: libmodplug-devel
40BuildRequires: libmpcdec-devel
41#BuildRequires: libofa-devel
42BuildRequires: librsvg2-devel
43BuildRequires: libsndfile-devel
44#BuildRequires: libtimidity-devel
45BuildRequires: libvpx-devel
46BuildRequires: mesa-libGLU-devel
47BuildRequires: openssl-devel
48BuildRequires: orc-devel
49#BuildRequires: schroedinger-devel
50BuildRequires: SDL-devel
51#BuildRequires: slv2-devel
52BuildRequires: soundtouch-devel
53BuildRequires: wavpack-devel
54#BuildRequires: wildmidi-devel
55#BuildRequires: zbar-devel
56BuildRequires: libmms-devel
57BuildRequires: twolame-devel
58#BuildRequires: libmimic-devel
59
60# self build
61#BuildRequires: libdca-devel
62#BuildRequires: faad2-devel
63#BuildRequires: xvidcore-devel
64#BuildRequires: mjpegtools-devel
65
66
67%description
68GStreamer is a streaming media framework, based on graphs of elements which
69operate on media data.
70
71This package contains plug-ins that have licensing issues, aren't tested
72well enough, or the code is not of good enough quality.
73
74
75# %package extras
76# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
77# Group: Applications/Multimedia
78# Requires: %{name} = %{version}-%{release}
79
80# %description extras
81# GStreamer is a streaming media framework, based on graphs of elements which
82# operate on media data.
83
84# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
85# tested well enough, or the code is not of good enough quality.
86
87# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
88# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
89# very much and require additional libraries to be installed.
90
91
92%prep
93%setup -q -n gst-plugins-bad-%{version}
94
95%build
96%configure \
97        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
98
99# Don't use rpath!
100%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
101%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
102%{__make} %{?_smp_mflags}
103
104
105%install
106%{__rm} -rf %{buildroot}
107%{__make} install DESTDIR="%{buildroot}"
108
109# Clean out files that should not be part of the rpm.
110%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
111%{__rm} -f %{buildroot}%{_libdir}/*.la
112
113# conflict with gstreamer1-plugins-bad
114%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
116%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
117%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
118%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
119
120REMOVE_MODULE_LIST=" \
121        libgstadpcmdec.so \
122        libgstadpcmenc.so \
123        libgstasfmux.so \
124        libgstaudiomixer.so \
125        libgstaudiovisualizers.so \
126        libgstautoconvert.so \
127        libgstbayer.so \
128        libgstbz2.so \
129        libgstcamerabin2.so \
130        libgstcoloreffects.so \
131        libgstcompositor.so \
132        libgstdataurisrc.so \
133        libgstdebugutilsbad.so \
134        libgstdtmf.so \
135        libgstdvb.so \
136        libgstfestival.so \
137        libgstfieldanalysis.so \
138        libgstfragmented.so \
139        libgstfrei0r.so \
140        libgstgaudieffects.so \
141        libgstgdp.so \
142        libgstgeometrictransform.so \
143        libgstgsm.so \
144        libgstid3tag.so \
145        libgstinter.so \
146        libgstinterlace.so \
147        libgstivfparse.so \
148        libgstjp2kdecimator.so \
149        libgstjpegformat.so \
150        libgstliveadder.so \
151        libgstmpegpsdemux.so \
152        libgstmpegtsdemux.so \
153        libgstmpegpsmux.so \
154        libgstmpegtsmux.so \
155        libgstmidi.so \
156        libgstneonhttpsrc.so \
157        libgstopengl.so \
158        libgstpcapparse.so \
159        libgstpnm.so \
160        libgstrawparse.so \
161        libgstremovesilence.so \
162        libgstresindvd.so \
163        libgstrfbsrc.so \
164        libgstrtpmux.so \
165        libgstrtpvp8.so \
166        libgstscaletempoplugin.so \
167        libgstsdpelem.so \
168        libgstsegmentclip.so \
169        libgstshm.so \
170        libgstsmooth.so \
171        libgstsndfile.so \
172        libgstsoundtouch.so \
173        libgstspeed.so \
174        libgststereo.so \
175        libgstsubenc.so \
176        libgsty4mdec.so \
177        libgstaccurip.so \
178        libgstaiff.so \
179        libgstaudiofxbad \
180        libgstfreeverb.so \
181        libgstivtc.so \
182        libgstmfc.so \
183        libgstmxf.so \
184        libgstrsvg.so \
185        libgstvideofiltersbad.so \
186        libgstvideoparsersbad.so \
187        libgstvideosignal.so \
188        libgstvmnc.so \
189        libgstaudiofxbad.so \
190        libgstyadif.so"
191for file in $REMOVE_MODULE_LIST; do
192        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
193done
194
195%clean
196%{__rm} -rf %{buildroot}
197
198
199%post -p /sbin/ldconfig
200
201%postun -p /sbin/ldconfig
202
203
204%files
205%defattr(-,root,root,-)
206%doc AUTHORS COPYING README REQUIREMENTS
207%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
208%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
209%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
210%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
211%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
212%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
213%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
214%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
215%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
216%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
217%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
218%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
219%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
220%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
221%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
222%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
223%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
224%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
225
226
227%changelog
228* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-2
229- changed Group to System Environment/Libraries
230
231* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
232- new upstream release
233
234* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
235- new upstream release
236
237* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
238- new upstream release
239
240* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
241- new upstream release
242
243* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
244- new upstream release
245
246* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
247- new upstream release
248
249* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
250- new upstream release
251
252* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
253- new upstream release
254
255* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
256- new upstream release
257
258* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
259- new upstream release
260
261* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
262- new upstream release
263
264* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
265- new upstream release
266
267* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
268- new upstream release
269
270* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
271- new upstream release
272
273* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
274- new upstream release
275
276* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
277- new upstream release
278- rename package
279
280* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
281- new upstream release
282- added BuildRequires: libvpx-devel
283
284* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
285- s/self-build-libdvdnav/libdvdnav/
286
287* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
288- new upstream release
289- added BuildRequires:
290  - libmms-devel
291  - librtmp-devel
292
293* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
294- new upstream release
295
296* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
297- new upstream release
298
299* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
300- new upstream release
301- added BuildRequires: libvdpau-devel
302
303* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
304- new upstream release
305
306* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
307- new upstream release
308- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
309  gst-plugins-bad-0.10.5-mms-seek.patch
310
311* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
312- new upstream release
313- dropped devel and devel-docs subpackages
314
315* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
316- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
317- changed to BuildRequires:  self-build-faad2 from faad2-devel
318
319* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
320- initial build based on RPM Fusion package
321
322* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
323- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
324
325* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
326- Rebuild for new x264 (using patch from Rathann)
327
328* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
329- New upstream release 0.10.9
330- Rebuild for new directfb
331
332* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
333- Rebuild for new x264 and to generate new magic gstreamer provides
334
335* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
336- Enable DVD navigation plugin
337
338* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
339- Release bump to keep rpmfusion version higher then livna
340
341* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
342- New upstream release 0.10.8
343- Merge changes from latest freshrpms package: enable ofa and dirac plugins
344
345* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
346- Rebuild for new x264
347
348* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
349- New upstream release 0.10.7
350- Drop many upstreamed patches
351
352* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
353- Rebuild for new x264
354
355* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
356- Enable dc1394 plugin
357
358* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
359- New upstream release 0.10.6-1
360- Drop many upstreamed patches
361- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
362
363* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
364- Fix compilation with gcc 4.3
365
366* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
367- Add flv demuxer from CVS (livna bug 1846)
368
369* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
370- Add patch fixing compilation with mjpegtools 1.9.0rc3
371
372* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
373- Add patch from upstream vcs which makes mms honor your connection speed
374  settings
375- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
376
377* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
378- Rebuild for new faad2
379
380* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
381- Rebuild for new libdca
382
383* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
384- Rebuild for new (old) faad2 (livna bug 1679)
385
386* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
387- Update mythtvsrc code to CVS version (livna bug 1660)
388
389* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
390- No libgstreal.so on ppc / ppc64
391
392* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
393- Fix detection of libdts with current livna libtds, this might need to be
394  changed back again for rpmfusion, depending on how libdts will look there
395
396* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
397- Add mythtvsrc plugin (livna 1646)
398- Put some less often used plugins, which bring in also usually not installed
399  deps in a -extras package
400
401* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
402- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
403- Set release to 4 to be higher as both livna and freshrpms latest release
404- Set package name and origin to rpmfusion
405- Make mpeg2enc plugin compile with current mjpegtools
406- Make the real plugins search for the RealPlayer .so files in various
407  known possible locations instead of using only one hardcoded path to them
408- Make the wildmidi plugin work with the default Fedora timidity patch set
409- Add a couple of missing modtracker mimetypes to the modplug plugin
410- Use the system version of libmodplug
411- Fix building of the neonsrc plugin with the latest (rawhide) neon
412- Disable the ladspa plugin as this has been added to Fedora's rawhide
413  gstreamer-plugins-good
414- Don't put an rpath in the .so's on x86_64
415- Re-enable gtk-doc now that we have a -devel package again
416- Enable libtimidity plugin
417- Fix detection of (and linking with) libdca for the dtsdec plugin
418
419* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
420- Update to 0.10.5.
421- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
422- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
423- Enable new nas, x264, wildmidi and libsndfile plugins.
424- Re-add devel package now that we have a main shared lib and header files.
425- Add check build requirement.
426
427* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
428- Update to 0.10.4 for F7.
429- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
430  somewhat more, maybe then it'll be worth re-enabling.
431- Re-enable wavpack, it works again now.
432- Enable libcdaudio support.
433- Enable jack support.
434- Enable ladspa support.
435- Enable mpeg2enc (mjpegtools) support.
436- Remove no longer present libgstvideo4linux2.so and add all new plugins.
437- Remove all gtk-doc references (all gone...?) and devel package too.
438
439* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
440- Update faad2 patch to also update the plugin sources, not just configure.
441
442* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
443- Try to rebuild against new wavpack 4.40 from Extras : Fails.
444- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
445- Try to include patch to update wavpack plugin source from 0.10.3.2
446  pre-release : Fails to find wavpack/md5.h.
447- Give up and disable wavpack support for now, sorry! Patches welcome.
448- Include patch to fix faad2 2.5 detection.
449- Add soundtouch support.
450
451* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
452- Update to 0.10.3.
453- Add new translations.
454- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
455- Add new libmusicbrainz support.
456
457* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
458- Add libmms support, thanks to Daniel S. Rogers.
459
460* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
461- Update to 0.10.1.
462- Add libgstcdxaparse.so and libgstfreeze.so.
463- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
464
465* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
466- Update to 0.10.0.1, add new plugins.
467- Spec file cleanup and rebuild for FC5.
468
469* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
470- 0.10.0-0.gst.1
471- new release
472
473* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
474- 0.9.7-0.gst.1
475- new release with 0.10 major/minor
476
477* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
478- new release
479- remove tta patch
480- don't check for languages, no translations yet
481- added gtk-doc
482
483* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
484- 0.9.4-0.gst.1
485- new release
486- added speed plugin
487
488* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
489- 0.9.3-0.gst.1
490- new release
491
Note: See TracBrowser for help on using the repository browser.