source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 9097

Revision 9097, 15.6 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.4.4
5%define gstpb_minver 1.4.4
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer1-plugins-bad
9Version: 1.4.4
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
21
22BuildRequires: check
23BuildRequires: gettext
24BuildRequires: PyXML
25BuildRequires: libXt-devel
26
27BuildRequires: bzip2-devel
28BuildRequires: celt-devel
29BuildRequires: exempi-devel
30BuildRequires: jasper-devel
31#BuildRequires: ladspa-devel
32BuildRequires: libass-devel
33BuildRequires: libdc1394-devel
34BuildRequires: libdvdnav-devel
35BuildRequires: libexif-devel
36#BuildRequires: libiptcdata-devel
37BuildRequires: kate-devel
38BuildRequires: libmodplug-devel
39BuildRequires: libmpcdec-devel
40#BuildRequires: libofa-devel
41BuildRequires: librsvg2-devel
42BuildRequires: libsndfile-devel
43#BuildRequires: libtimidity-devel
44BuildRequires: libvpx-devel
45BuildRequires: mesa-libGLU-devel
46BuildRequires: openssl-devel
47BuildRequires: orc-devel
48#BuildRequires: schroedinger-devel
49BuildRequires: SDL-devel
50#BuildRequires: slv2-devel
51BuildRequires: soundtouch-devel
52BuildRequires: wavpack-devel
53#BuildRequires: wildmidi-devel
54#BuildRequires: zbar-devel
55BuildRequires: libmms-devel
56BuildRequires: twolame-devel
57#BuildRequires: libmimic-devel
58
59# self build
60#BuildRequires: libdca-devel
61#BuildRequires: faad2-devel
62#BuildRequires: xvidcore-devel
63#BuildRequires: mjpegtools-devel
64
65
66%description
67GStreamer is a streaming media framework, based on graphs of elements which
68operate on media data.
69
70This package contains plug-ins that have licensing issues, aren't tested
71well enough, or the code is not of good enough quality.
72
73
74# %package extras
75# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
76# Group: Applications/Multimedia
77# Requires: %{name} = %{version}-%{release}
78
79# %description extras
80# GStreamer is a streaming media framework, based on graphs of elements which
81# operate on media data.
82
83# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
84# tested well enough, or the code is not of good enough quality.
85
86# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
87# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
88# very much and require additional libraries to be installed.
89
90
91%prep
92%setup -q -n gst-plugins-bad-%{version}
93
94%build
95%configure \
96        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
97
98# Don't use rpath!
99%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
100%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
101%{__make} %{?_smp_mflags}
102
103
104%install
105%{__rm} -rf %{buildroot}
106%{__make} install DESTDIR="%{buildroot}"
107
108# Clean out files that should not be part of the rpm.
109%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
110%{__rm} -f %{buildroot}%{_libdir}/*.la
111
112# conflict with gstreamer1-plugins-bad
113%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
114%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
116%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
117%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
118
119REMOVE_MODULE_LIST=" \
120        libgstadpcmdec.so \
121        libgstadpcmenc.so \
122        libgstasfmux.so \
123        libgstaudiomixer.so \
124        libgstaudiovisualizers.so \
125        libgstautoconvert.so \
126        libgstbayer.so \
127        libgstbz2.so \
128        libgstcamerabin2.so \
129        libgstcoloreffects.so \
130        libgstcompositor.so \
131        libgstdataurisrc.so \
132        libgstdebugutilsbad.so \
133        libgstdtmf.so \
134        libgstdvb.so \
135        libgstfestival.so \
136        libgstfieldanalysis.so \
137        libgstfragmented.so \
138        libgstfrei0r.so \
139        libgstgaudieffects.so \
140        libgstgdp.so \
141        libgstgeometrictransform.so \
142        libgstgsm.so \
143        libgstid3tag.so \
144        libgstinter.so \
145        libgstinterlace.so \
146        libgstivfparse.so \
147        libgstjp2kdecimator.so \
148        libgstjpegformat.so \
149        libgstliveadder.so \
150        libgstmpegpsdemux.so \
151        libgstmpegtsdemux.so \
152        libgstmpegpsmux.so \
153        libgstmpegtsmux.so \
154        libgstmidi.so \
155        libgstneonhttpsrc.so \
156        libgstopengl.so \
157        libgstpcapparse.so \
158        libgstpnm.so \
159        libgstrawparse.so \
160        libgstremovesilence.so \
161        libgstresindvd.so \
162        libgstrfbsrc.so \
163        libgstrtpmux.so \
164        libgstrtpvp8.so \
165        libgstscaletempoplugin.so \
166        libgstsdpelem.so \
167        libgstsegmentclip.so \
168        libgstshm.so \
169        libgstsmooth.so \
170        libgstsndfile.so \
171        libgstsoundtouch.so \
172        libgstspeed.so \
173        libgststereo.so \
174        libgstsubenc.so \
175        libgsty4mdec.so \
176        libgstaccurip.so \
177        libgstaiff.so \
178        libgstaudiofxbad \
179        libgstfreeverb.so \
180        libgstivtc.so \
181        libgstmfc.so \
182        libgstmxf.so \
183        libgstrsvg.so \
184        libgstvideofiltersbad.so \
185        libgstvideoparsersbad.so \
186        libgstvideosignal.so \
187        libgstvmnc.so \
188        libgstaudiofxbad.so \
189        libgstyadif.so"
190for file in $REMOVE_MODULE_LIST; do
191        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
192done
193
194%clean
195%{__rm} -rf %{buildroot}
196
197
198%post -p /sbin/ldconfig
199
200%postun -p /sbin/ldconfig
201
202
203%files
204%defattr(-,root,root,-)
205%doc AUTHORS COPYING README REQUIREMENTS
206%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
207%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
208%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
209%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
210%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
211%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
212%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
213%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
214%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
215%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
216%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
217%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
218%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
219%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
220%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
221%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
222%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
223%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
224
225
226%changelog
227* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
228- new upstream release
229
230* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
231- new upstream release
232
233* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
234- new upstream release
235
236* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
237- new upstream release
238
239* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
240- new upstream release
241
242* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
243- new upstream release
244
245* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
246- new upstream release
247
248* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
249- new upstream release
250
251* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
252- new upstream release
253
254* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
255- new upstream release
256
257* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
258- new upstream release
259
260* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
261- new upstream release
262
263* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
264- new upstream release
265
266* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
267- new upstream release
268
269* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
270- new upstream release
271- rename package
272
273* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
274- new upstream release
275- added BuildRequires: libvpx-devel
276
277* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
278- s/self-build-libdvdnav/libdvdnav/
279
280* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
281- new upstream release
282- added BuildRequires:
283  - libmms-devel
284  - librtmp-devel
285
286* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
287- new upstream release
288
289* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
290- new upstream release
291
292* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
293- new upstream release
294- added BuildRequires: libvdpau-devel
295
296* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
297- new upstream release
298
299* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
300- new upstream release
301- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
302  gst-plugins-bad-0.10.5-mms-seek.patch
303
304* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
305- new upstream release
306- dropped devel and devel-docs subpackages
307
308* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
309- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
310- changed to BuildRequires:  self-build-faad2 from faad2-devel
311
312* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
313- initial build based on RPM Fusion package
314
315* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
316- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
317
318* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
319- Rebuild for new x264 (using patch from Rathann)
320
321* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
322- New upstream release 0.10.9
323- Rebuild for new directfb
324
325* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
326- Rebuild for new x264 and to generate new magic gstreamer provides
327
328* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
329- Enable DVD navigation plugin
330
331* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
332- Release bump to keep rpmfusion version higher then livna
333
334* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
335- New upstream release 0.10.8
336- Merge changes from latest freshrpms package: enable ofa and dirac plugins
337
338* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
339- Rebuild for new x264
340
341* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
342- New upstream release 0.10.7
343- Drop many upstreamed patches
344
345* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
346- Rebuild for new x264
347
348* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
349- Enable dc1394 plugin
350
351* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
352- New upstream release 0.10.6-1
353- Drop many upstreamed patches
354- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
355
356* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
357- Fix compilation with gcc 4.3
358
359* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
360- Add flv demuxer from CVS (livna bug 1846)
361
362* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
363- Add patch fixing compilation with mjpegtools 1.9.0rc3
364
365* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
366- Add patch from upstream vcs which makes mms honor your connection speed
367  settings
368- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
369
370* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
371- Rebuild for new faad2
372
373* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
374- Rebuild for new libdca
375
376* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
377- Rebuild for new (old) faad2 (livna bug 1679)
378
379* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
380- Update mythtvsrc code to CVS version (livna bug 1660)
381
382* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
383- No libgstreal.so on ppc / ppc64
384
385* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
386- Fix detection of libdts with current livna libtds, this might need to be
387  changed back again for rpmfusion, depending on how libdts will look there
388
389* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
390- Add mythtvsrc plugin (livna 1646)
391- Put some less often used plugins, which bring in also usually not installed
392  deps in a -extras package
393
394* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
395- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
396- Set release to 4 to be higher as both livna and freshrpms latest release
397- Set package name and origin to rpmfusion
398- Make mpeg2enc plugin compile with current mjpegtools
399- Make the real plugins search for the RealPlayer .so files in various
400  known possible locations instead of using only one hardcoded path to them
401- Make the wildmidi plugin work with the default Fedora timidity patch set
402- Add a couple of missing modtracker mimetypes to the modplug plugin
403- Use the system version of libmodplug
404- Fix building of the neonsrc plugin with the latest (rawhide) neon
405- Disable the ladspa plugin as this has been added to Fedora's rawhide
406  gstreamer-plugins-good
407- Don't put an rpath in the .so's on x86_64
408- Re-enable gtk-doc now that we have a -devel package again
409- Enable libtimidity plugin
410- Fix detection of (and linking with) libdca for the dtsdec plugin
411
412* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
413- Update to 0.10.5.
414- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
415- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
416- Enable new nas, x264, wildmidi and libsndfile plugins.
417- Re-add devel package now that we have a main shared lib and header files.
418- Add check build requirement.
419
420* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
421- Update to 0.10.4 for F7.
422- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
423  somewhat more, maybe then it'll be worth re-enabling.
424- Re-enable wavpack, it works again now.
425- Enable libcdaudio support.
426- Enable jack support.
427- Enable ladspa support.
428- Enable mpeg2enc (mjpegtools) support.
429- Remove no longer present libgstvideo4linux2.so and add all new plugins.
430- Remove all gtk-doc references (all gone...?) and devel package too.
431
432* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
433- Update faad2 patch to also update the plugin sources, not just configure.
434
435* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
436- Try to rebuild against new wavpack 4.40 from Extras : Fails.
437- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
438- Try to include patch to update wavpack plugin source from 0.10.3.2
439  pre-release : Fails to find wavpack/md5.h.
440- Give up and disable wavpack support for now, sorry! Patches welcome.
441- Include patch to fix faad2 2.5 detection.
442- Add soundtouch support.
443
444* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
445- Update to 0.10.3.
446- Add new translations.
447- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
448- Add new libmusicbrainz support.
449
450* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
451- Add libmms support, thanks to Daniel S. Rogers.
452
453* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
454- Update to 0.10.1.
455- Add libgstcdxaparse.so and libgstfreeze.so.
456- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
457
458* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
459- Update to 0.10.0.1, add new plugins.
460- Spec file cleanup and rebuild for FC5.
461
462* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
463- 0.10.0-0.gst.1
464- new release
465
466* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
467- 0.9.7-0.gst.1
468- new release with 0.10 major/minor
469
470* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
471- new release
472- remove tta patch
473- don't check for languages, no translations yet
474- added gtk-doc
475
476* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
477- 0.9.4-0.gst.1
478- new release
479- added speed plugin
480
481* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
482- 0.9.3-0.gst.1
483- new release
484
Note: See TracBrowser for help on using the repository browser.