source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 7303

Revision 7303, 16.1 KB checked in by Takemikaduchi, 11 years ago (diff)

mesa-libGLU: fix BR,
others: new upstream release

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.0.5
5%define gstpb_minver 1.0.5
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer1-plugins-bad
9Version: 1.0.5
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: bzip2-devel
27BuildRequires: celt-devel
28BuildRequires: exempi-devel
29BuildRequires: jasper-devel
30#BuildRequires: ladspa-devel
31BuildRequires: libass-devel
32BuildRequires: libdc1394-devel
33BuildRequires: libdvdnav-devel
34BuildRequires: libexif-devel
35#BuildRequires: libiptcdata-devel
36BuildRequires: kate-devel
37BuildRequires: libmodplug-devel
38BuildRequires: libmpcdec-devel
39#BuildRequires: libofa-devel
40BuildRequires: librsvg2-devel
41BuildRequires: libsndfile-devel
42#BuildRequires: libtimidity-devel
43BuildRequires: libvpx-devel
44BuildRequires: mesa-libGLU-devel
45BuildRequires: openssl-devel
46BuildRequires: orc-devel
47#BuildRequires: schroedinger-devel
48BuildRequires: SDL-devel
49#BuildRequires: slv2-devel
50BuildRequires: soundtouch-devel
51BuildRequires: wavpack-devel
52#BuildRequires: wildmidi-devel
53#BuildRequires: zbar-devel
54BuildRequires: libmms-devel
55BuildRequires: twolame-devel
56#BuildRequires: libmimic-devel
57
58# self build
59#BuildRequires: libdca-devel
60#BuildRequires: faad2-devel
61#BuildRequires: xvidcore-devel
62#BuildRequires: mjpegtools-devel
63
64
65%description
66GStreamer is a streaming media framework, based on graphs of elements which
67operate on media data.
68
69This package contains plug-ins that have licensing issues, aren't tested
70well enough, or the code is not of good enough quality.
71
72
73# %package extras
74# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
75# Group: Applications/Multimedia
76# Requires: %{name} = %{version}-%{release}
77
78# %description extras
79# GStreamer is a streaming media framework, based on graphs of elements which
80# operate on media data.
81
82# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
83# tested well enough, or the code is not of good enough quality.
84
85# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
86# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
87# very much and require additional libraries to be installed.
88
89
90%prep
91%setup -q -n gst-plugins-bad-%{version}
92
93%build
94%configure \
95        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
96
97# Don't use rpath!
98%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
99%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
100%{__make} %{?_smp_mflags}
101
102
103%install
104%{__rm} -rf %{buildroot}
105%{__make} install DESTDIR="%{buildroot}"
106
107# Clean out files that should not be part of the rpm.
108%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
109%{__rm} -f %{buildroot}%{_libdir}/*.la
110
111# conflict with gstreamer1-plugins-bad
112%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
113%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
115%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
116%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstadpcmdec.so
117%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstadpcmenc.so
118%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstasfmux.so
119%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstaudiovisualizers.so
120%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstautoconvert.so
121%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
122%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
123%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstcamerabin2.so
124%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstcoloreffects.so
125%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdataurisrc.so
126%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdebugutilsbad.so
127%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdtmf.so
128%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
129%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
130%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfragmented.so
131%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfrei0r.so
132%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgaudieffects.so
133%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgdp.so
134%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgeometrictransform.so
135%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
136%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstid3tag.so
137%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstinter.so
138%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstinterlace.so
139%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstjpegformat.so
140%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstliveadder.so
141%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegpsdemux.so
142%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegtsdemux.so
143%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
144%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
145%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstpnm.so
146%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
147%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstremovesilence.so
148%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstresindvd.so
149%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrtpmux.so
150%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrtpvp8.so
151%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
152%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
153%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsegmentclip.so
154%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstshm.so
155%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsmooth.so
156%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
157%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
158%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstvideoparsersbad.so
159%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgsty4mdec.so
160
161%clean
162%{__rm} -rf %{buildroot}
163
164
165%post -p /sbin/ldconfig
166
167%postun -p /sbin/ldconfig
168
169
170%files
171%defattr(-,root,root,-)
172%doc AUTHORS COPYING README REQUIREMENTS
173%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
174%{_libdir}/gstreamer-%{majorminor}/libgstcelt.so
175%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
176%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
177%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
178%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
179%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
180%{_libdir}/gstreamer-%{majorminor}/libgstfieldanalysis.so
181%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
182%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
183%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
184%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
185%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
186%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
187%{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
188
189
190%changelog
191* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
192- new upstream release
193
194* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
195- new upstream release
196
197* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
198- new upstream release
199- rename package
200
201* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
202- new upstream release
203- added BuildRequires: libvpx-devel
204
205* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
206- s/self-build-libdvdnav/libdvdnav/
207
208* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
209- new upstream release
210- added BuildRequires:
211  - libmms-devel
212  - librtmp-devel
213
214* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
215- new upstream release
216
217* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
218- new upstream release
219
220* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
221- new upstream release
222- added BuildRequires: libvdpau-devel
223
224* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
225- new upstream release
226
227* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
228- new upstream release
229- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
230  gst-plugins-bad-0.10.5-mms-seek.patch
231
232* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
233- new upstream release
234- dropped devel and devel-docs subpackages
235
236* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
237- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
238- changed to BuildRequires:  self-build-faad2 from faad2-devel
239
240* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
241- initial build based on RPM Fusion package
242
243* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
244- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
245
246* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
247- Rebuild for new x264 (using patch from Rathann)
248
249* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
250- New upstream release 0.10.9
251- Rebuild for new directfb
252
253* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
254- Rebuild for new x264 and to generate new magic gstreamer provides
255
256* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
257- Enable DVD navigation plugin
258
259* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
260- Release bump to keep rpmfusion version higher then livna
261
262* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
263- New upstream release 0.10.8
264- Merge changes from latest freshrpms package: enable ofa and dirac plugins
265
266* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
267- Rebuild for new x264
268
269* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
270- New upstream release 0.10.7
271- Drop many upstreamed patches
272
273* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
274- Rebuild for new x264
275
276* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
277- Enable dc1394 plugin
278
279* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
280- New upstream release 0.10.6-1
281- Drop many upstreamed patches
282- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
283
284* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
285- Fix compilation with gcc 4.3
286
287* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
288- Add flv demuxer from CVS (livna bug 1846)
289
290* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
291- Add patch fixing compilation with mjpegtools 1.9.0rc3
292
293* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
294- Add patch from upstream vcs which makes mms honor your connection speed
295  settings
296- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
297
298* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
299- Rebuild for new faad2
300
301* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
302- Rebuild for new libdca
303
304* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
305- Rebuild for new (old) faad2 (livna bug 1679)
306
307* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
308- Update mythtvsrc code to CVS version (livna bug 1660)
309
310* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
311- No libgstreal.so on ppc / ppc64
312
313* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
314- Fix detection of libdts with current livna libtds, this might need to be
315  changed back again for rpmfusion, depending on how libdts will look there
316
317* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
318- Add mythtvsrc plugin (livna 1646)
319- Put some less often used plugins, which bring in also usually not installed
320  deps in a -extras package
321
322* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
323- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
324- Set release to 4 to be higher as both livna and freshrpms latest release
325- Set package name and origin to rpmfusion
326- Make mpeg2enc plugin compile with current mjpegtools
327- Make the real plugins search for the RealPlayer .so files in various
328  known possible locations instead of using only one hardcoded path to them
329- Make the wildmidi plugin work with the default Fedora timidity patch set
330- Add a couple of missing modtracker mimetypes to the modplug plugin
331- Use the system version of libmodplug
332- Fix building of the neonsrc plugin with the latest (rawhide) neon
333- Disable the ladspa plugin as this has been added to Fedora's rawhide
334  gstreamer-plugins-good
335- Don't put an rpath in the .so's on x86_64
336- Re-enable gtk-doc now that we have a -devel package again
337- Enable libtimidity plugin
338- Fix detection of (and linking with) libdca for the dtsdec plugin
339
340* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
341- Update to 0.10.5.
342- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
343- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
344- Enable new nas, x264, wildmidi and libsndfile plugins.
345- Re-add devel package now that we have a main shared lib and header files.
346- Add check build requirement.
347
348* Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
349- Update to 0.10.4 for F7.
350- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
351  somewhat more, maybe then it'll be worth re-enabling.
352- Re-enable wavpack, it works again now.
353- Enable libcdaudio support.
354- Enable jack support.
355- Enable ladspa support.
356- Enable mpeg2enc (mjpegtools) support.
357- Remove no longer present libgstvideo4linux2.so and add all new plugins.
358- Remove all gtk-doc references (all gone...?) and devel package too.
359
360* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
361- Update faad2 patch to also update the plugin sources, not just configure.
362
363* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
364- Try to rebuild against new wavpack 4.40 from Extras : Fails.
365- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
366- Try to include patch to update wavpack plugin source from 0.10.3.2
367  pre-release : Fails to find wavpack/md5.h.
368- Give up and disable wavpack support for now, sorry! Patches welcome.
369- Include patch to fix faad2 2.5 detection.
370- Add soundtouch support.
371
372* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
373- Update to 0.10.3.
374- Add new translations.
375- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
376- Add new libmusicbrainz support.
377
378* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
379- Add libmms support, thanks to Daniel S. Rogers.
380
381* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
382- Update to 0.10.1.
383- Add libgstcdxaparse.so and libgstfreeze.so.
384- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
385
386* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
387- Update to 0.10.0.1, add new plugins.
388- Spec file cleanup and rebuild for FC5.
389
390* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
391- 0.10.0-0.gst.1
392- new release
393
394* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
395- 0.9.7-0.gst.1
396- new release with 0.10 major/minor
397
398* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
399- new release
400- remove tta patch
401- don't check for languages, no translations yet
402- added gtk-doc
403
404* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
405- 0.9.4-0.gst.1
406- new release
407- added speed plugin
408
409* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
410- 0.9.3-0.gst.1
411- new release
412
Note: See TracBrowser for help on using the repository browser.