source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 7022

Revision 7022, 16.0 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-desktop3: update ja.po patch
others: new package

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.0.2
5%define gstpb_minver 1.0.2
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Name: gstreamer1-plugins-bad
9Version: 1.0.2
10Release: 1%{?_dist_release}
11# The freeze and nfs plugins are LGPLv2 (only)
12License: LGPLv2+
13Group: Applications/Multimedia
14URL: http://gstreamer.freedesktop.org/
15Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires: %{gstreamer} >= %{gst_minver}
18BuildRequires: %{gstreamer}-devel >= %{gst_minver}
19BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
20
21BuildRequires: check
22BuildRequires: gettext
23BuildRequires: PyXML
24BuildRequires: libXt-devel
25
26BuildRequires: bzip2-devel
27BuildRequires: celt-devel
28BuildRequires: exempi-devel
29BuildRequires: jasper-devel
30#BuildRequires: ladspa-devel
31BuildRequires: libass-devel
32BuildRequires: libdc1394-devel
33BuildRequires: libdvdnav-devel
34BuildRequires: libexif-devel
35#BuildRequires: libiptcdata-devel
36BuildRequires: kate-devel
37BuildRequires: libmodplug-devel
38BuildRequires: libmpcdec-devel
39#BuildRequires: libofa-devel
40BuildRequires: librsvg2-devel
41BuildRequires: libsndfile-devel
42#BuildRequires: libtimidity-devel
43BuildRequires: libvpx-devel
44BuildRequires: mesa-libGLU-devel
45BuildRequires: openssl-devel
46BuildRequires: orc-devel
47#BuildRequires: schroedinger-devel
48BuildRequires: SDL-devel
49#BuildRequires: slv2-devel
50BuildRequires: soundtouch-devel
51BuildRequires: wavpack-devel
52#BuildRequires: wildmidi-devel
53#BuildRequires: zbar-devel
54BuildRequires: libmms-devel
55BuildRequires: twolame-devel
56#BuildRequires: libmimic-devel
57
58# self build
59#BuildRequires: libdca-devel
60#BuildRequires: faad2-devel
61#BuildRequires: xvidcore-devel
62#BuildRequires: mjpegtools-devel
63
64
65%description
66GStreamer is a streaming media framework, based on graphs of elements which
67operate on media data.
68
69This package contains plug-ins that have licensing issues, aren't tested
70well enough, or the code is not of good enough quality.
71
72
73# %package extras
74# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
75# Group: Applications/Multimedia
76# Requires: %{name} = %{version}-%{release}
77
78# %description extras
79# GStreamer is a streaming media framework, based on graphs of elements which
80# operate on media data.
81
82# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
83# tested well enough, or the code is not of good enough quality.
84
85# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
86# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
87# very much and require additional libraries to be installed.
88
89
90%prep
91%setup -q -n gst-plugins-bad-%{version}
92
93%build
94%configure \
95        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
96
97# Don't use rpath!
98%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
99%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
100%{__make} %{?_smp_mflags}
101
102
103%install
104%{__rm} -rf %{buildroot}
105%{__make} install DESTDIR="%{buildroot}"
106
107# Clean out files that should not be part of the rpm.
108%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
109%{__rm} -f %{buildroot}%{_libdir}/*.la
110
111# conflict with gstreamer1-plugins-bad
112%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
113%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
114%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
115%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
116%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstadpcmdec.so
117%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstadpcmenc.so
118%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstasfmux.so
119%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstaudiovisualizers.so
120%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstautoconvert.so
121%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstbayer.so
122%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstbz2.so
123%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstcamerabin2.so
124%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstcoloreffects.so
125%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdataurisrc.so
126%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdebugutilsbad.so
127%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdtmf.so
128%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstdvb.so
129%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfestival.so
130%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfragmented.so
131%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstfrei0r.so
132%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgaudieffects.so
133%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgdp.so
134%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgeometrictransform.so
135%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
136%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstid3tag.so
137%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstinter.so
138%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstinterlace.so
139%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstjpegformat.so
140%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstliveadder.so
141%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegpsdemux.so
142%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegtsdemux.so
143%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstmpegtsmux.so
144%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstpcapparse.so
145%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstpnm.so
146%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrawparse.so
147%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstremovesilence.so
148%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstresindvd.so
149%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrtpmux.so
150%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstrtpvp8.so
151%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstscaletempoplugin.so
152%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsdpelem.so
153%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsegmentclip.so
154%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstshm.so
155%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsmooth.so
156%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstsoundtouch.so
157%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstspeed.so
158%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstvideoparsersbad.so
159%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgsty4mdec.so
160
161%clean
162%{__rm} -rf %{buildroot}
163
164
165%post -p /sbin/ldconfig
166
167%postun -p /sbin/ldconfig
168
169
170%files
171%defattr(-,root,root,-)
172%doc AUTHORS COPYING README REQUIREMENTS
173%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
174%{_libdir}/gstreamer-%{majorminor}/libgstcelt.so
175%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
176%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
177%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
178%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
179%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
180%{_libdir}/gstreamer-%{majorminor}/libgstfieldanalysis.so
181%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
182%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
183%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
184%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
185%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
186%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
187%{_libdir}/gstreamer-%{majorminor}/libgstsubenc.so
188
189
190%changelog
191* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
192- new upstream release
193- rename package
194
195* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
196- new upstream release
197- added BuildRequires: libvpx-devel
198
199* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
200- s/self-build-libdvdnav/libdvdnav/
201
202* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
203- new upstream release
204- added BuildRequires:
205  - libmms-devel
206  - librtmp-devel
207
208* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
209- new upstream release
210
211* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
212- new upstream release
213
214* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
215- new upstream release
216- added BuildRequires: libvdpau-devel
217
218* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
219- new upstream release
220
221* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
222- new upstream release
223- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
224  gst-plugins-bad-0.10.5-mms-seek.patch
225
226* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
227- new upstream release
228- dropped devel and devel-docs subpackages
229
230* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
231- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
232- changed to BuildRequires:  self-build-faad2 from faad2-devel
233
234* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
235- initial build based on RPM Fusion package
236
237* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
238- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
239
240* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
241- Rebuild for new x264 (using patch from Rathann)
242
243* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
244- New upstream release 0.10.9
245- Rebuild for new directfb
246
247* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
248- Rebuild for new x264 and to generate new magic gstreamer provides
249
250* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
251- Enable DVD navigation plugin
252
253* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
254- Release bump to keep rpmfusion version higher then livna
255
256* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
257- New upstream release 0.10.8
258- Merge changes from latest freshrpms package: enable ofa and dirac plugins
259
260* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
261- Rebuild for new x264
262
263* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
264- New upstream release 0.10.7
265- Drop many upstreamed patches
266
267* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
268- Rebuild for new x264
269
270* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
271- Enable dc1394 plugin
272
273* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
274- New upstream release 0.10.6-1
275- Drop many upstreamed patches
276- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
277
278* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
279- Fix compilation with gcc 4.3
280
281* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
282- Add flv demuxer from CVS (livna bug 1846)
283
284* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
285- Add patch fixing compilation with mjpegtools 1.9.0rc3
286
287* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
288- Add patch from upstream vcs which makes mms honor your connection speed
289  settings
290- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
291
292* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
293- Rebuild for new faad2
294
295* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
296- Rebuild for new libdca
297
298* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
299- Rebuild for new (old) faad2 (livna bug 1679)
300
301* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
302- Update mythtvsrc code to CVS version (livna bug 1660)
303
304* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
305- No libgstreal.so on ppc / ppc64
306
307* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
308- Fix detection of libdts with current livna libtds, this might need to be
309  changed back again for rpmfusion, depending on how libdts will look there
310
311* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
312- Add mythtvsrc plugin (livna 1646)
313- Put some less often used plugins, which bring in also usually not installed
314  deps in a -extras package
315
316* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
317- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
318- Set release to 4 to be higher as both livna and freshrpms latest release
319- Set package name and origin to rpmfusion
320- Make mpeg2enc plugin compile with current mjpegtools
321- Make the real plugins search for the RealPlayer .so files in various
322  known possible locations instead of using only one hardcoded path to them
323- Make the wildmidi plugin work with the default Fedora timidity patch set
324- Add a couple of missing modtracker mimetypes to the modplug plugin
325- Use the system version of libmodplug
326- Fix building of the neonsrc plugin with the latest (rawhide) neon
327- Disable the ladspa plugin as this has been added to Fedora's rawhide
328  gstreamer-plugins-good
329- Don't put an rpath in the .so's on x86_64
330- Re-enable gtk-doc now that we have a -devel package again
331- Enable libtimidity plugin
332- Fix detection of (and linking with) libdca for the dtsdec plugin
333
334* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
335- Update to 0.10.5.
336- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
337- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
338- Enable new nas, x264, wildmidi and libsndfile plugins.
339- Re-add devel package now that we have a main shared lib and header files.
340- Add check build requirement.
341
342* Wed Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
343- Update to 0.10.4 for F7.
344- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
345  somewhat more, maybe then it'll be worth re-enabling.
346- Re-enable wavpack, it works again now.
347- Enable libcdaudio support.
348- Enable jack support.
349- Enable ladspa support.
350- Enable mpeg2enc (mjpegtools) support.
351- Remove no longer present libgstvideo4linux2.so and add all new plugins.
352- Remove all gtk-doc references (all gone...?) and devel package too.
353
354* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
355- Update faad2 patch to also update the plugin sources, not just configure.
356
357* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
358- Try to rebuild against new wavpack 4.40 from Extras : Fails.
359- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
360- Try to include patch to update wavpack plugin source from 0.10.3.2
361  pre-release : Fails to find wavpack/md5.h.
362- Give up and disable wavpack support for now, sorry! Patches welcome.
363- Include patch to fix faad2 2.5 detection.
364- Add soundtouch support.
365
366* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
367- Update to 0.10.3.
368- Add new translations.
369- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
370- Add new libmusicbrainz support.
371
372* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
373- Add libmms support, thanks to Daniel S. Rogers.
374
375* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
376- Update to 0.10.1.
377- Add libgstcdxaparse.so and libgstfreeze.so.
378- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
379
380* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
381- Update to 0.10.0.1, add new plugins.
382- Spec file cleanup and rebuild for FC5.
383
384* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
385- 0.10.0-0.gst.1
386- new release
387
388* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
389- 0.9.7-0.gst.1
390- new release with 0.10 major/minor
391
392* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
393- new release
394- remove tta patch
395- don't check for languages, no translations yet
396- added gtk-doc
397
398* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
399- 0.9.4-0.gst.1
400- new release
401- added speed plugin
402
403* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
404- 0.9.3-0.gst.1
405- new release
406
Note: See TracBrowser for help on using the repository browser.