source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 10717

Revision 10717, 16.8 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.8.2
5%define gstpb_minver 1.8.2
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Summary(ja): GStreamer ストリーミングメディアフレームワーク用 bad プラグイン集
9Name: gstreamer1-plugins-bad
10Version: 1.8.2
11Release: 1%{?_dist_release}
12# The freeze and nfs plugins are LGPLv2 (only)
13License: LGPLv2+
14Group: System Environment/Libraries
15URL: http://gstreamer.freedesktop.org/
16Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires: %{gstreamer} >= %{gst_minver}
19BuildRequires: %{gstreamer}-devel >= %{gst_minver}
20BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
21BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
22
23BuildRequires: check
24BuildRequires: gettext
25BuildRequires: PyXML
26BuildRequires: libXt-devel
27
28BuildRequires: bzip2-devel
29BuildRequires: celt-devel
30BuildRequires: exempi-devel
31BuildRequires: jasper-devel
32#BuildRequires: ladspa-devel
33BuildRequires: libass-devel
34BuildRequires: libdc1394-devel
35BuildRequires: libdvdnav-devel
36BuildRequires: libexif-devel
37#BuildRequires: libiptcdata-devel
38BuildRequires: kate-devel
39BuildRequires: libmodplug-devel
40BuildRequires: libmpcdec-devel
41#BuildRequires: libofa-devel
42BuildRequires: librsvg2-devel
43BuildRequires: libsndfile-devel
44#BuildRequires: libtimidity-devel
45BuildRequires: libvpx-devel
46BuildRequires: mesa-libGLU-devel
47BuildRequires: openssl-devel
48BuildRequires: orc-devel
49#BuildRequires: schroedinger-devel
50BuildRequires: SDL-devel
51#BuildRequires: slv2-devel
52BuildRequires: soundtouch-devel
53BuildRequires: wavpack-devel
54#BuildRequires: wildmidi-devel
55#BuildRequires: zbar-devel
56BuildRequires: libmms-devel
57BuildRequires: twolame-devel
58#BuildRequires: libmimic-devel
59
60# self build
61#BuildRequires: libdca-devel
62#BuildRequires: faad2-devel
63#BuildRequires: xvidcore-devel
64#BuildRequires: mjpegtools-devel
65
66
67%description
68GStreamer is a streaming media framework, based on graphs of elements which
69operate on media data.
70
71This package contains plug-ins that have licensing issues, aren't tested
72well enough, or the code is not of good enough quality.
73
74
75# %package extras
76# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
77# Group: Applications/Multimedia
78# Requires: %{name} = %{version}-%{release}
79
80# %description extras
81# GStreamer is a streaming media framework, based on graphs of elements which
82# operate on media data.
83
84# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
85# tested well enough, or the code is not of good enough quality.
86
87# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
88# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
89# very much and require additional libraries to be installed.
90
91
92%prep
93%setup -q -n gst-plugins-bad-%{version}
94
95%build
96%configure \
97        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
98
99# Don't use rpath!
100%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
101%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
102%{__make} %{?_smp_mflags}
103
104
105%install
106%{__rm} -rf %{buildroot}
107%{__make} install DESTDIR="%{buildroot}"
108
109# Clean out files that should not be part of the rpm.
110%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
111%{__rm} -f %{buildroot}%{_libdir}/*.la
112
113# conflict with gstreamer1-plugins-bad
114%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
116%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h
117%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
118%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
119%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
120
121REMOVE_MODULE_LIST=" \
122        libgstadpcmdec.so \
123        libgstadpcmenc.so \
124        libgstasfmux.so \
125        libgstaudiomixer.so \
126        libgstaudiovisualizers.so \
127        libgstautoconvert.so \
128        libgstbayer.so \
129        libgstbz2.so \
130        libgstcamerabin2.so \
131        libgstcoloreffects.so \
132        libgstcompositor.so \
133        libgstdataurisrc.so \
134        libgstdebugutilsbad.so \
135        libgstdtmf.so \
136        libgstdvb.so \
137        libgstfestival.so \
138        libgstfieldanalysis.so \
139        libgstfragmented.so \
140        libgstfrei0r.so \
141        libgstgaudieffects.so \
142        libgstgdp.so \
143        libgstgeometrictransform.so \
144        libgstgsm.so \
145        libgstid3tag.so \
146        libgstinter.so \
147        libgstinterlace.so \
148        libgstivfparse.so \
149        libgstjp2kdecimator.so \
150        libgstjpegformat.so \
151        libgstliveadder.so \
152        libgstmpegpsdemux.so \
153        libgstmpegtsdemux.so \
154        libgstmpegpsmux.so \
155        libgstmpegtsmux.so \
156        libgstmidi.so \
157        libgstneonhttpsrc.so \
158        libgstopengl.so \
159        libgstpcapparse.so \
160        libgstpnm.so \
161        libgstrawparse.so \
162        libgstremovesilence.so \
163        libgstresindvd.so \
164        libgstrfbsrc.so \
165        libgstrtpmux.so \
166        libgstrtpvp8.so \
167        libgstscaletempoplugin.so \
168        libgstsdpelem.so \
169        libgstsegmentclip.so \
170        libgstshm.so \
171        libgstsmooth.so \
172        libgstsndfile.so \
173        libgstsoundtouch.so \
174        libgstspeed.so \
175        libgststereo.so \
176        libgstsubenc.so \
177        libgsty4mdec.so \
178        libgstaccurip.so \
179        libgstaiff.so \
180        libgstaudiofxbad \
181        libgstfreeverb.so \
182        libgstivtc.so \
183        libgstmfc.so \
184        libgstmxf.so \
185        libgstrsvg.so \
186        libgstvideofiltersbad.so \
187        libgstvideoparsersbad.so \
188        libgstvideosignal.so \
189        libgstvmnc.so \
190        libgstaudiofxbad.so \
191        libgstyadif.so \
192        libgstdtls.so \
193        libgstrtpbad.so \
194        libgstrtponvif.so \
195        libgstvcdsrc.so \
196    libgsthls.so \
197    libgstnetsim.so \
198    libgstvideoframe_audiolevel.so"
199
200for file in $REMOVE_MODULE_LIST; do
201        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
202done
203
204%clean
205%{__rm} -rf %{buildroot}
206
207
208%post -p /sbin/ldconfig
209
210%postun -p /sbin/ldconfig
211
212
213%files
214%defattr(-,root,root,-)
215%doc AUTHORS COPYING README REQUIREMENTS
216%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
217%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
218%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
219%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
220%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
221%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
222%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
223%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
224%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
225%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
226%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
227%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
228%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
229%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
230%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
231%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
232%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
233%{_libdir}/gstreamer-%{majorminor}/libgstx265.so
234
235
236%changelog
237* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
238- new upstream release
239
240* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
241- new upstream release
242
243* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
244- new upstream release
245
246* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-3
247- rebuild with gnutls-3.4.7
248
249* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-2
250- rebuild with nettle-3.1.1
251
252* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
253- new upstream release
254
255* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
256- new upstream release
257
258* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-2
259- changed Group to System Environment/Libraries
260
261* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
262- new upstream release
263
264* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
265- new upstream release
266
267* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
268- new upstream release
269
270* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
271- new upstream release
272
273* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
274- new upstream release
275
276* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
277- new upstream release
278
279* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
280- new upstream release
281
282* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
283- new upstream release
284
285* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
286- new upstream release
287
288* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
289- new upstream release
290
291* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
292- new upstream release
293
294* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
295- new upstream release
296
297* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
298- new upstream release
299
300* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
301- new upstream release
302
303* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
304- new upstream release
305
306* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
307- new upstream release
308- rename package
309
310* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
311- new upstream release
312- added BuildRequires: libvpx-devel
313
314* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
315- s/self-build-libdvdnav/libdvdnav/
316
317* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
318- new upstream release
319- added BuildRequires:
320  - libmms-devel
321  - librtmp-devel
322
323* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
324- new upstream release
325
326* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
327- new upstream release
328
329* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
330- new upstream release
331- added BuildRequires: libvdpau-devel
332
333* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
334- new upstream release
335
336* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
337- new upstream release
338- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
339  gst-plugins-bad-0.10.5-mms-seek.patch
340
341* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
342- new upstream release
343- dropped devel and devel-docs subpackages
344
345* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
346- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
347- changed to BuildRequires:  self-build-faad2 from faad2-devel
348
349* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
350- initial build based on RPM Fusion package
351
352* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
353- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
354
355* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
356- Rebuild for new x264 (using patch from Rathann)
357
358* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
359- New upstream release 0.10.9
360- Rebuild for new directfb
361
362* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
363- Rebuild for new x264 and to generate new magic gstreamer provides
364
365* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
366- Enable DVD navigation plugin
367
368* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
369- Release bump to keep rpmfusion version higher then livna
370
371* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
372- New upstream release 0.10.8
373- Merge changes from latest freshrpms package: enable ofa and dirac plugins
374
375* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
376- Rebuild for new x264
377
378* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
379- New upstream release 0.10.7
380- Drop many upstreamed patches
381
382* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
383- Rebuild for new x264
384
385* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
386- Enable dc1394 plugin
387
388* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
389- New upstream release 0.10.6-1
390- Drop many upstreamed patches
391- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
392
393* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
394- Fix compilation with gcc 4.3
395
396* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
397- Add flv demuxer from CVS (livna bug 1846)
398
399* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
400- Add patch fixing compilation with mjpegtools 1.9.0rc3
401
402* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
403- Add patch from upstream vcs which makes mms honor your connection speed
404  settings
405- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
406
407* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
408- Rebuild for new faad2
409
410* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
411- Rebuild for new libdca
412
413* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
414- Rebuild for new (old) faad2 (livna bug 1679)
415
416* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
417- Update mythtvsrc code to CVS version (livna bug 1660)
418
419* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
420- No libgstreal.so on ppc / ppc64
421
422* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
423- Fix detection of libdts with current livna libtds, this might need to be
424  changed back again for rpmfusion, depending on how libdts will look there
425
426* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
427- Add mythtvsrc plugin (livna 1646)
428- Put some less often used plugins, which bring in also usually not installed
429  deps in a -extras package
430
431* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
432- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
433- Set release to 4 to be higher as both livna and freshrpms latest release
434- Set package name and origin to rpmfusion
435- Make mpeg2enc plugin compile with current mjpegtools
436- Make the real plugins search for the RealPlayer .so files in various
437  known possible locations instead of using only one hardcoded path to them
438- Make the wildmidi plugin work with the default Fedora timidity patch set
439- Add a couple of missing modtracker mimetypes to the modplug plugin
440- Use the system version of libmodplug
441- Fix building of the neonsrc plugin with the latest (rawhide) neon
442- Disable the ladspa plugin as this has been added to Fedora's rawhide
443  gstreamer-plugins-good
444- Don't put an rpath in the .so's on x86_64
445- Re-enable gtk-doc now that we have a -devel package again
446- Enable libtimidity plugin
447- Fix detection of (and linking with) libdca for the dtsdec plugin
448
449* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
450- Update to 0.10.5.
451- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
452- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
453- Enable new nas, x264, wildmidi and libsndfile plugins.
454- Re-add devel package now that we have a main shared lib and header files.
455- Add check build requirement.
456
457* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
458- Update to 0.10.4 for F7.
459- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
460  somewhat more, maybe then it'll be worth re-enabling.
461- Re-enable wavpack, it works again now.
462- Enable libcdaudio support.
463- Enable jack support.
464- Enable ladspa support.
465- Enable mpeg2enc (mjpegtools) support.
466- Remove no longer present libgstvideo4linux2.so and add all new plugins.
467- Remove all gtk-doc references (all gone...?) and devel package too.
468
469* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
470- Update faad2 patch to also update the plugin sources, not just configure.
471
472* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
473- Try to rebuild against new wavpack 4.40 from Extras : Fails.
474- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
475- Try to include patch to update wavpack plugin source from 0.10.3.2
476  pre-release : Fails to find wavpack/md5.h.
477- Give up and disable wavpack support for now, sorry! Patches welcome.
478- Include patch to fix faad2 2.5 detection.
479- Add soundtouch support.
480
481* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
482- Update to 0.10.3.
483- Add new translations.
484- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
485- Add new libmusicbrainz support.
486
487* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
488- Add libmms support, thanks to Daniel S. Rogers.
489
490* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
491- Update to 0.10.1.
492- Add libgstcdxaparse.so and libgstfreeze.so.
493- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
494
495* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
496- Update to 0.10.0.1, add new plugins.
497- Spec file cleanup and rebuild for FC5.
498
499* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
500- 0.10.0-0.gst.1
501- new release
502
503* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
504- 0.9.7-0.gst.1
505- new release with 0.10 major/minor
506
507* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
508- new release
509- remove tta patch
510- don't check for languages, no translations yet
511- added gtk-doc
512
513* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
514- 0.9.4-0.gst.1
515- new release
516- added speed plugin
517
518* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
519- 0.9.3-0.gst.1
520- new release
521
Note: See TracBrowser for help on using the repository browser.