source: projects/specs/trunk/nonfree/self-build-gstreamer1-plugins-bad/gstreamer1-plugins-bad-vl.spec @ 9986

Revision 9986, 16.6 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define majorminor   1.0
2%define gstreamer    gstreamer1
3
4%define gst_minver   1.6.3
5%define gstpb_minver 1.6.3
6
7Summary: GStreamer streaming media framework "bad" plug-ins
8Summary(ja): GStreamer ストリーミングメディアフレームワーク用 bad プラグイン集
9Name: gstreamer1-plugins-bad
10Version: 1.6.3
11Release: 1%{?_dist_release}
12# The freeze and nfs plugins are LGPLv2 (only)
13License: LGPLv2+
14Group: System Environment/Libraries
15URL: http://gstreamer.freedesktop.org/
16Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires: %{gstreamer} >= %{gst_minver}
19BuildRequires: %{gstreamer}-devel >= %{gst_minver}
20BuildRequires: %{gstreamer}-plugins-base-devel >= %{gstpb_minver}
21BuildRequires: %{gstreamer}-plugins-bad-free-devel >= %{gstpb_minver}
22
23BuildRequires: check
24BuildRequires: gettext
25BuildRequires: PyXML
26BuildRequires: libXt-devel
27
28BuildRequires: bzip2-devel
29BuildRequires: celt-devel
30BuildRequires: exempi-devel
31BuildRequires: jasper-devel
32#BuildRequires: ladspa-devel
33BuildRequires: libass-devel
34BuildRequires: libdc1394-devel
35BuildRequires: libdvdnav-devel
36BuildRequires: libexif-devel
37#BuildRequires: libiptcdata-devel
38BuildRequires: kate-devel
39BuildRequires: libmodplug-devel
40BuildRequires: libmpcdec-devel
41#BuildRequires: libofa-devel
42BuildRequires: librsvg2-devel
43BuildRequires: libsndfile-devel
44#BuildRequires: libtimidity-devel
45BuildRequires: libvpx-devel
46BuildRequires: mesa-libGLU-devel
47BuildRequires: openssl-devel
48BuildRequires: orc-devel
49#BuildRequires: schroedinger-devel
50BuildRequires: SDL-devel
51#BuildRequires: slv2-devel
52BuildRequires: soundtouch-devel
53BuildRequires: wavpack-devel
54#BuildRequires: wildmidi-devel
55#BuildRequires: zbar-devel
56BuildRequires: libmms-devel
57BuildRequires: twolame-devel
58#BuildRequires: libmimic-devel
59
60# self build
61#BuildRequires: libdca-devel
62#BuildRequires: faad2-devel
63#BuildRequires: xvidcore-devel
64#BuildRequires: mjpegtools-devel
65
66
67%description
68GStreamer is a streaming media framework, based on graphs of elements which
69operate on media data.
70
71This package contains plug-ins that have licensing issues, aren't tested
72well enough, or the code is not of good enough quality.
73
74
75# %package extras
76# Summary: Extra GStreamer "bad" plugins (less often used "bad" plugins)
77# Group: Applications/Multimedia
78# Requires: %{name} = %{version}-%{release}
79
80# %description extras
81# GStreamer is a streaming media framework, based on graphs of elements which
82# operate on media data.
83
84# gstreamer1-plugins-bad contains plug-ins that have licensing issues, aren't
85# tested well enough, or the code is not of good enough quality.
86
87# This package (gstreamer1-plugins-bad-extras) contains extra "bad" plugins for
88# sources (mythtv), sinks (jack, nas) and effects (pitch) which are not used
89# very much and require additional libraries to be installed.
90
91
92%prep
93%setup -q -n gst-plugins-bad-%{version}
94
95%build
96%configure \
97        --enable-debug --disable-static --disable-gtk-doc --enable-experimental
98
99# Don't use rpath!
100%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
101%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
102%{__make} %{?_smp_mflags}
103
104
105%install
106%{__rm} -rf %{buildroot}
107%{__make} install DESTDIR="%{buildroot}"
108
109# Clean out files that should not be part of the rpm.
110%{__rm} -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
111%{__rm} -f %{buildroot}%{_libdir}/*.la
112
113# conflict with gstreamer1-plugins-bad
114%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.so*
115%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/girepository-1.0
116%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h
117%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
118%{__rm} -rf $RPM_BUILD_ROOT%{_includedir}
119%{__rm} -rf $RPM_BUILD_ROOT%{_datadir}
120
121REMOVE_MODULE_LIST=" \
122        libgstadpcmdec.so \
123        libgstadpcmenc.so \
124        libgstasfmux.so \
125        libgstaudiomixer.so \
126        libgstaudiovisualizers.so \
127        libgstautoconvert.so \
128        libgstbayer.so \
129        libgstbz2.so \
130        libgstcamerabin2.so \
131        libgstcoloreffects.so \
132        libgstcompositor.so \
133        libgstdataurisrc.so \
134        libgstdebugutilsbad.so \
135        libgstdtmf.so \
136        libgstdvb.so \
137        libgstfestival.so \
138        libgstfieldanalysis.so \
139        libgstfragmented.so \
140        libgstfrei0r.so \
141        libgstgaudieffects.so \
142        libgstgdp.so \
143        libgstgeometrictransform.so \
144        libgstgsm.so \
145        libgstid3tag.so \
146        libgstinter.so \
147        libgstinterlace.so \
148        libgstivfparse.so \
149        libgstjp2kdecimator.so \
150        libgstjpegformat.so \
151        libgstliveadder.so \
152        libgstmpegpsdemux.so \
153        libgstmpegtsdemux.so \
154        libgstmpegpsmux.so \
155        libgstmpegtsmux.so \
156        libgstmidi.so \
157        libgstneonhttpsrc.so \
158        libgstopengl.so \
159        libgstpcapparse.so \
160        libgstpnm.so \
161        libgstrawparse.so \
162        libgstremovesilence.so \
163        libgstresindvd.so \
164        libgstrfbsrc.so \
165        libgstrtpmux.so \
166        libgstrtpvp8.so \
167        libgstscaletempoplugin.so \
168        libgstsdpelem.so \
169        libgstsegmentclip.so \
170        libgstshm.so \
171        libgstsmooth.so \
172        libgstsndfile.so \
173        libgstsoundtouch.so \
174        libgstspeed.so \
175        libgststereo.so \
176        libgstsubenc.so \
177        libgsty4mdec.so \
178        libgstaccurip.so \
179        libgstaiff.so \
180        libgstaudiofxbad \
181        libgstfreeverb.so \
182        libgstivtc.so \
183        libgstmfc.so \
184        libgstmxf.so \
185        libgstrsvg.so \
186        libgstvideofiltersbad.so \
187        libgstvideoparsersbad.so \
188        libgstvideosignal.so \
189        libgstvmnc.so \
190        libgstaudiofxbad.so \
191        libgstyadif.so \
192        libgstdtls.so \
193        libgstrtpbad.so \
194        libgstrtponvif.so \
195        libgstvcdsrc.so"
196
197for file in $REMOVE_MODULE_LIST; do
198        rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/$file
199done
200
201%clean
202%{__rm} -rf %{buildroot}
203
204
205%post -p /sbin/ldconfig
206
207%postun -p /sbin/ldconfig
208
209
210%files
211%defattr(-,root,root,-)
212%doc AUTHORS COPYING README REQUIREMENTS
213%{_libdir}/gstreamer-%{majorminor}/libgstassrender.so
214%{_libdir}/gstreamer-%{majorminor}/libgstdecklink.so
215%{_libdir}/gstreamer-%{majorminor}/libgstdtsdec.so
216%{_libdir}/gstreamer-%{majorminor}/libgstdvbsuboverlay.so
217%{_libdir}/gstreamer-%{majorminor}/libgstdvdspu.so
218%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
219%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
220%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
221%{_libdir}/gstreamer-%{majorminor}/libgstmodplug.so
222%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2enc.so
223%{_libdir}/gstreamer-%{majorminor}/libgstmplex.so
224%{_libdir}/gstreamer-%{majorminor}/libgstopenal.so
225%{_libdir}/gstreamer-%{majorminor}/libgstrtmp.so
226%{_libdir}/gstreamer-%{majorminor}/libgstsiren.so
227%{_libdir}/gstreamer-%{majorminor}/libgstdashdemux.so
228%{_libdir}/gstreamer-%{majorminor}/libgstfbdevsink.so
229%{_libdir}/gstreamer-%{majorminor}/libgstsmoothstreaming.so
230%{_libdir}/gstreamer-%{majorminor}/libgstvdpau.so
231%{_libdir}/gstreamer-%{majorminor}/libgstx265.so
232
233
234%changelog
235* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
236- new upstream release
237
238* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-3
239- rebuild with gnutls-3.4.7
240
241* Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-2
242- rebuild with nettle-3.1.1
243
244* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
245- new upstream release
246
247* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
248- new upstream release
249
250* Wed Mar 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-2
251- changed Group to System Environment/Libraries
252
253* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
254- new upstream release
255
256* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
257- new upstream release
258
259* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
260- new upstream release
261
262* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
263- new upstream release
264
265* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
266- new upstream release
267
268* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
269- new upstream release
270
271* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
272- new upstream release
273
274* Sun Oct 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
275- new upstream release
276
277* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
278- new upstream release
279
280* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
281- new upstream release
282
283* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
284- new upstream release
285
286* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
287- new upstream release
288
289* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
290- new upstream release
291
292* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
293- new upstream release
294
295* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
296- new upstream release
297
298* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
299- new upstream release
300- rename package
301
302* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.22-1
303- new upstream release
304- added BuildRequires: libvpx-devel
305
306* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-2
307- s/self-build-libdvdnav/libdvdnav/
308
309* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.21-1
310- new upstream release
311- added BuildRequires:
312  - libmms-devel
313  - librtmp-devel
314
315* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.20-1
316- new upstream release
317
318* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
319- new upstream release
320
321* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
322- new upstream release
323- added BuildRequires: libvdpau-devel
324
325* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
326- new upstream release
327
328* Wed May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.12-1
329- new upstream release
330- dropped gstreamer-plugins-bad-0.10.5-sys-modplug.patch,
331  gst-plugins-bad-0.10.5-mms-seek.patch
332
333* Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
334- new upstream release
335- dropped devel and devel-docs subpackages
336
337* Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-2
338- rebuild with twolame-devel, libmpcdec-devel, mjpegtools-devel
339- changed to BuildRequires:  self-build-faad2 from faad2-devel
340
341* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.9-1
342- initial build based on RPM Fusion package
343
344* Sat Dec 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-3
345- Put devel docs in seperate subpackage to avoid multilib conflict (rf 276)
346
347* Wed Dec 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-2
348- Rebuild for new x264 (using patch from Rathann)
349
350* Sun Oct 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.9-1
351- New upstream release 0.10.9
352- Rebuild for new directfb
353
354* Sun Sep 14 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-4
355- Rebuild for new x264 and to generate new magic gstreamer provides
356
357* Sat Aug 16 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-3
358- Enable DVD navigation plugin
359
360* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-2
361- Release bump to keep rpmfusion version higher then livna
362
363* Fri Aug  1 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.8-1
364- New upstream release 0.10.8
365- Merge changes from latest freshrpms package: enable ofa and dirac plugins
366
367* Fri Jun 27 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-2
368- Rebuild for new x264
369
370* Thu Apr 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.7-1
371- New upstream release 0.10.7
372- Drop many upstreamed patches
373
374* Sun Mar  9 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-3
375- Rebuild for new x264
376
377* Tue Feb 26 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-2
378- Enable dc1394 plugin
379
380* Sun Feb 24 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.6-1
381- New upstream release 0.10.6-1
382- Drop many upstreamed patches
383- Fixes conflict with the latest gstreamer-plugins-good (livna 1884)
384
385* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-15
386- Fix compilation with gcc 4.3
387
388* Tue Feb  5 2008  Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-14
389- Add flv demuxer from CVS (livna bug 1846)
390
391* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-13
392- Add patch fixing compilation with mjpegtools 1.9.0rc3
393
394* Sun Dec  9 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-12
395- Add patch from upstream vcs which makes mms honor your connection speed
396  settings
397- Add (painstakingly self written) patch adding support for mms / mmsh seeking!
398
399* Tue Nov 13 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-11
400- Rebuild for new faad2
401
402* Sun Nov  4 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-10
403- Rebuild for new libdca
404
405* Thu Oct 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-9
406- Rebuild for new (old) faad2 (livna bug 1679)
407
408* Sat Sep 29 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-8
409- Update mythtvsrc code to CVS version (livna bug 1660)
410
411* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-7
412- No libgstreal.so on ppc / ppc64
413
414* Thu Sep 27 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-6
415- Fix detection of libdts with current livna libtds, this might need to be
416  changed back again for rpmfusion, depending on how libdts will look there
417
418* Sat Sep 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-5
419- Add mythtvsrc plugin (livna 1646)
420- Put some less often used plugins, which bring in also usually not installed
421  deps in a -extras package
422
423* Sat Sep 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.5-4
424- Merge livna spec bugfixes into freshrpms spec for rpmfusion:
425- Set release to 4 to be higher as both livna and freshrpms latest release
426- Set package name and origin to rpmfusion
427- Make mpeg2enc plugin compile with current mjpegtools
428- Make the real plugins search for the RealPlayer .so files in various
429  known possible locations instead of using only one hardcoded path to them
430- Make the wildmidi plugin work with the default Fedora timidity patch set
431- Add a couple of missing modtracker mimetypes to the modplug plugin
432- Use the system version of libmodplug
433- Fix building of the neonsrc plugin with the latest (rawhide) neon
434- Disable the ladspa plugin as this has been added to Fedora's rawhide
435  gstreamer-plugins-good
436- Don't put an rpath in the .so's on x86_64
437- Re-enable gtk-doc now that we have a -devel package again
438- Enable libtimidity plugin
439- Fix detection of (and linking with) libdca for the dtsdec plugin
440
441* Tue Aug 21 2007 Matthias Saou <http://freshrpms.net/> 0.10.5-1
442- Update to 0.10.5.
443- Update faad2 patch : Some fixes went in, but faad2.h still produces an error.
444- Remove libgstqtdemux, libgstvideocrop and libgstwavpack, all are in good now.
445- Enable new nas, x264, wildmidi and libsndfile plugins.
446- Re-add devel package now that we have a main shared lib and header files.
447- Add check build requirement.
448
449* Fri Mar 30 2007 Matthias Saou <http://freshrpms.net/> 0.10.4-1
450- Update to 0.10.4 for F7.
451- Disable swfdec... does anything/anyone even use it here? Once it stabilizes
452  somewhat more, maybe then it'll be worth re-enabling.
453- Re-enable wavpack, it works again now.
454- Enable libcdaudio support.
455- Enable jack support.
456- Enable ladspa support.
457- Enable mpeg2enc (mjpegtools) support.
458- Remove no longer present libgstvideo4linux2.so and add all new plugins.
459- Remove all gtk-doc references (all gone...?) and devel package too.
460
461* Tue Jan  9 2007 Matthias Saou <http://freshrpms.net/> 0.10.3-3
462- Update faad2 patch to also update the plugin sources, not just configure.
463
464* Mon Dec 18 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-2
465- Try to rebuild against new wavpack 4.40 from Extras : Fails.
466- Try to update to 0.10.3.2 pre-release : Fails, it needs a more recent gst.
467- Try to include patch to update wavpack plugin source from 0.10.3.2
468  pre-release : Fails to find wavpack/md5.h.
469- Give up and disable wavpack support for now, sorry! Patches welcome.
470- Include patch to fix faad2 2.5 detection.
471- Add soundtouch support.
472
473* Thu Jun  1 2006 Matthias Saou <http://freshrpms.net/> 0.10.3-1
474- Update to 0.10.3.
475- Add new translations.
476- Add libgstmodplug.so, libgstvideo4linux2.so and libgstxingheader.so.
477- Add new libmusicbrainz support.
478
479* Thu Mar 23 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-2
480- Add libmms support, thanks to Daniel S. Rogers.
481
482* Wed Feb 22 2006 Matthias Saou <http://freshrpms.net/> 0.10.1-1
483- Update to 0.10.1.
484- Add libgstcdxaparse.so and libgstfreeze.so.
485- Enable libgstbz2.so, libgstglimagesink.so and libgstneonhttpsrc.so.
486
487* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 0.10.0.1-1
488- Update to 0.10.0.1, add new plugins.
489- Spec file cleanup and rebuild for FC5.
490
491* Mon Dec 05 2005 Thomas Vander Stichele <thomas at apestaart dot org>
492- 0.10.0-0.gst.1
493- new release
494
495* Thu Dec 01 2005 Thomas Vander Stichele <thomas at apestaart dot org>
496- 0.9.7-0.gst.1
497- new release with 0.10 major/minor
498
499* Sat Nov 12 2005 Thomas Vander Stichele <thomas at apestaart dot org>
500- new release
501- remove tta patch
502- don't check for languages, no translations yet
503- added gtk-doc
504
505* Wed Oct 26 2005 Thomas Vander Stichele <thomas at apestaart dot org>
506- 0.9.4-0.gst.1
507- new release
508- added speed plugin
509
510* Mon Oct 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
511- 0.9.3-0.gst.1
512- new release
513
Note: See TracBrowser for help on using the repository browser.