source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec @ 615

Revision 615, 5.9 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname gstreamer-plugins-ugly
2%define _gst_ver        0.10.14
3%define _gstpb_ver      0.10.3
4%define release 1%{?_dist_release}
5
6%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{_gst_ver}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           self-build-%{pkgname}
11Version:        %{_gst_ver}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source101:      gstreamer-plugins-ugly-x264.patch
15License:        LGPL
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
22Requires(post):         self-build-ffmpeg
23Requires(post):         gstreamer-devel >= %{_gst_ver}
24Requires(post):         gstreamer-plugins-base-devel >= %{_gstpb_ver}
25#Requires(post):                gtk-doc >= 1.3
26Requires(post):         python >= 2.1, python-pyxml
27Requires(post):         glib2-devel >= 2.6
28Requires(post):         liboil-devel >= 0.3.0
29Requires(post):         self-build-libmad >= 0.15
30Requires(post):         libid3tag-devel >= 0.15
31Requires(post):         self-build-libmpeg2
32Requires(post):         self-build-a52dec
33Requires(post):         self-build-lame
34
35BuildArch:      noarch
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37
38Packager:       munepi
39
40%description
41gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
42streaming-media framework.
43
44If you install this package, it automaticaly downloads source
45code, compile it, and create rpm packages of
46%{pkgname}-%{version}.
47And the created rpm packages are automatically installed
48if installation is executed by apt-get command or synaptic
49package manager.
50
51
52[Note]
53This package requires many other packages to compile
54targetsoftware. So it consume more disk space than usual.
55Also installation takes logner time because of compilation.
56(This will take a few minutes to quarter or half of an hour,
57depends on building environment)
58
59[About self-build package]
60For some kind of software, distributing of binary package
61may viorate the patent or law. Therefore we chose self-build
62packge, create binary package on your machine, for such kind
63of softwares instead of distributing binary package.
64
65Please obey the national law when you use the created binary
66packages. And if you want to use the softwares using patented
67thechnology, it may be required to get a permission, make an
68agreement or purchas a license. Please consider it with your
69purpose or way of use and take appropriate action.
70
71%description -l ja
72gstreamer-plugins-ugly は GStreamer ストリーミングメディア
73フレームワーク用 ugly プラグイン集です。
74
75このパッケージをインストールすると、自動的にソースコードを
76ダウンロードしてコンパイルし、%{pkgname}-%{version}
77の rpm パッケージを作成します。
78また apt-get コマンドや synaptic パッケージマネージャから実行
79した場合は、作成された rpm パッケージのインストールも自動的に
80行います。
81
82
83[注意]
84コンパイルに必要な多くの関連パッケージを要求するので通常より
85ディスクの領域を多く消費します。
86またインストール時にコンパイルを行うため、通常より時間がかか
87る場合があります。(環境にもよりますが数分から数十分程度)
88
89[self-build パッケージについて]
90ソフトウェアによってはバイナリパッケージの配布が特許や法律に
91違反する可能性があるものがあります。その為、このような問題が
92懸念されるソフトウェアについてはバイナリパッケージを直接配布
93せずに、ユーザの環境でバイナリを作成する self-build パッケー
94ジという方法を採っています。
95
96作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
97アのライセンス、および利用する国の各種法令に従ってください。
98また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
99センスの購入などが必要となる場合がありますので、利用する目的
100や形態に応じて各自で判断し適切な対応を取ってください。
101
102
103%prep
104[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
105
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
110%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
111%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117%posttrans
118/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 35000
119
120%files
121%defattr(-,root,root)
122%{_datadir}/%{name}
123
124%changelog
125* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
126- new upstream relase
127- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
128
129* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
130- new upstream relase
131
132* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
133- new upstream relase
134- added Requires(post): self-build-libmpeg2
135  - enable mpeg2dec with libmpeg2-devel in %%configure
136- check version between original spec and self-build spec in %%prep
137
138* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
139- avoided to execute self-build-rpm.sh on RPM transaction
140  - moved %%post actions to %%posttrans
141
142* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
143- added BuildArch: noarch
144- dropped PreReq: gtk-doc >= 1.3
145
146* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
147- new upstream relase
148
149* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
150- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
151
152* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
153- new upstream relase
154
155* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
156- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.