source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec @ 1258

Revision 1258, 6.2 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define pkgname gstreamer-plugins-ugly
2%define _gst_ver        0.10.15
3%define _gstpb_ver      0.10.3
4%define release 1%{?_dist_release}
5
6%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{_gst_ver}.tar.bz2
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           self-build-%{pkgname}
11Version:        %{_gst_ver}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source101:      gstreamer-plugins-ugly-x264.patch
15License:        LGPL
16Group:          Restricted Software
17
18Requires(post):         self-build-setup >= 0.9.9
19
20# (build)requies of target package.
21Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
22Requires(post):         gstreamer-devel >= %{_gst_ver}
23Requires(post):         gstreamer-plugins-base-devel >= %{_gstpb_ver}
24#Requires(post):                gtk-doc >= 1.3
25Requires(post):         python >= 2.1, python-pyxml
26Requires(post):         glib2-devel >= 2.6
27Requires(post):         twolame-devel
28Requires(post):         liboil-devel >= 0.3.0
29Requires(post):         libcdio-devel >= 0.82
30Requires(post):         libdvdread-devel
31Requires(post):         PyXML
32Requires(post):         self-build-libmad >= 0.15
33Requires(post):         libid3tag-devel >= 0.15
34Requires(post):         self-build-ffmpeg
35Requires(post):         self-build-x264
36Requires(post):         self-build-libmpeg2
37Requires(post):         self-build-a52dec
38Requires(post):         self-build-lame
39Requires(post):         self-build-libmad
40
41
42BuildArch:      noarch
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44
45Packager:       munepi
46
47%description
48gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
49streaming-media framework.
50
51If you install this package, it automaticaly downloads source
52code, compile it, and create rpm packages of
53%{pkgname}-%{version}.
54And the created rpm packages are automatically installed
55if installation is executed by apt-get command or synaptic
56package manager.
57
58
59[Note]
60This package requires many other packages to compile
61targetsoftware. So it consume more disk space than usual.
62Also installation takes logner time because of compilation.
63(This will take a few minutes to quarter or half of an hour,
64depends on building environment)
65
66[About self-build package]
67For some kind of software, distributing of binary package
68may viorate the patent or law. Therefore we chose self-build
69packge, create binary package on your machine, for such kind
70of softwares instead of distributing binary package.
71
72Please obey the national law when you use the created binary
73packages. And if you want to use the softwares using patented
74thechnology, it may be required to get a permission, make an
75agreement or purchas a license. Please consider it with your
76purpose or way of use and take appropriate action.
77
78%description -l ja
79gstreamer-plugins-ugly は GStreamer ストリーミングメディア
80フレームワーク用 ugly プラグイン集です。
81
82このパッケージをインストールすると、自動的にソースコードを
83ダウンロードしてコンパイルし、%{pkgname}-%{version}
84の rpm パッケージを作成します。
85また apt-get コマンドや synaptic パッケージマネージャから実行
86した場合は、作成された rpm パッケージのインストールも自動的に
87行います。
88
89
90[注意]
91コンパイルに必要な多くの関連パッケージを要求するので通常より
92ディスクの領域を多く消費します。
93またインストール時にコンパイルを行うため、通常より時間がかか
94る場合があります。(環境にもよりますが数分から数十分程度)
95
96[self-build パッケージについて]
97ソフトウェアによってはバイナリパッケージの配布が特許や法律に
98違反する可能性があるものがあります。その為、このような問題が
99懸念されるソフトウェアについてはバイナリパッケージを直接配布
100せずに、ユーザの環境でバイナリを作成する self-build パッケー
101ジという方法を採っています。
102
103作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
104アのライセンス、および利用する国の各種法令に従ってください。
105また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
106センスの購入などが必要となる場合がありますので、利用する目的
107や形態に応じて各自で判断し適切な対応を取ってください。
108
109
110%prep
111[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
112
113
114%install
115%{__rm} -rf ${RPM_BUILD_ROOT}
116%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
117%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
118%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
119
120
121%clean
122%{__rm} -rf ${RPM_BUILD_ROOT}
123
124%posttrans
125/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 81000
126
127%files
128%defattr(-,root,root)
129%{_datadir}/%{name}
130
131%changelog
132* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
133- new upstream relase
134
135* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
136- new upstream relase
137- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
138
139* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
140- new upstream relase
141
142* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
143- new upstream relase
144- added Requires(post): self-build-libmpeg2
145  - enable mpeg2dec with libmpeg2-devel in %%configure
146- check version between original spec and self-build spec in %%prep
147
148* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
149- avoided to execute self-build-rpm.sh on RPM transaction
150  - moved %%post actions to %%posttrans
151
152* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
153- added BuildArch: noarch
154- dropped PreReq: gtk-doc >= 1.3
155
156* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
157- new upstream relase
158
159* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
160- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
161
162* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
163- new upstream relase
164
165* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
166- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.