source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/self-build-gstreamer-plugins-ugly-vl.spec @ 10524

Revision 10524, 7.0 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1%define pkgname gstreamer-plugins-ugly
2%define major           0.10
3%define _gst_ver        0.10.26
4%define _gstpb_ver      0.10.26
5%define version 0.10.19
6%define release 3%{?_dist_release}
7
8%define sourceurl       http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
9
10Summary:        Package to automatically build %{pkgname} rpm package
11Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
12Name:           self-build-%{pkgname}
13Version:        %{version}
14Release:        %{release}
15Source0:        %{pkgname}-vl.spec
16Source101:      gstreamer-plugins-ugly-x264.patch
17Source102:      gstreamer-plugins-ugly-libcdio-0.92.patch
18License:        LGPLv2+
19Group:          Restricted Software
20
21Requires(post):         self-build-setup >= 0.9.9
22
23# (build)requies of target package.
24Requires(post):         libogg-devel, libtheora-devel, libvorbis-devel
25Requires(post):         gstreamer-devel >= %{_gst_ver}
26Requires(post):         gstreamer-plugins-base-devel >= %{_gstpb_ver}
27#Requires(post):                gtk-doc >= 1.3
28Requires(post):         python >= 2.1, python-pyxml
29Requires(post):         glib2-devel >= 2.6
30Requires(post):         twolame-devel
31Requires(post):         liboil-devel >= 0.3.0
32Requires(post):         libcdio-devel >= 0.82
33Requires(post):         libdvdread-devel
34Requires(post):         PyXML
35Requires(post):         self-build-libmad >= 0.15
36Requires(post):         libid3tag-devel >= 0.15
37Requires(post):         self-build-ffmpeg
38Requires(post):         self-build-x264
39Requires(post):         self-build-libmpeg2
40Requires(post):         self-build-a52dec
41Requires(post):         self-build-lame
42Requires(post):         self-build-libmad
43
44
45BuildArch:      noarch
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48Packager:       munepi
49
50%description
51gstreamer-plugins-ugly is a set of ugly plugins for Gstreamer
52streaming-media framework.
53
54If you install this package, it automaticaly downloads source
55code, compile it, and create rpm packages of
56%{pkgname}-%{version}.
57And the created rpm packages are automatically installed
58if installation is executed by apt-get command or synaptic
59package manager.
60
61
62[Note]
63This package requires many other packages to compile
64targetsoftware. So it consume more disk space than usual.
65Also installation takes logner time because of compilation.
66(This will take a few minutes to quarter or half of an hour,
67depends on building environment)
68
69[About self-build package]
70For some kind of software, distributing of binary package
71may viorate the patent or law. Therefore we chose self-build
72packge, create binary package on your machine, for such kind
73of softwares instead of distributing binary package.
74
75Please obey the national law when you use the created binary
76packages. And if you want to use the softwares using patented
77thechnology, it may be required to get a permission, make an
78agreement or purchas a license. Please consider it with your
79purpose or way of use and take appropriate action.
80
81%description -l ja
82gstreamer-plugins-ugly は GStreamer ストリーミングメディア
83フレームワーク用 ugly プラグイン集です。
84
85このパッケージをインストールすると、自動的にソースコードを
86ダウンロードしてコンパイルし、%{pkgname}-%{version}
87の rpm パッケージを作成します。
88また apt-get コマンドや synaptic パッケージマネージャから実行
89した場合は、作成された rpm パッケージのインストールも自動的に
90行います。
91
92
93[注意]
94コンパイルに必要な多くの関連パッケージを要求するので通常より
95ディスクの領域を多く消費します。
96またインストール時にコンパイルを行うため、通常より時間がかか
97る場合があります。(環境にもよりますが数分から数十分程度)
98
99[self-build パッケージについて]
100ソフトウェアによってはバイナリパッケージの配布が特許や法律に
101違反する可能性があるものがあります。その為、このような問題が
102懸念されるソフトウェアについてはバイナリパッケージを直接配布
103せずに、ユーザの環境でバイナリを作成する self-build パッケー
104ジという方法を採っています。
105
106作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
107アのライセンス、および利用する国の各種法令に従ってください。
108また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
109センスの購入などが必要となる場合がありますので、利用する目的
110や形態に応じて各自で判断し適切な対応を取ってください。
111
112
113%prep
114[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
115
116
117%install
118%{__rm} -rf ${RPM_BUILD_ROOT}
119%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
120%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
121%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
122%{__install} -m 644 %{SOURCE102} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
123
124
125%clean
126%{__rm} -rf ${RPM_BUILD_ROOT}
127
128%posttrans
129/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
130
131%files
132%defattr(-,root,root)
133%{_datadir}/%{name}
134
135%changelog
136* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-3
137- rebuild with libcdio-0.93
138
139* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-2
140- rebuild with libcdio-0.92
141- add Source102 (gstreamer-plugins-ugly-libcdio-0.92.patch)
142
143* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
144- new upstream relase
145
146* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
147- new upstream relase
148- built with new x264
149- License: LGPLv2+
150
151* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
152- new upstream relase
153
154* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
155- new upstream relase
156
157* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
158- new upstream relase
159
160* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
161- new upstream relase
162- renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
163
164* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
165- new upstream relase
166
167* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
168- new upstream relase
169- added Requires(post): self-build-libmpeg2
170  - enable mpeg2dec with libmpeg2-devel in %%configure
171- check version between original spec and self-build spec in %%prep
172
173* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
174- avoided to execute self-build-rpm.sh on RPM transaction
175  - moved %%post actions to %%posttrans
176
177* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
178- added BuildArch: noarch
179- dropped PreReq: gtk-doc >= 1.3
180
181* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
182- new upstream relase
183
184* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
185- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
186
187* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
188- new upstream relase
189
190* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
191- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.