source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 615

Revision 615, 10.7 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.14
5%define _gstpb_ver      0.10.3
6%define pkg_release     1%{?_dist_release}
7
8Summary:        GStreamer Streaming-media framework ugly plugins
9Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
10Name:           gstreamer-plugins-ugly
11Version:        %{_gst_ver}
12Release:        %{pkg_release}
13License:        LGPL
14Group:          System Environment/Libraries
15URL:            http://gstreamer.freedesktop.org/
16Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gstreamer >= %{_gst_ver}
20Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
21Requires:       glib2
22Requires:       libid3tag
23# Don't require libmad because they are provided by
24# self-build-libmad packages.
25#Requires:      libmad
26
27BuildRequires:  gstreamer-devel >= %{_gst_ver}
28BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
29#BuildRequires: gtk-doc >= 1.3
30BuildRequires:  python >= 2.1, python-pyxml
31BuildRequires:  glib2-devel >= 2.6
32BuildRequires:  liboil-devel >= 0.3.0
33BuildRequires:  libid3tag-devel >= 0.15
34
35# *-devel packages provided by other self-build-* should only be listed
36# in self-build-%{name}.spec as PreReq.
37##BuildRequires:        x264-devel
38##BuildRequires:        libmpeg2-devel
39##BuildRequires:        a52dec-devel
40##BuildRequires:        lame-devel
41##BuildRequires:        libmad-devel >= 0.15
42
43Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
44
45%description
46GStreamer is a streaming-media framework, based on graphs of filters which
47operate on media data. Applications using this library can do anything
48from real-time sound processing to playing videos, and just about anything
49else media-related.  Its plugin-based architecture means that new data
50types or processing capabilities can be added simply by installing new
51plugins.
52
53This package contains a set of plug-ins that have good quality and
54correct functionality, but distributing them might pose problems. The
55license on either the plug-ins or the supporting libraries might not
56be how the GStreamer authors like. The code might be widely known to
57present patent problems.
58
59%description -l ja
60GStreamer はメディアデータ操作用の filter graph をベースにしたスト
61リーミングメディアフレームワークです。 このライブラリを使用すれば
62アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
63メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
64イン方式を採用していることから、新しい種類のデータや機能への対応が、
65プラグインを追加することで簡単に実現できます。
66
67このパッケージは品質も機能も問題は無いものの、配布すると問題になる
68可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
69ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
70関連するコードとして良く知られています。
71
72# %package devel
73# Summary:      Documentation files for GStreamer ugly plugins.
74# Summary(ja):  GStreamer ugly プラグインのドキュメント
75# Group:                Development/Libraries
76# Requires:     %{name} = %{version}-%{release}
77
78# %description devel
79# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
80# リーミングメディアフレームワークです。 このライブラリを使用すれば
81# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
82# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
83# イン方式を採用していることから、新しい種類のデータや機能への対応が、
84# プラグインを追加することで簡単に実現できます。
85
86# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
87
88
89%prep
90%setup -q -n gst-plugins-ugly-%{version}
91
92
93%build
94%configure \
95    --disable-static \
96    --disable-amrnb \
97    --disable-sidplay \
98
99%__make %{?_smp_mflags}
100
101%install
102%__rm -rf %{buildroot}
103%makeinstall
104
105# Clean out files that should not be part of the rpm.
106%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
107%__rm -f %{buildroot}%{_libdir}/*.{a,la}
108
109%find_lang gst-plugins-ugly-%{major}
110
111%clean
112%__rm -rf %{buildroot}
113
114
115%files -f gst-plugins-ugly-%{major}.lang
116%defattr(-,root,root)
117%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
118%{_datadir}/gstreamer-%{major}/presets
119# ugly plugins without external dependencies
120%{_libdir}/gstreamer-%{major}
121
122# ugly plugins with external dependencies, but in the main package
123# %{_libdir}/gstreamer-%{major}/libgstmad.so
124
125# %files devel
126# %defattr(-,root,root)
127# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
128
129
130%changelog
131* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
132- new upstream relase
133
134* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
135- new upstream relase
136
137* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
138- new upstream relase
139- enable mpeg2dec with libmpeg2-devel in %%configure
140
141* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
142- change release to sync with self-build-gstreamer-plugins-ugly
143
144* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
145- dropped BuildRequires: gtk-doc >= 1.3
146  - disable-gtk-doc in configure options
147  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
148
149* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
150- new upstream relase
151
152* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
153- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
154
155* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
156- new upstream relase
157
158* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
159- upstream release
160- delete --disable-a52dec configure option
161- delete %%with_lame macro
162- added japanase summary and description
163
164* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
165- upstream release
166- update %%_gst_ver
167
168* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
169- add NoSource: 0
170
171* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
172- add %%with_lame macro
173  - enable lame support if rpmbuild with '--with lame'
174
175* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
176- upstream release
177
178* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
179- upstream release
180- add libgstdvdsub.so
181
182* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
183- upstream release
184- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
185- add libgstasf.so
186
187* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
188- fix typo
189
190* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
191- initial package based on gstreamer-plugins
192- new upstream release
193  - change major to 0.10
194- update dependencies
195- update %%configure options
196
197* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
198- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
199
200* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
201- added missing alsa plugin
202
203* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
204- new upstream release
205- added alsa and cairo plugins
206
207* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
208- new upstream release
209
210* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
211- new upstream release
212
213* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
214- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
215
216* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
217- added libgstcdparania.so for gnome-cd (gnome-media)
218- BuildRequires: cdparanoia-devel
219
220* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
221- drop BuildRequires: xmms-devel, Requires: xmms
222
223* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
224- libgstvideo4linux2.so temoporally omitted for ppc
225  (will be back later, I hope)
226
227* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
228- new upstream release
229- s/Copyright/License/
230- includes plugins depend on main package libraries only
231
232* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
233- new upstream release
234
235* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
236- new upstream release
237
238* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
239- new upstream release
240
241* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
242- new upstream release
243
244* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
245- build with -fPIC on alpha
246
247* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
248- modified scripts
249
250* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
251- new upstream release
252
253* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
254- disable some plugins.
255
256* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
257- new upstream release
258- initial build for Vine Linux
259
260* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
261- Include ia64
262- Add BuildRequires: autoconf automake
263
264* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
265- rebuild
266
267* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
268- rebuild
269
270* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
271- rebuild
272- disable tests
273
274* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
275- rebuild
276
277* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
278- fix libdir for ia64.
279
280* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
281- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
282- Add devel package
283
284* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
285- 0.5.0
286- apparently, festival-devel isn't needed.
287
288* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
289- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
290
291* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
292- excludearch the arches that can't build gstreamer cothreads
293- well it isn't really SMP-safe
294- add patch for including pthread.h when required
295- prereq gconftool
296- fix typo that broke schema installation in post
297
298* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
299- initial "official" import
300- munge tarball for legal cleanliness
301
302* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
303- 0.4.2
304
305* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
306- 0.4.1
307- install the gconf schema
308- use %%configure
309
310* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
311- update to 0.4.0
312- give explicit vorbis include path, don't run vorbis test
313
314* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
315- collapse into one package to preserve some sanity
316
317* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
318- added more BuildRequires and Requires
319- rearranged some plugins
320- added changelog ;)
Note: See TracBrowser for help on using the repository browser.