source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 1817

Revision 1817, 11.0 KB checked in by munepi, 14 years ago (diff)

updated self-build-gstreamer-plugins-ugly

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.16
5%define _gstpb_ver      0.10.3
6%define pkg_release     1%{?_dist_release}
7
8Summary:        GStreamer Streaming-media framework ugly plugins
9Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
10Name:           gstreamer-plugins-ugly
11Version:        %{_gst_ver}
12Release:        %{pkg_release}
13License:        LGPLv2+
14Group:          System Environment/Libraries
15URL:            http://gstreamer.freedesktop.org/
16Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gstreamer >= %{_gst_ver}
20Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
21Requires:       glib2
22Requires:       libid3tag
23# Don't require libmad because they are provided by
24# self-build-libmad packages.
25#Requires:      libmad
26
27BuildRequires:  gstreamer-devel >= %{_gst_ver}
28BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
29#BuildRequires: gtk-doc >= 1.3
30BuildRequires:  python >= 2.1, python-pyxml
31BuildRequires:  glib2-devel >= 2.6
32BuildRequires:  twolame-devel
33BuildRequires:  libid3tag-devel >= 0.15
34BuildRequires:  liboil-devel >= 0.3.0
35BuildRequires:  libcdio-devel >= 0.82
36BuildRequires:  libdvdread-devel
37BuildRequires:  PyXML
38
39# *-devel packages provided by other self-build-* should only be listed
40# in self-build-%{name}.spec as PreReq.
41##BuildRequires:        x264-devel
42##BuildRequires:        libmpeg2-devel
43##BuildRequires:        a52dec-devel
44##BuildRequires:        lame-devel
45##BuildRequires:        libmad-devel >= 0.15
46
47Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
48
49%description
50GStreamer is a streaming-media framework, based on graphs of filters which
51operate on media data. Applications using this library can do anything
52from real-time sound processing to playing videos, and just about anything
53else media-related.  Its plugin-based architecture means that new data
54types or processing capabilities can be added simply by installing new
55plugins.
56
57This package contains a set of plug-ins that have good quality and
58correct functionality, but distributing them might pose problems. The
59license on either the plug-ins or the supporting libraries might not
60be how the GStreamer authors like. The code might be widely known to
61present patent problems.
62
63%description -l ja
64GStreamer はメディアデータ操作用の filter graph をベースにしたスト
65リーミングメディアフレームワークです。 このライブラリを使用すれば
66アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
67メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
68イン方式を採用していることから、新しい種類のデータや機能への対応が、
69プラグインを追加することで簡単に実現できます。
70
71このパッケージは品質も機能も問題は無いものの、配布すると問題になる
72可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
73ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
74関連するコードとして良く知られています。
75
76# %package devel
77# Summary:      Documentation files for GStreamer ugly plugins.
78# Summary(ja):  GStreamer ugly プラグインのドキュメント
79# Group:                Development/Libraries
80# Requires:     %{name} = %{version}-%{release}
81
82# %description devel
83# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
84# リーミングメディアフレームワークです。 このライブラリを使用すれば
85# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
86# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
87# イン方式を採用していることから、新しい種類のデータや機能への対応が、
88# プラグインを追加することで簡単に実現できます。
89
90# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
91
92
93%prep
94%setup -q -n gst-plugins-ugly-%{version}
95
96
97%build
98%configure \
99    --disable-static \
100    --disable-amrnb \
101    --disable-sidplay \
102
103%__make %{?_smp_mflags}
104
105%install
106%__rm -rf %{buildroot}
107%makeinstall
108
109# Clean out files that should not be part of the rpm.
110%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
111%__rm -f %{buildroot}%{_libdir}/*.{a,la}
112
113%find_lang gst-plugins-ugly-%{major}
114
115%clean
116%__rm -rf %{buildroot}
117
118
119%files -f gst-plugins-ugly-%{major}.lang
120%defattr(-,root,root)
121%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
122%{_datadir}/gstreamer-%{major}/presets
123# ugly plugins without external dependencies
124%{_libdir}/gstreamer-%{major}/*.so
125
126# ugly plugins with external dependencies, but in the main package
127# %{_libdir}/gstreamer-%{major}/libgstmad.so
128
129# %files devel
130# %defattr(-,root,root)
131# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
132
133
134%changelog
135* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
136- new upstream relase
137
138* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
139- new upstream relase
140
141* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
142- new upstream relase
143
144* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
145- new upstream relase
146
147* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
148- new upstream relase
149- enable mpeg2dec with libmpeg2-devel in %%configure
150
151* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
152- change release to sync with self-build-gstreamer-plugins-ugly
153
154* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
155- dropped BuildRequires: gtk-doc >= 1.3
156  - disable-gtk-doc in configure options
157  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
158
159* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
160- new upstream relase
161
162* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
163- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
164
165* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
166- new upstream relase
167
168* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
169- upstream release
170- delete --disable-a52dec configure option
171- delete %%with_lame macro
172- added japanase summary and description
173
174* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
175- upstream release
176- update %%_gst_ver
177
178* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
179- add NoSource: 0
180
181* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
182- add %%with_lame macro
183  - enable lame support if rpmbuild with '--with lame'
184
185* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
186- upstream release
187
188* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
189- upstream release
190- add libgstdvdsub.so
191
192* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
193- upstream release
194- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
195- add libgstasf.so
196
197* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
198- fix typo
199
200* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
201- initial package based on gstreamer-plugins
202- new upstream release
203  - change major to 0.10
204- update dependencies
205- update %%configure options
206
207* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
208- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
209
210* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
211- added missing alsa plugin
212
213* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
214- new upstream release
215- added alsa and cairo plugins
216
217* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
218- new upstream release
219
220* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
221- new upstream release
222
223* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
224- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
225
226* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
227- added libgstcdparania.so for gnome-cd (gnome-media)
228- BuildRequires: cdparanoia-devel
229
230* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
231- drop BuildRequires: xmms-devel, Requires: xmms
232
233* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
234- libgstvideo4linux2.so temoporally omitted for ppc
235  (will be back later, I hope)
236
237* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
238- new upstream release
239- s/Copyright/License/
240- includes plugins depend on main package libraries only
241
242* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
243- new upstream release
244
245* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
246- new upstream release
247
248* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
249- new upstream release
250
251* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
252- new upstream release
253
254* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
255- build with -fPIC on alpha
256
257* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
258- modified scripts
259
260* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
261- new upstream release
262
263* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
264- disable some plugins.
265
266* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
267- new upstream release
268- initial build for Vine Linux
269
270* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
271- Include ia64
272- Add BuildRequires: autoconf automake
273
274* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
275- rebuild
276
277* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
278- rebuild
279
280* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
281- rebuild
282- disable tests
283
284* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
285- rebuild
286
287* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
288- fix libdir for ia64.
289
290* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
291- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
292- Add devel package
293
294* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
295- 0.5.0
296- apparently, festival-devel isn't needed.
297
298* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
299- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
300
301* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
302- excludearch the arches that can't build gstreamer cothreads
303- well it isn't really SMP-safe
304- add patch for including pthread.h when required
305- prereq gconftool
306- fix typo that broke schema installation in post
307
308* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
309- initial "official" import
310- munge tarball for legal cleanliness
311
312* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
313- 0.4.2
314
315* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
316- 0.4.1
317- install the gconf schema
318- use %%configure
319
320* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
321- update to 0.4.0
322- give explicit vorbis include path, don't run vorbis test
323
324* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
325- collapse into one package to preserve some sanity
326
327* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
328- added more BuildRequires and Requires
329- rearranged some plugins
330- added changelog ;)
Note: See TracBrowser for help on using the repository browser.