source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 1258

Revision 1258, 10.9 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.15
5%define _gstpb_ver      0.10.3
6%define pkg_release     1%{?_dist_release}
7
8Summary:        GStreamer Streaming-media framework ugly plugins
9Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
10Name:           gstreamer-plugins-ugly
11Version:        %{_gst_ver}
12Release:        %{pkg_release}
13License:        LGPL
14Group:          System Environment/Libraries
15URL:            http://gstreamer.freedesktop.org/
16Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gstreamer >= %{_gst_ver}
20Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
21Requires:       glib2
22Requires:       libid3tag
23# Don't require libmad because they are provided by
24# self-build-libmad packages.
25#Requires:      libmad
26
27BuildRequires:  gstreamer-devel >= %{_gst_ver}
28BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
29#BuildRequires: gtk-doc >= 1.3
30BuildRequires:  python >= 2.1, python-pyxml
31BuildRequires:  glib2-devel >= 2.6
32BuildRequires:  twolame-devel
33BuildRequires:  libid3tag-devel >= 0.15
34BuildRequires:  liboil-devel >= 0.3.0
35BuildRequires:  libcdio-devel >= 0.82
36BuildRequires:  libdvdread-devel
37BuildRequires:  PyXML
38
39# *-devel packages provided by other self-build-* should only be listed
40# in self-build-%{name}.spec as PreReq.
41##BuildRequires:        x264-devel
42##BuildRequires:        libmpeg2-devel
43##BuildRequires:        a52dec-devel
44##BuildRequires:        lame-devel
45##BuildRequires:        libmad-devel >= 0.15
46
47Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
48
49%description
50GStreamer is a streaming-media framework, based on graphs of filters which
51operate on media data. Applications using this library can do anything
52from real-time sound processing to playing videos, and just about anything
53else media-related.  Its plugin-based architecture means that new data
54types or processing capabilities can be added simply by installing new
55plugins.
56
57This package contains a set of plug-ins that have good quality and
58correct functionality, but distributing them might pose problems. The
59license on either the plug-ins or the supporting libraries might not
60be how the GStreamer authors like. The code might be widely known to
61present patent problems.
62
63%description -l ja
64GStreamer はメディアデータ操作用の filter graph をベースにしたスト
65リーミングメディアフレームワークです。 このライブラリを使用すれば
66アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
67メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
68イン方式を採用していることから、新しい種類のデータや機能への対応が、
69プラグインを追加することで簡単に実現できます。
70
71このパッケージは品質も機能も問題は無いものの、配布すると問題になる
72可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
73ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
74関連するコードとして良く知られています。
75
76# %package devel
77# Summary:      Documentation files for GStreamer ugly plugins.
78# Summary(ja):  GStreamer ugly プラグインのドキュメント
79# Group:                Development/Libraries
80# Requires:     %{name} = %{version}-%{release}
81
82# %description devel
83# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
84# リーミングメディアフレームワークです。 このライブラリを使用すれば
85# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
86# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
87# イン方式を採用していることから、新しい種類のデータや機能への対応が、
88# プラグインを追加することで簡単に実現できます。
89
90# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
91
92
93%prep
94%setup -q -n gst-plugins-ugly-%{version}
95
96
97%build
98%configure \
99    --disable-static \
100    --disable-amrnb \
101    --disable-sidplay \
102
103%__make %{?_smp_mflags}
104
105%install
106%__rm -rf %{buildroot}
107%makeinstall
108
109# Clean out files that should not be part of the rpm.
110%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
111%__rm -f %{buildroot}%{_libdir}/*.{a,la}
112
113%find_lang gst-plugins-ugly-%{major}
114
115%clean
116%__rm -rf %{buildroot}
117
118
119%files -f gst-plugins-ugly-%{major}.lang
120%defattr(-,root,root)
121%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
122%{_datadir}/gstreamer-%{major}/presets
123# ugly plugins without external dependencies
124%{_libdir}/gstreamer-%{major}/*.so
125
126# ugly plugins with external dependencies, but in the main package
127# %{_libdir}/gstreamer-%{major}/libgstmad.so
128
129# %files devel
130# %defattr(-,root,root)
131# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
132
133
134%changelog
135* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
136- new upstream relase
137
138* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
139- new upstream relase
140
141* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
142- new upstream relase
143
144* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
145- new upstream relase
146- enable mpeg2dec with libmpeg2-devel in %%configure
147
148* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
149- change release to sync with self-build-gstreamer-plugins-ugly
150
151* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
152- dropped BuildRequires: gtk-doc >= 1.3
153  - disable-gtk-doc in configure options
154  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
155
156* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
157- new upstream relase
158
159* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
160- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
161
162* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
163- new upstream relase
164
165* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
166- upstream release
167- delete --disable-a52dec configure option
168- delete %%with_lame macro
169- added japanase summary and description
170
171* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
172- upstream release
173- update %%_gst_ver
174
175* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
176- add NoSource: 0
177
178* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
179- add %%with_lame macro
180  - enable lame support if rpmbuild with '--with lame'
181
182* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
183- upstream release
184
185* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
186- upstream release
187- add libgstdvdsub.so
188
189* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
190- upstream release
191- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
192- add libgstasf.so
193
194* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
195- fix typo
196
197* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
198- initial package based on gstreamer-plugins
199- new upstream release
200  - change major to 0.10
201- update dependencies
202- update %%configure options
203
204* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
205- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
206
207* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
208- added missing alsa plugin
209
210* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
211- new upstream release
212- added alsa and cairo plugins
213
214* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
215- new upstream release
216
217* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
218- new upstream release
219
220* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
221- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
222
223* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
224- added libgstcdparania.so for gnome-cd (gnome-media)
225- BuildRequires: cdparanoia-devel
226
227* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
228- drop BuildRequires: xmms-devel, Requires: xmms
229
230* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
231- libgstvideo4linux2.so temoporally omitted for ppc
232  (will be back later, I hope)
233
234* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
235- new upstream release
236- s/Copyright/License/
237- includes plugins depend on main package libraries only
238
239* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
240- new upstream release
241
242* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
243- new upstream release
244
245* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
246- new upstream release
247
248* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
249- new upstream release
250
251* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
252- build with -fPIC on alpha
253
254* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
255- modified scripts
256
257* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
258- new upstream release
259
260* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
261- disable some plugins.
262
263* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
264- new upstream release
265- initial build for Vine Linux
266
267* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
268- Include ia64
269- Add BuildRequires: autoconf automake
270
271* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
272- rebuild
273
274* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
275- rebuild
276
277* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
278- rebuild
279- disable tests
280
281* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
282- rebuild
283
284* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
285- fix libdir for ia64.
286
287* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
288- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
289- Add devel package
290
291* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
292- 0.5.0
293- apparently, festival-devel isn't needed.
294
295* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
296- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
297
298* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
299- excludearch the arches that can't build gstreamer cothreads
300- well it isn't really SMP-safe
301- add patch for including pthread.h when required
302- prereq gconftool
303- fix typo that broke schema installation in post
304
305* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
306- initial "official" import
307- munge tarball for legal cleanliness
308
309* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
310- 0.4.2
311
312* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
313- 0.4.1
314- install the gconf schema
315- use %%configure
316
317* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
318- update to 0.4.0
319- give explicit vorbis include path, don't run vorbis test
320
321* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
322- collapse into one package to preserve some sanity
323
324* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
325- added more BuildRequires and Requires
326- rearranged some plugins
327- added changelog ;)
Note: See TracBrowser for help on using the repository browser.