source: projects/specs/trunk/nonfree/self-build-gstreamer-plugins-ugly/gstreamer-plugins-ugly-vl.spec @ 10524

Revision 10524, 11.6 KB checked in by Takemikaduchi, 8 years ago (diff)

glib: add patch
others: rebuild

Line 
1## TODO: build with opencore-amr
2
3%define major           0.10
4%define _gst_ver        0.10.26
5%define _gstpb_ver      0.10.26
6
7Summary:        GStreamer Streaming-media framework ugly plugins
8Summary(ja):    GStreamer ストリーミングメディアフレームワーク用 ugly プラグイン
9Name:           gstreamer-plugins-ugly
10Version:        0.10.19
11Release:        3%{?_dist_release}
12License:        LGPLv2+
13Group:          System Environment/Libraries
14URL:            http://gstreamer.freedesktop.org/
15Source:         http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
16
17Patch2:         gstreamer-plugins-ugly-libcdio-0.92.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21Requires:       gstreamer >= %{_gst_ver}
22Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
23Requires:       glib2
24Requires:       libid3tag
25# Don't require libmad because they are provided by
26# self-build-libmad packages.
27#Requires:      libmad
28
29BuildRequires:  gstreamer-devel >= %{_gst_ver}
30BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
31#BuildRequires: gtk-doc >= 1.3
32BuildRequires:  python >= 2.1, python-pyxml
33BuildRequires:  glib2-devel >= 2.6
34BuildRequires:  twolame-devel
35BuildRequires:  libid3tag-devel >= 0.15
36BuildRequires:  liboil-devel >= 0.3.0
37BuildRequires:  libcdio-devel >= 0.82
38BuildRequires:  libdvdread-devel
39BuildRequires:  PyXML
40
41# *-devel packages provided by other self-build-* should only be listed
42# in self-build-%{name}.spec as PreReq.
43##BuildRequires:        x264-devel
44##BuildRequires:        libmpeg2-devel
45##BuildRequires:        a52dec-devel
46##BuildRequires:        lame-devel
47##BuildRequires:        libmad-devel >= 0.15
48
49Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
50
51%description
52GStreamer is a streaming-media framework, based on graphs of filters which
53operate on media data. Applications using this library can do anything
54from real-time sound processing to playing videos, and just about anything
55else media-related.  Its plugin-based architecture means that new data
56types or processing capabilities can be added simply by installing new
57plugins.
58
59This package contains a set of plug-ins that have good quality and
60correct functionality, but distributing them might pose problems. The
61license on either the plug-ins or the supporting libraries might not
62be how the GStreamer authors like. The code might be widely known to
63present patent problems.
64
65%description -l ja
66GStreamer はメディアデータ操作用の filter graph をベースにしたスト
67リーミングメディアフレームワークです。 このライブラリを使用すれば
68アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
69メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
70イン方式を採用していることから、新しい種類のデータや機能への対応が、
71プラグインを追加することで簡単に実現できます。
72
73このパッケージは品質も機能も問題は無いものの、配布すると問題になる
74可能性があるプラグインを含んでいます。プラグインとそのサポート・ライ
75ブラリのライセンスも Gstreamer とは異なっています。一般には特許に
76関連するコードとして良く知られています。
77
78# %package devel
79# Summary:      Documentation files for GStreamer ugly plugins.
80# Summary(ja):  GStreamer ugly プラグインのドキュメント
81# Group:                Development/Libraries
82# Requires:     %{name} = %{version}-%{release}
83
84# %description devel
85# GStreamer はメディアデータ操作用の filter graph をベースにしたスト
86# リーミングメディアフレームワークです。 このライブラリを使用すれば
87# アプリケーションは、サウンドのリアルタイム処理からビデオ再生まで、
88# メディアに関係する全ての機能が利用できます。また Gstremer はプラグ
89# イン方式を採用していることから、新しい種類のデータや機能への対応が、
90# プラグインを追加することで簡単に実現できます。
91
92# このパッケージは GStreamer ugly 用のドキュメントを含んでいます。
93
94
95%prep
96%setup -q -n gst-plugins-ugly-%{version}
97%patch2 -p1 -b .cdio
98
99%build
100%configure \
101    --disable-static \
102    --disable-amrnb \
103    --disable-sidplay \
104
105%__make %{?_smp_mflags}
106
107%install
108%__rm -rf %{buildroot}
109%makeinstall
110
111# Clean out files that should not be part of the rpm.
112%__rm -f %{buildroot}%{_libdir}/gstreamer-%{major}/*.{a,la}
113%__rm -f %{buildroot}%{_libdir}/*.{a,la}
114
115%find_lang gst-plugins-ugly-%{major}
116
117%clean
118%__rm -rf %{buildroot}
119
120
121%files -f gst-plugins-ugly-%{major}.lang
122%defattr(-,root,root)
123%doc AUTHORS ChangeLog COPYING NEWS README RELEASE REQUIREMENTS
124%{_datadir}/gstreamer-%{major}/presets
125# ugly plugins without external dependencies
126%{_libdir}/gstreamer-%{major}/*.so
127
128# ugly plugins with external dependencies, but in the main package
129# %{_libdir}/gstreamer-%{major}/libgstmad.so
130
131# %files devel
132# %defattr(-,root,root)
133# %{_datadir}/gtk-doc/html/gst-plugins-ugly-plugins-%{major}
134
135
136%changelog
137* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-3
138- rebuild with libcdio-0.93
139
140* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.19-2
141- rebuild with libcdio-0.92
142- add patch2 (gstreamer-plugins-ugly-libcdio-0.92.patch)
143
144* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
145- new upstream relase
146
147* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
148- new upstream relase
149- built with new x264
150- License: LGPLv2+
151
152* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
153- new upstream relase
154
155* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
156- new upstream relase
157
158* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
159- new upstream relase
160
161* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
162- new upstream relase
163
164* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
165- new upstream relase
166
167* Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
168- new upstream relase
169- enable mpeg2dec with libmpeg2-devel in %%configure
170
171* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
172- change release to sync with self-build-gstreamer-plugins-ugly
173
174* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
175- dropped BuildRequires: gtk-doc >= 1.3
176  - disable-gtk-doc in configure options
177  - added Obsoletes: gstreamer-plugins-ugly-devel <= 0.10.11-1vl5
178
179* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
180- new upstream relase
181
182* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
183- changed to PreReq:  self-build-libmad >= 0.15 from libmad-devel
184
185* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
186- new upstream relase
187
188* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10,8-1
189- upstream release
190- delete --disable-a52dec configure option
191- delete %%with_lame macro
192- added japanase summary and description
193
194* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.5-0vl1
195- upstream release
196- update %%_gst_ver
197
198* Sun Nov 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl3
199- add NoSource: 0
200
201* Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl2
202- add %%with_lame macro
203  - enable lame support if rpmbuild with '--with lame'
204
205* Wed Aug 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
206- upstream release
207
208* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
209- upstream release
210- add libgstdvdsub.so
211
212* Fri Feb 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
213- upstream release
214- update %%_gst_ver, %%_gstpb_ver (0.10.1->0.10.3)
215- add libgstasf.so
216
217* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl2
218- fix typo
219
220* Mon Jan 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
221- initial package based on gstreamer-plugins
222- new upstream release
223  - change major to 0.10
224- update dependencies
225- update %%configure options
226
227* Mon Dec 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
228- remove duplicated libgst{idct,qtdemux,xwindowlistener}.so
229
230* Thu Oct 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
231- added missing alsa plugin
232
233* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.11-0vl1
234- new upstream release
235- added alsa and cairo plugins
236
237* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
238- new upstream release
239
240* Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
241- new upstream release
242
243* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl5
244- added Conflicts: gstreamer-plugins-extra-audio < 0.8.8-0vl2
245
246* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl4
247- added libgstcdparania.so for gnome-cd (gnome-media)
248- BuildRequires: cdparanoia-devel
249
250* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.8-0vl3
251- drop BuildRequires: xmms-devel, Requires: xmms
252
253* Tue Mar 29 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.8.8-0vl2
254- libgstvideo4linux2.so temoporally omitted for ppc
255  (will be back later, I hope)
256
257* Sun Mar 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.8-0vl1
258- new upstream release
259- s/Copyright/License/
260- includes plugins depend on main package libraries only
261
262* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.5-0vl1
263- new upstream release
264
265* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
266- new upstream release
267
268* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
269- new upstream release
270
271* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
272- new upstream release
273
274* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl3
275- build with -fPIC on alpha
276
277* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl2
278- modified scripts
279
280* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
281- new upstream release
282
283* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
284- disable some plugins.
285
286* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
287- new upstream release
288- initial build for Vine Linux
289
290* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-15
291- Include ia64
292- Add BuildRequires: autoconf automake
293
294* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
295- rebuild
296
297* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-12
298- rebuild
299
300* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-10
301- rebuild
302- disable tests
303
304* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 0.5.0-9
305- rebuild
306
307* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
308- fix libdir for ia64.
309
310* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-3
311- ExcludeArch: ia64.   Random assembler errors that I have no hope of fixing
312- Add devel package
313
314* Wed Dec 11 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-1
315- 0.5.0
316- apparently, festival-devel isn't needed.
317
318* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 0.4.2-3
319- rebuild to fix broken dep on libgstreamer-0.4.2.so.0
320
321* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
322- excludearch the arches that can't build gstreamer cothreads
323- well it isn't really SMP-safe
324- add patch for including pthread.h when required
325- prereq gconftool
326- fix typo that broke schema installation in post
327
328* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
329- initial "official" import
330- munge tarball for legal cleanliness
331
332* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
333- 0.4.2
334
335* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
336- 0.4.1
337- install the gconf schema
338- use %%configure
339
340* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
341- update to 0.4.0
342- give explicit vorbis include path, don't run vorbis test
343
344* Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
345- collapse into one package to preserve some sanity
346
347* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
348- added more BuildRequires and Requires
349- rearranged some plugins
350- added changelog ;)
Note: See TracBrowser for help on using the repository browser.